PDA

View Full Version : F9 doesnt start



ASUS
5th June 2008, 02:35 AM
First time user of Linux.

AMD Sempron
1G ram
80 G HD
ATi X1300

Trying to have Dual boot with XP and F9.

I tried to install F9 in remaining 20G after all the XP partitions with "custom partitions" several times, all replied" Could not allocate cylinder-based partition". Then I tried "let Linux manage the free space" and F9 is installed successfully.

Restart. Able to load XP from GRUB(Bravo!). Then when I choose to load F9 from GRUB, doesnt work. It went like this,

GRUB starts.......
Choose F9.......Loading........
.
.
.
Then something like" Press I to interactive start...
udev>...................[OK]"
Then screen goes black and halt, monitor goes into energy saving mode.


Anyone able to help? Much appreciation!

JEO
5th June 2008, 05:46 AM
Sounds like you have a video driver problem. Right after udev starts a program called Red Hat Graphical Boot tries to start the X server (rhgb).
So I would disable rhgb for starters, it appears in the /boot/grub/grub.conf file kernel command line, just edit it out.
Another thing to try is renaming the /etc/X11/xorg.conf file to something else and see what happens.
Lastly,. you could change the driver name in that file from whatever it is (probably "radeon") to "vesa" and see if it works that way.

ASUS
6th June 2008, 12:24 PM
I tried the first way, disable rhgb from the kernel line. It got me through the "udev>...."stage that i stuck in early on. But another problem came out, as followed,
Checking File System.......
/:Clean............
fsck.ext3: Unable to resolve UUID=cXXXXXXXXX................[Failed]
Then i was given a shell and required root p/w.

Thank you for your help JEO!
Meanwhile i got myself into another bad place, please see my threadmy thread (http://forums.fedoraforum.org/showthread.php?t=191007)

dan.btown
6th June 2008, 05:27 PM
Hi ASUS,

did you possibly had a USB-Stick, FlashPen or something the like connected to your system while installing / upgrading?

If so, the installing / upgrading procedure will create an entry in your file /etc/fstab pointing to this device and will complain it missing later after you removed it.

Remedy in this case: Visit /etc/fstab and comment out the line that reminds you of the suspected device by typing a number sign ("#") in its first column. The respective line should have something with "UUID" in it.

Cheers,

-- Dan

dan.btown
6th June 2008, 05:32 PM
Btw., in case you don't know how to get to your /etc/fstab when you can't boot into your installation and don't have a rescue media handy:

Download the first CD iso image for F9 and burn it; then boot from the CD-R and choose resuce mode. When asked to try mounting the system partition to /mnt/sysimage, say yes. Then enter chroot /mnt/sysimage at the shell -- You should then be able to use whatever editor you like (and chose to install).

Note: It's not necessary to download the other 5 CD iso images in order to use the rescue mode.

Cheers,

-- Dan

ASUS
9th June 2008, 08:29 AM
Thanks for the tips, Dan. I will try. Finger cross.