PDA

View Full Version : Fedora 9 Slow Sound issue



Carcifier
3rd June 2008, 09:29 PM
I had a Fedora 8 install that was an upgrade from 7 that I erased, mostly, and installed Fedora 9 "clean". I kept my "/home" partition from the previous install.

I tried to clean up my "home directory" by removing as many directories as possible, that contained settings I felt were unnecessary or could cause a conflict with the newer versions of software in Fedora 9. I only kept a few directories or setting files that I thought would be convenient.

I patiently waited for the new Nvidia driver to be released, and when it was I installed it. It was after doing this that I noticed I had an audio problem.

The problem may have existed from the start, but I didn't notice it until I started running 3D accelerated applications. It was when I tested out some games like Enemy Territory: Quake Wars and Quake 4 that it became really clear audio was not syncing properly. I could pull the trigger the gun would fire and a second later the audio for it would occur. Also, some sounds were not playing properly. Some npc voice files sounded "raspy/corrupted, not clear" when played. My frame rate appeared normal however.

I tried WINE and got no sound at all out of one 3D accelerated game. This one worked fine in Fedora 8 and 7.

Up until now I had only been using Rhythmbox, playing Ogg Vorbis tracks and not noticing any audio difficulties. I do think though, they exist. I think music is playing slightly slower than it should. Flash videos appear out of sync too, slow. Also Flash video's appear to be dropping some frames.

It's almost as if when sound is played whether its through Pulse audio or not, I get this effect that is kind of like "losing frame rate". Yet, I don't think I am. I'm just kinda getting a "lagged sound" effect which mimics it. It's difficult to describe. Although, I have to admit Flash video quality may be suffering. I don't think I have any video issues in the games though. I haven't run tests to confirm though.

I deleted my pulse cookies file and my pulse user settings directory to make sure I hadn't carried anything over from my previous install that might be incompatible. That didn't help.

I found an old article via google where someone seemed to have a remotely similar problem in Fedora 8 and part of the solution suggested making sure a couple services were running. One of which I don't think exists in Fedora 9 and the other "AVAHI" was disabled for me. I enabled it, to no effect. I probably disabled Avahi after install, thinking I didn't need it.

Could someone tell me what are the necessary sound services required to be running and any correct settings I need?

Or if you know what's causing my problem, a solution in it's place would sure be fine. :)

My hardware is old, but good enough for what I'm trying to run. I've never had issues running these apps in previous versions of Fedora.

Pentium 4 3.0 Ghz (800 Mhz FSB)
1 GB DDR 400 RAM
Soundblaster Live 5.1
Gigabyte GeForce 7600 GS (256 MB)

Machine has been updated with every bug fix/patch available from the Fedora repositories. I have not added any other repo's, except for Adobe's.

kernel:2.6.25.3-18
nvidia driver: 173.14.05

The only other odd symptom I encounter is sometimes when I try to bring up the Pulse audio Volume Control I get an error message saying it was unable to connect to the server. However, it's intermittent.

Any help appreciated, thanks in advance.

blackdog1012
4th June 2008, 04:12 AM
I have exactly the same problem with Soundblaster Live 5.1 in Fedora 9.

my hardware:

Athlon XP 2500+
1G DDR400 RAM
Geforce Ti 4200
ASUS A7V600 mother board
Soundblaster Live 5.1