PDA

View Full Version : unable to install any packages, plz help~



qwer112233
1st June 2008, 03:12 PM
installing packages

playonlinux-3.0.1.....

When i press apply

Unable to retrieve software information

unable to retrieve software information.This could be caused by not having a network connection available.

Detail:
Cannot retrieve repository metadata (repomd.xml) for repository: acpacks. Please verify its path and try again


Also because of this, i can not use yum neither.....

and same as the Add and Remove software

bob
1st June 2008, 04:37 PM
Have you set up your internet connection properly? Can you surf okay?

qwer112233
1st June 2008, 11:49 PM
The internet connection should be ok, because i am using it.

and Can you surf okay?

wt is that mean????

the package manager is down for a long time~


Also, my internet connection was down for a while, but later I fixed it.

When i try to restore Fedora using the live cd, nothing happen.

put the live cd in and restart it-that is what i did.

thank you

bob
2nd June 2008, 12:25 AM
So...you're trying to install packages from the Live CD? I don't believ that's possible unless you're in VMWare, for instance.

qwer112233
2nd June 2008, 12:42 AM
thanks for reply

but i installed the live cd into the computer for a long time already.

first when i get fedora, everything works perfectly fine...

and now.....

is the respomd.xml or something that i dont know~ noob~

it happens a few day after i installed yum extender.

bob
2nd June 2008, 12:55 AM
Not sure what the problem could be either. Why not open a terminal and sign in as root (su -) followed by 'yum clean all' and then 'yum update'. If still not working, post the results and see if someone can help with what the coding's telling you.

qwer112233
2nd June 2008, 01:08 AM
thanks, but it did not work.....

here is the result

[qwer112233@localhost ~]$ su
Password:
[root@localhost qwer112233]# yum clean all
Cleaning up Everything
[root@localhost qwer112233]# yum update
livna-development 100% |=========================| 2.1 kB 00:00
primary.sqlite.bz2 100% |=========================| 154 kB 00:00
updates-source 100% |=========================| 2.1 kB 00:00
primary.sqlite.bz2 100% |=========================| 706 kB 00:02
livna-development-debugin 100% |=========================| 1.9 kB 00:00
primary.sqlite.bz2 100% |=========================| 51 kB 00:00
updates-testing 100% |=========================| 2.3 kB 00:00
primary.sqlite.bz2 100% |=========================| 397 kB 00:00
livna 100% |=========================| 2.1 kB 00:00
primary.sqlite.bz2 100% |=========================| 383 kB 00:01
updates-testing-source 100% |=========================| 2.1 kB 00:00
primary.sqlite.bz2 100% |=========================| 109 kB 00:00
livna-debuginfo 100% |=========================| 1.9 kB 00:00
primary.sqlite.bz2 100% |=========================| 89 kB 00:00
fedora-debuginfo 100% |=========================| 2.1 kB 00:00
primary.sqlite.bz2 100% |=========================| 1.2 MB 00:01
fedora 100% |=========================| 2.1 kB 00:00
primary.sqlite.bz2 100% |=========================| 4.9 MB 00:05
development-source 100% |=========================| 1.9 kB 00:00
primary.sqlite.bz2 100% |=========================| 1.7 MB 00:04
development 100% |=========================| 2.4 kB 00:00
primary.sqlite.bz2 100% |=========================| 6.4 MB 00:08
updates-debuginfo 100% |=========================| 1.9 kB 00:00
primary.sqlite.bz2 100% |=========================| 720 kB 00:01
http://download.tuxfamily.org/acpacks/7/repodata/repomd.xml: [Errno 14] HTTP Error 404: Not Found
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: acpacks. Please verify its path and try again
[root@localhost qwer112233]#

bob
2nd June 2008, 01:18 AM
Well, there's a NUMBER of things! First, you can use 'yum disablerepo=acpacks update' to bypass the one error. However, you've got a lot of development and testing repos that should NOT be enabled. If you've done any updates with this setup, you're better off backing up your critical data and reinstalling.

qwer112233
2nd June 2008, 01:25 AM
[root@localhost qwer112233]# yum disablerepo=acpacks update
Usage: yum [options] < grouplist, localinstall, groupinfo, localupdate, resolvedep, erase, deplist, groupremove, makecache, upgrade, provides, shell, install, whatprovides, groupinstall, update, repolist, groupupdate, info, search, check-update, list, remove, clean, grouperase >

thanks, this is my result or......maybe not.....but is what i got

so you think i should reinstall it?

but when i put the cd in and restart, nothing happened

bob
2nd June 2008, 01:42 AM
Sorry, it should be 'yum --disablerepo=acpacks update' but BEFORE you do that, as root I'd 'cd /etc/yum.repos.d' and then list them like this: "ls".

Then look at these repos of yours:
livna-development
livna-development-debugin
updates-source
updates-testing
updates-testing-source
livna-debuginfo
fedora-debuginfo
development-source
updates-debuginfo

you should use gedit and change the 'enabled=1' to 'enabled=0' for each of them. In other words, just leave the normal Fedora, Updates and Livna repos open and the rest disabled.

qwer112233
2nd June 2008, 02:00 AM
hummmm i am waiting for it to be updated
sry that i didnt understand cd/etc/yum.repos.d'
i can not find where it is...
i mean gedit

so i just update it... which takes a long time....

qwer112233
2nd June 2008, 02:03 AM
Error: Missing Dependency: libavformat.so.51 is needed by package vlc-core
Error: Missing Dependency: mono(pango-sharp) = 2.10.0.0 is needed by package f-spot
Error: Missing Dependency: mono(pango-sharp) = 2.10.0.0 is needed by package gnome-sharp
Error: Missing Dependency: mono(gtk-sharp) = 2.10.0.0 is needed by package f-spot
Error: Missing Dependency: mono(glade-sharp) = 2.10.0.0 is needed by package f-spot
Error: Missing Dependency: perl(:MODULE_COMPAT_5.8.8) is needed by package perl-DateManip
Error: Missing Dependency: mono(gtk-sharp) = 2.10.0.0 is needed by package tomboy
Error: Missing Dependency: liblber-2.3.so.0 is needed by package wine-ldap
Error: Missing Dependency: mono(glade-sharp) = 2.10.0.0 is needed by package gnome-sharp
Error: Missing Dependency: mono(gtk-sharp) = 2.10.0.0 is needed by package gnome-sharp
Error: Missing Dependency: mono(glib-sharp) = 2.10.0.0 is needed by package f-spot
Error: Missing Dependency: mono(glib-sharp) = 2.10.0.0 is needed by package gnome-sharp
Error: Missing Dependency: mono(pango-sharp) = 2.10.0.0 is needed by package tomboy
Error: Missing Dependency: libdvdread.so.3 is needed by package vlc-core
Error: Missing Dependency: mono(gdk-sharp) = 2.10.0.0 is needed by package gnome-sharp
Error: Missing Dependency: mono(gdk-sharp) = 2.10.0.0 is needed by package f-spot
Error: Missing Dependency: mono(atk-sharp) = 2.10.0.0 is needed by package gnome-sharp
Error: Missing Dependency: libldap_r-2.3.so.0 is needed by package wine-ldap
Error: Missing Dependency: mono(gtk-sharp) = 2.10.0.0 is needed by package muine
Error: Missing Dependency: mono(glib-sharp) = 2.10.0.0 is needed by package muine
Error: Missing Dependency: mono(gdk-sharp) = 2.10.0.0 is needed by package tomboy
Error: Missing Dependency: libx264.so.56 is needed by package vlc-core
Error: Missing Dependency: mono(gdk-sharp) = 2.10.0.0 is needed by package muine
Error: Missing Dependency: mono(glib-sharp) = 2.10.0.0 is needed by package tomboy
[root@localhost qwer112233]#

qwer112233
2nd June 2008, 02:05 AM
there are alot more updates but is way too much, so i pasted all the errors...


thank you~

bob
2nd June 2008, 02:12 AM
Apparently, you've used development and testing repos before this. Frankly, it's time to back up your data and reinstall. Someone with advanced skills might get back to 'normal' after a long struggle, but almost anyone would find it much, much easier to reinstall.

qwer112233
2nd June 2008, 02:15 AM
hummm then how do i reinstall yum

or you mean restore as the whole operation

bob
2nd June 2008, 02:18 AM
The whole Fedora.

qwer112233
2nd June 2008, 02:32 AM
humm then how do you.......... yea.........reinstall the whole fedora....

same thing put the cd in like i first started???

but it does not work....

any other method??

bob
2nd June 2008, 02:37 AM
The CD might be scratched? I'd download a fresh one and try again. If you want to keep working around the errors instead (and hope for the best), you can try 'yum .sh'. First, download this and save it to your /home/username as 'yum.sh':


#!/bin/sh
for i in `yum list updates |cut -f 1 -d " " |grep -A 500 -e Updated |\
grep -v -e Updated` ; do
echo "Updating $i"
yum -y update $i
done

Then, as 'su', type "sh yum.sh". It will slowly update package by package, but skip the ones that have dependency errors.

qwer112233
2nd June 2008, 02:44 AM
ok thank you so much for your help,
if the final method does not work
i will download a new one
thx~