PDA

View Full Version : Modifying the login screen



KirkD
1st June 2008, 06:46 AM
I really don't like the login screen, but I can't seem to find any way to change it. I tried using the Login Manager (I'm using KDE), but regardless of the settings I apply here, nothing changes on the login screen. I also tried to download different themes and while they show that they have been installed, none of them appear in the theme selection window. Only the default themes are there. What's going on? Have I missed something obvious?

BTW - can I change the avatar for users on the login? The default weeble-wobble is kind of boring.

-Kirk

JohnVV
1st June 2008, 08:34 AM
--- for Gnome not Kde ---

look in System / Administration / Login Window / local ( tab)
for fedora 8 there are 4 preinstalled to choose from
and for Gnome search the web there a many themes with a boot menu
http://www.gnome-look.org/

kyuso
1st June 2008, 10:12 AM
If you switched to kde, it may be using kde login manager. Using the gnome login manager will not help with kde login settings.

I haven't used kde for quite some time, so I don't know which menu item invokes kde login manager.

You can still run command-line
kcontrol and choose System Administration -> Login Manager.

KirkD
1st June 2008, 02:35 PM
Ummmm.....right....yes, I tried using the login manager. Like I said in my original post:

I tried using the Login Manager (I'm using KDE), but regardless of the settings I apply here, nothing changes on the login screen. I also tried to download different themes and while they show that they have been installed, none of them appear in the theme selection window. Only the default themes are there. What's going on? Have I missed something obvious?

It seems that changes I make in the Login Manager don't take effect.

JohnVV
1st June 2008, 04:39 PM
boot into gnome and switch it there ,then reboot and select kde from the list

PabloTwo
1st June 2008, 10:28 PM
/usr/sbin/gdmsetup
This is the application that allows you to change your GUI login graphics.

av1611
1st June 2008, 11:53 PM
I have the same issue. All the fixes here don't apply to F9...
How can I switch to GDM and how can I then modify GDM in F9?

Thanks.

KirkD
2nd June 2008, 12:53 AM
kyuso - I do not appear to have kcontrol. I looked in /usr/bin and /usr/sbin - no luck. Regardless, it seems that login manager changes I make through the GUI don't take effect.

PabloTwo - same result. gdmsetup is nowhere to be found.

JohnVV - I tried booting into Gnome, but I cannot seem to find a Login Manger anywhere. I've looked in all the usual places - System / Administration / Login Window is not there.

PabloTwo
2nd June 2008, 01:08 AM
Well, I'm still back in FC6, so things may be a bit different on later Fedora distros.. But, that said, gdmsetup is installed by package gdm. Try 'yum info gdm' and see what, if anything, comes up.

edit: Just checked the F8 and F9 repos and 'gdm' is alive and well on both.

JohnVV
2nd June 2008, 03:46 AM
take a look at -- Fedora 8 Gnome i don't have 9 --
right click on upper left ( Applications Places System )
and click " edit menus " scroll down on the left to System / Administration
and see if " login Window " is unchecked in the right panel if so check it

i may be wrong but doesn't Gnome control the login window even for kde in fedora

popatopalous
17th June 2008, 04:26 AM
take a look at -- Fedora 8 Gnome i don't have 9 --
right click on upper left ( Applications Places System )
and click " edit menus " scroll down on the left to System / Administration
and see if " login Window " is unchecked in the right panel if so check it

i may be wrong but doesn't Gnome control the login window even for kde in fedora

I don't believe there is a Gnome login manager or login window setting utility in Fedora 9. And I REALLY don't know why. For me in Fedora 9/Gnome:


# /usr/sbin/gdmsetup -bash: /usr/sbin/gdmsetup: No such file or directory

# gdmsetup -bash: gdmsetup: command not found

Why is this? I believe we should have a login manager.

Edit: There is this for auto login:

http://dnmouse.webs.com/autologin.html

harrywagner
27th June 2008, 03:55 PM
I've the same problem in F9.

JohnVV
27th June 2008, 05:58 PM
from what i have read gdm is missing on the install disk
give this a try
yum install gdm
-- and --
yum search gdm
-- for optional packages --

KirkD
27th June 2008, 06:33 PM
Does the same apply to KDE?

harrywagner
27th June 2008, 06:36 PM
I already had GDM and most of the optional packages installed, so this had no effect.

skoona
27th June 2008, 07:16 PM
GDM is being rewritten and leaves these 'Login Manager / gdmsetup' features broken for Fedora 9. I have been trying to enable XDMCP since forever without success.

http://forums.fedoraforum.org/showthread.php?t=188130&referrerid=275

Knowing this there are a few things to try. It likely to be a manual edit of an xml file somewhere. I'm not a KDE user, so I can't help.

James,

JohnVV
27th June 2008, 07:19 PM
my mistake i miss read/remembered some posts see
http://forums.fedoraforum.org/forum/showthread.php?t=190137&highlight=configure+GDM
and wayne's replay
http://forums.fedoraforum.org/forum/showpost.php?p=1030490&postcount=6

skoona
27th June 2008, 08:39 PM
In total the changes to Fedora 7 through 9, has upped the pain level greatly. I now need to go re-read the "HowTo use Fedora" experience document.