PDA

View Full Version : Fedora 7 Boot Problem



psmount
1st June 2008, 05:44 AM
My Fedora 7 boots properly only about once every 5 or 6 tries.
The other times I end up with my desktop picture but an otherwise empty desktop.
No top or bottom pannels. No desktop folders or files.
Any suggestions?

Could it be Grub related?
I use to have Fedora 5 running ok, then updated to 7.
Fedora 7 ran ok up to a few weeks ago. Then the problem described above

Regards,
psmount

kyuso
1st June 2008, 06:43 AM
I use to have Fedora 5 running ok, then updated to 7.


If you are re-using kde/gnome settings from older version, there may be problems.

I always make sure all original settings are backed up and force re-creating them anew.

Try moving all your dot files in your home directory somewhere safe (preferably from console login), then login to your GUI desktop.



mkdir ~/olddots
mv ~/.??* ~/olddots/


If you know what settings dot files you can restore back, that's great, but I found it easier to just manually customize GUI settings from scratch than hunting down which older settings files can be restored, which takes more time than it's worth.

You may still restore dot files that are not related to desktop window manager and are compatible with newer versions (most console applications) , but for GUI applications, better let them generate the default settings before customizing them.

psmount
1st June 2008, 07:44 AM
Thanks Kyuso,

I made that change you described and have now rebooted 3 times succesfully to test.
I think perhaps the time the problem started coincided with me switching from gnome to kde or the other way.

Not suprisingly I guess, I have now lost my saved emails in thunderbird amongst other things.
I moved my .thunderbird back from the saved folder but it looks like more is needed.
Can you say what else I should move back to my home directory to get thunderbird back as before?

regards,
psmount

kyuso
1st June 2008, 08:27 AM
All thunderbird settings should be in ~/.thunderbird, so just restoring that should suffice, e.g.,

cp -ipr ~/olddots/.thunderbird ~/

Check ~/.thunderbird/profiles.ini to make sure it's pointing to the right path, and that the path does have your mailbox files.

BTW, make sure you keep the old files so in case of problems you can still restore them back again. Don't move them back, but copy them.

kyuso
1st June 2008, 08:35 AM
One other thing. Thunderbird has index files with extension .msf which may be corrupted/inconsistent. Remove them (not from your backup, but from your restored ~/.thunderbird, as you should never touch your backup unless you desperately need disk space, which is highly unlikely for settings files), then start thunderbird.

psmount
1st June 2008, 09:03 AM
Ok, thats good.
Thunderbird is back!

Also, I noticed a similar post in this forum a few months back - from XMAG on 27 Sep 2007
The replies then were more about .gconf
But I'm happy for now

Thanks kyuso