PDA

View Full Version : Dual Boot with Fedora 8 and 9



ronty
31st May 2008, 01:34 PM
Hi
At the moment I am running fedora 8 on my machine on sda partitioned with conventional ex3 partitions which runs absolutely perfect so much so I have dispensed with windows altogether. I have installed a new drive on my machine sdb and what I want to do is install Fedora 9 on this drive to keep up-to-date for changes in Fedora in the future. Can anyone advise me the best way to install Fedora 9 so I can choose to boot either fedora 8 or 9 on start up. Which do I install the mbr on? sda or sdb or a boot partition and which is the best partitioning method to use, Lvm or ex3.
Thanks

stoat
1st June 2008, 01:41 AM
Can anyone advise me the best way to install Fedora 9 so I can choose to boot either fedora 8 or 9 on start up. Which do I install the mbr on?Hello ronty,

It's probably safe to assume that Fedora 8 has its GRUB installed in the MBR of /dev/sda. I would leave that the way it is and install Fedora 9 choosing the boot loader option to install GRUB in the first sector of the the Fedora 9 boot partition (Configure advanced boot loader options (http://docs.fedoraproject.org/install-guide/f9/en_US/sn-bootloader-advanced.html)). Fedora 9 will not boot at first, but it will when you add it to the Fedora 8 menu.




which is the best partitioning method to use, Lvm or ex3.That subject is debated here often. Each has its advocates. One way to decide is to ask yourself if the features of LVM are things that you want. If the answer is no, then use standard partitions.

Anniedog
1st June 2008, 02:15 AM
I have tried LVM, but I find the controlling of partitioning under ext3 more suited to my needs.

My thought on LVM is that if you have a system that you will not update ie stick with F8 orF9 for a long period then LVM may well fit. However I being a glutton for punishment just cant wait to get the next fedora. Now that fedora is recognising and mounting partitions automatically and that editing of /etc/fstab hardly needed now, it seems just easier for me to just make the ext3 partitions I need.

For reference I shall shortly (give it another couple of weeks) be going back down to dual boot and remove the f8 from the machine below. F9 is now with the latest samba update fully functional for me.Some niggles yes, some changes I dont like yes, but overall f9 is an interesting release. In fact I have not now used f8 for 2 days that is a record as for the last month or so it was an hour or so playing with f9 and then back to f8 to get things done. So you may find you do not need the f8 anyway

ronty
1st June 2008, 08:35 AM
Hello Stoat,
Thanks for your reply to my question. After I posted I noticed a post by Basilicum which you replied to. Sorry I missed it at first.
I did as you suggested and entered in Grub Boot Loader..
title Second Fedora
configfile (hd1,0)/boot/grub/grub.conf
I could not get it to work. I also tried as It says in the fedora manual to cut and paste grub conf files from 9 to 8 that too did not work
I must be doing something basically wrong because when I downloaded a prog called Super Grub off the net it found 9 and mounted it albeit a little long winded. It booted from (hd1,0).
I will have another go today and let you know what happens. Thanks once again.

ronty
1st June 2008, 10:16 AM
Hello Anniedog,
I forgot to mention also, I decided to use conventional formatting ex3. Thanks for that

ronty
1st June 2008, 03:14 PM
I have tried most of the day trying to get fd8 to boot fd9 and it just will not do it!!
grub is written to the first partition on sdb (hd1,0) Supergrub finds it and mounts it but not fd8.
finally given up. So it's back on my hands and knees swapping my hard drives about...ah well

bob
1st June 2008, 04:05 PM
I've actually installed two versions of Fedora 9 on one drive and Fedora 8 on my other drive and all booted just fine. If you'd installed the second drive after the Fedora 8 install and are still using Fedora 8's grub.conf, then you might have to 'map' the drives to make Fedora 8 notice the second drive. Mapping's done this way:

title Fedora 9
map (hd0) (hd1)
map (hd1) (hd0)
root (hd1,0)
chainloader +1

(in deference to Stoat and Stevea, you can substitute the 'configfile' info rather than the 'root & chainloader' lines. )

ronty
1st June 2008, 04:43 PM
Hello Bob,
Thanks for your information. Do I insert the mapping information into my grub.conf file? if so is there anything else to go with it? What I mean to say is should this info boot my fd9.

stoat
1st June 2008, 04:49 PM
I did as you suggested and entered in Grub Boot Loader..
title Second Fedora
configfile (hd1,0)/boot/grub/grub.conf
I could not get it to work.Maybe you have a separate boot partition for F9. If (hd1,0) is a boot partition that is separate from the rest of the F9 partitions, then you should try it this way...
title Fedora 9
configfile (hd1,0)/grub/grub.conf

bob
1st June 2008, 04:59 PM
You can copy/paste that info into the grub.conf, but when adding something to the bottom of the grub.conf, be sure to hit 'enter' once more to create a blank line that lets grub read all the way down.

As long as you have your grub.conf open for editing, why not also add Stoat's suggestion as another line and give each a try? Nothing wrong with adding a bunch of stuff, testing and then removing what doesn't work.

ronty
1st June 2008, 05:09 PM
Hi Stoat,
I don't have a separate boot partition. I have /root /home swap on both disks. I have reinstalled fd9 again and installed mbr on my first partition (hd1). SuperGrub still mounts it. I have remapped as suggested by Bob but it still will not mount with fd8. When I remapped it it did no go anywhere and gave me no suggestions.
I also tried your configfile for a separate boot partition. I must be doing something wrong somewhere
Thanks for the information

ronty
1st June 2008, 07:15 PM
Hi
I must thank everyone for their interest on this subject.
I have installed fc8 on sdb and did exactly as advised and it has worked perfectly i.e. fc8 on sda boots fc8 on sdb so as a conclusion it must be fc9 that has a fault in it and not as I thought my fault.
Once again thanks I will try fc9 at a later date.

Anniedog
2nd June 2008, 11:49 AM
Just for reference and I hope it may help. I have f9 installed on sata drive along with XP. F8 is installed on a pata drive(compatibility issues) and I have another sata drive which is just for data. this is my fdisk -l from the f9Disk

/dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x0001d730

Device Boot Start End Blocks Id System
/dev/sda1 * 1 19122 153597433+ 83 Linux
/dev/sda2 19123 38244 153597465 83 Linux
/dev/sda3 38245 44618 51199155 83 Linux

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
26 heads, 27 sectors/track, 445273 cylinders
Units = cylinders of 702 * 512 = 359424 bytes
Disk identifier: 0x00000220

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 116697 40960633+ 7 HPFS/NTFS
/dev/sdb2 116698 175045 20480148 7 HPFS/NTFS
/dev/sdb3 175046 175337 102492 83 Linux
/dev/sdb4 175338 445273 94747536 5 Extended
/dev/sdb5 175338 321206 51200005+ 83 Linux
/dev/sdb6 321207 327181 2097211+ 82 Linux swap / Solaris

Disk /dev/sdc: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xa771eacb

Device Boot Start End Blocks Id System
/dev/sdc1 * 1 13 104391 83 Linux
/dev/sdc2 14 5112 40957717+ 83 Linux
/dev/sdc3 5113 7662 20482875 83 Linux
/dev/sdc4 7663 19457 94743337+ 5 Extended
/dev/sdc5 7663 11486 30716248+ 83 Linux
/dev/sdc6 11487 11741 2048256 82 Linux swap / Solaris
/dev/sdc7 11742 14358 21021021 83 Linux
As you can see a little bit of a mess but the point is F9 is installed grub on mbr of sdb and I have f8 installed on mbr of sdc.
I can in bios change the first boot drive, but this can get a little hairy as the drives are identified by their actual names and you need to work out which is which. This is the workaround solution that I can use to choose either f8 or the f9/xp to boot into. This is not the best so I have edited my /boot/grub/grub.conf in the f9 to read.
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,2)
# kernel /vmlinuz-version ro root=/dev/sdc5
# initrd /initrd-version.img
#boot=/dev/sdc
default=2
timeout=15
splashimage=(hd0,2)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.25.3-18.fc9.x86_64)
root (hd0,2)
kernel /vmlinuz-2.6.25.3-18.fc9.x86_64 ro root=UUID=428da114-5703-483e-a2e1-5b8aa0c79748 rhgb quiet
initrd /initrd-2.6.25.3-18.fc9.x86_64.img
title Fedora (2.6.25-14.fc9.x86_64)
root (hd0,2)
kernel /vmlinuz-2.6.25-14.fc9.x86_64 ro root=UUID=428da114-5703-483e-a2e1-5b8aa0c79748 rhgb quiet
initrd /initrd-2.6.25-14.fc9.x86_64.img
title Fedora (2.6.24.4-64.fc8)
root (hd1,0)
kernel /vmlinuz-2.6.24.4-64.fc8 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.24.4-64.fc8.img
title Windows XP
rootnoverify (hd0,0)
chainloader +1
I have also edited my F8 /boot/grub/grub.conf to
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/sda5
# initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=10
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.24.4-64.fc8)
root (hd0,0)
kernel /vmlinuz-2.6.24.4-64.fc8 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.24.4-64.fc8.img
title Fedora (2.6.24.3-50.fc8)
root (hd0,0)
kernel /vmlinuz-2.6.24.3-50.fc8 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.24.3-50.fc8.img
title Fedora (2.6.24.3-12.fc8)
root (hd0,0)
kernel /vmlinuz-2.6.24.3-12.fc8 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.24.3-12.fc8.img
title Fedora (2.6.23.9-85.fc8)
root (hd0,0)
kernel /vmlinuz-2.6.23.9-85.fc8 ro root=LABEL=/ rhgb quiet
initrd /initrd-2.6.23.9-85.fc8.img
itle Fedora (2.6.25.3-18.fc9.x86_64)
root (hd1,2)
kernel /vmlinuz-2.6.25.3-18.fc9.x86_64 ro root=UUID=428da114-5703-483e-a2e1-5b8aa0c79748 rhgb quiet
initrd /initrd-2.6.25.3-18.fc9.x86_64.img
title Windows XP
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1

The only problem is that if a kernel is updated I have to change the details depending upon which drive I boot into. There is suposed to be an automatic solution using config option in grub but that did not work for me.
Anyway This works for me so perhaps you can pick the bones out of it and adapt it. The only important thing to remember is that the sda/b references are different for each fedora and rememeber -1 drives start at hd0,0. I have just set my machine to boot to the f9 drive and boot from there to f8 if needed. I increased the time out to 15 to give me more time and have not needed to use the f8 drive for weeks.

ronty
3rd June 2008, 02:58 PM
Hi
I have solved the problem of my dual boot fc8 on sda to fc9 on sdb. It now works perfectly :)
I reformatted my sdb with 3 partitions /boot /root and swap, installed mbr on sdb /boot and did as you suggested i.e. added to sda grub conf...

title Fedora 9
map (hd0 (hd1)
map (hd1) (hd0)
configfile (hd1,0)/grub/grub.conf

However much I tried It certainly would not see grub on my root partition of sdb

Thanks once again for all who took an interest in my problem.