PDA

View Full Version : How to kill login gui screen



Driftwould
31st May 2008, 03:33 AM
I installed fedora 9 with only xfce and afterwords found out that the install dvd doesn't really install xfce.

I would like to kill gdm so I can log into root at the command line so I can yum groupinstall XFCE, or do I have to go throu the whole install process.

Wayne
31st May 2008, 04:56 AM
No need for that, if you have Gnome (or the other DE) installed, just open a Terminal and su to root and type:

yum groupinstall "XFCE"

Exactly like that....

Wayne

Driftwould
31st May 2008, 05:08 AM
Thanks for the advice Wayne, but unfortunately I unchecked gnome and checked XFCE during the install. I use Gnome on my new laptop, so I was going to try out xfce on my old laptop for something to play around with, which still works great but was really sloooow with gnome on F8.

vinbob
31st May 2008, 05:19 AM
There's no need to 'kill' gdm, you can just switch to a terminal by doing [Ctrl]+[Alt]+[F1-F6], [Ctrl]+[Alt]+[F7] gets you back to your X session.
You can switch between these sessions at any time.

stevea
31st May 2008, 10:32 AM
Uhh - Vinbob is technically correct ,but his reply has nothing to do w/ the question.
The guy wants to avoid gdm b/c it makes his old system run slowly so yes he does want to prevent gdm from starting. Switching to a text vga virtual console does not stop gdm nor statr xcfe in it's place.

I haven't tried xfce on F9 but ... first at the login screen you should have the option of selecting what session type you wanted to start - Gnome, KDE, XFCE etc - whatever is installed.

Also you can choose among several windows managers; read /etc/X11/prefdm and thes set preferred in /etc/sysconfig/desktop

bbfuller
31st May 2008, 10:48 AM
Hello everyone.

The problem for Driftwould is that if you select "xfce" as a desktop environment from the dvd installer it doesn't get installed!!

The only way to install it is over the internet after the initial install is over.

Presumably, if you select "xfce" and deselect "gnome and/or kde" during the install process you are left with the graphical login screen and no desktop environment at all.

So, if you do "Alt-Ctrl-F1" and sign in a root, assuming "Driftwould" has a wired connection to the internet, what you need is the yum terminal command to install the xfce desktop.

ivancat
31st May 2008, 01:35 PM
and to avoid that login window you can also change inittab to start with initlevel 3 instead of 5

Driftwould
31st May 2008, 02:01 PM
Thanks, bbfuller, that was precisely the problem. "Alt-Ctrl-F1" was exactly what I needed to know and I was able to log into root and do a command line install. Really cool to use the command line. I successfully installed xfce using the groupinstall "XFCE" suggested by Wayne. Many thanks!

bbfuller
31st May 2008, 02:14 PM
Hello Driftwould

Glad it worked out OK - just another of those little Fedora oddities that keep us bewitched and bothered.

Remember your command line experience. I doubt you'll go far with Linux without coming across it again.

vinbob
31st May 2008, 02:29 PM
Uhh - Vinbob is technically correct ,but his reply has nothing to do w/ the question.
The guy wants to avoid gdm b/c it makes his old system run slowly so yes he does want to prevent gdm from starting. Switching to a text vga virtual console does not stop gdm nor statr xcfe in it's place.

I haven't tried xfce on F9 but ... first at the login screen you should have the option of selecting what session type you wanted to start - Gnome, KDE, XFCE etc - whatever is installed.

Also you can choose among several windows managers; read /etc/X11/prefdm and thes set preferred in /etc/sysconfig/desktop


?????
What are you on about?
GDM is the default login manager for both GNOME & XFCE, the login manager isn't what's slow, it's the desktop environment.
Please make sure you know what you're on about before attempting to correct someone.

P.S. -- Desktop Environment != Window Manager