PDA

View Full Version : Restoring Xorg



edkilp
12th July 2004, 03:30 PM
Hi, all. Long story short, I was trying to configure a dual-head setup. Never did get the second monitor to even flicker. I had asked a question a few days ago about how to get my monitor to stop shutting down, but I didn't get an answer. Anyway, since I've been messing around, my original xorg.conf is long gone. ( I know, I know, backup, backup, backup) How do I restore my xorg settings to their original state? Can I do this? I was able to use xorgconfig in Slackware. Is there a similar command in FC2? I tried xorg -configure, but received a fatal error:

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.


Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help.

Now, the monitor just goes to sleep even if I'm doing something. In fact, it went blank while I was typing this post!! What in the world did I do? Any help??? Thanks
ed

Bana
12th July 2004, 06:01 PM
Heheh, you answered your own question there,
Please consult the The X.Org Foundation support
at http://wiki.X.Org
for help. So I followed that and found the helpful xorg commands with one being of particular interest: xorgconfig http://freedesktop.org/~xorg/X11R6.7.0/doc/xorgconfig.1.html

That should generate a new xorg config for you.

carbo18
12th July 2004, 06:24 PM
I was able to use xorgconfig in Slackware. Is there a similar command in FC2?

Didn't you try xorgconfig in FC2? Seems like the logical thing to do :D

ghaefb
12th July 2004, 09:45 PM
If you change xorg.conf, xorg.config.backup file is usually created in the same dir...

edkilp
13th July 2004, 03:47 PM
That's true, but I changed it again, which seems to have saved the first overwrite as backup. I still can't get past the 'command not found' when I try anything involving xorg. I'll keep looking around. The link provided in the error message didn't help me, unless I'm really dense in the head! Thanks
ed

crackers
13th July 2004, 05:49 PM
Interesting - there's no "xorgconfig" on my FC2 installation. What I've done is invoke the "X" server with the -configure option (as root, naturally, and in runlevel 3) and gotten a nice, new default xorg.conf - it's a "hidden" option.

(Actually, I haven't done this with Xorg explicitly, but have lots of times with XFree86...)