PDA

View Full Version : fedora 9 and compiz



buddhabadboy
28th May 2008, 07:36 PM
Hello all,
I have ubuntu 8.04 with compiz.

since i'm a redhat / centos server guy, I thought.... great! compiz is what I want. sooo
i now try and configure fedora 9.

I see there's a desktop effects area: and I enable and cube

ok, cool. I get the wobbly effect, BUT, where's the cube? no docs that I can find that talks about the shortcuts, etc. Where are all the key assignments?

then I go to add and remove programs, and I see that there's an option to install the config: which I do, now its GL desktop.. ok, almost there...

I go and see... ahhh, ok, so there's some info for the cube.. BUT, there's no key assignments or anything... where are they? and what's the default key assignment for seeing the cube?

thanks!

TheMadIndian
28th May 2008, 09:44 PM
Hello all,
I have ubuntu 8.04 with compiz.

since i'm a redhat / centos server guy, I thought.... great! compiz is what I want. sooo
i now try and configure fedora 9.

I see there's a desktop effects area: and I enable and cube

ok, cool. I get the wobbly effect, BUT, where's the cube? no docs that I can find that talks about the shortcuts, etc. Where are all the key assignments?

then I go to add and remove programs, and I see that there's an option to install the config: which I do, now its GL desktop.. ok, almost there...

I go and see... ahhh, ok, so there's some info for the cube.. BUT, there's no key assignments or anything... where are they? and what's the default key assignment for seeing the cube?

thanks!
If you dont have compiz fully installed and are just using the default install of it, you can use gconf-editor

in there go to apps-compiz-plugins and you'll see the options
for each option to get to the key combinations go to allscreens-options

mathan
29th May 2008, 10:13 PM
We have to install a few packages for compiz-fusion.
compiz-fusion
compiz-fusion-gnome
compiz-fusion-extras
compiz-fusion-extras-gnome
compiz-manager
gnome-compiz-manager

yum install ccsm emerald-themes compizconfig-backend-gconf fusion-icon-gtk fusion-icon emerald compiz-fusion compiz-fusion-gnome libcompizconfig compiz-gnome compiz-bcop compiz compizconfig-python compiz-fusion-extras compiz-fusion-extras-gnome

or


su -
rpm -Uhv http://rpm.livna.org/livna-release-8.rpm
yum install kmod-nvidia -y
wget http://www.dfm.uninsubria.it/compiz/fusion/compiz-fusion.repo -O /etc/yum.repos.d/compiz-fusion.repo
yum install compiz-all fusion-icon-all compiz-fusion-plugins-unsupported compiz-bcop ccsm emerald-themes -y
shutdown -r now

andreselsuave
30th May 2008, 02:42 AM
Isn't it better to use nvidia propietary drivers? They have already released them 1 or 2 days ago... they work with xorg 1.5 !

mattcen
30th May 2008, 01:37 PM
Firstly, thanks for the info (I can never remember to install "ccsm" - darn acronyms!).

Generally I find that the Livna NVidia drivers are customized better for use with Fedora than the proprietary ones - My understanding is that they all come from the same place anyway.

I believe they take the official drivers, modify them to play nice with Fedora, and then release the RPMs for them. I for one have tried previously to get Compiz to work with the NVidia proprietary drivers with no success. I then tried the Livna drivers and they worked first time.

Regards,
Mattcen

bwire66
30th May 2008, 02:04 PM
I go and see... ahhh, ok, so there's some info for the cube.. BUT, there's no key assignments or anything... where are they? and what's the default key assignment for seeing the cube?


Try holding down the ctl and alt keys while pressing and dragging mouse button 1.

compiz-fusion key bindings (http://wiki.compiz-fusion.org/Common%20Keyboard%20Shortcuts)

buddhabadboy
3rd June 2008, 02:31 AM
thanks mathan, that solved the issue!!!

Main Target
3rd June 2008, 05:13 AM
When i try to use the KDE window switcher it says it cannot st art compiz.

When i start fusion icon, and switch over to compiz, i lose title bars...

Help!

weitjong
3rd June 2008, 08:29 AM
I think you have to switch off the Fedora "Desktop Effect" first before running compiz-fusion.

Also check your "current session" using System > Preferences > Personal > Sessions. Make sure there is only fusion-icon running. Remove all other compiz* session that you can find in the list.
Then, right click the fusion-icon in the tray and choose "Reload Window Manager".

HTH.

mathan
5th June 2008, 06:23 PM
Dear Friends if you have XFCE4 problem in fc9?

please use this command

yum groupinstall XFCE (note: XFCE in captial letter)

andreselsuave
5th June 2008, 09:40 PM
Hi there!
I discovered something about compiz and I want to share it with you... My compiz is working fine in FC9 but at first the effects weren't very fast, like If i didn't have enough RAM memory... The solution I found was to switch on Loose Binding. To activate it just open Compiz Icon if you haven't opened it already ,, right click on Compiz Icon > compiz options > Loose Binding.
Don't know wot is that for, but now all the effects work perfectly ;)

sidebrnz
5th June 2008, 11:33 PM
I just installed a GoForce card yesterday to upgrade to 128 Meg on the card. I'd downloaded the driver install program and tried to follow the instructions but it failed because I was missing some of the development packages. I did know enough to change the driver in xorg.conf to nv, so I was able to get into X long enough to come here and hunt down the pointers I needed to install using yum. Now, I'm having fun playing with the compiz effects and getting things working the way I want. It's taking time from what might be productive work, but at least it's not frustrating!