PDA

View Full Version : Missing F9 repos after preupgrade-ing



rmmartins
26th May 2008, 01:54 PM
Hello everyone! I am new to the Fedora world, just started using it (so far, so good).
I preupgraded from F8 to F9 but I noticed that, in "Software Sources", I don't have the F9 repos, neither base nor updates (only "test ...").
How do I add them? I swear, I have looked for an answer everywhere... It just seem like it's so obvious that nobody talks about it. :D

Thanks in advance!

dan.btown
26th May 2008, 03:32 PM
Hello everyone!
Hey you!


I am new to the Fedora world, just started using it (so far, so good).
Welcome aboard this forum and as a new penguinophilo.


How do I add them? I swear, I have looked for an answer everywhere... It just seem like it's so obvious that nobody talks about it. :D
In fact, this problem caused big stir.
Jump over to the thread
http://www.fedoraforum.org/forum/showthread.php?t=189596
and see if the solution works for you.
No matter if it does or not, post your feedback (to the solution described) overthere.

Cheers,

-- Dan

thirdlibrea
26th May 2008, 03:57 PM
The above solution is to add install media as a software source.

If you want to add the official F9 repos, download the fedora-release rpm from any of the F9 mirrors (http://mirrors.fedoraproject.org/publiclist/Fedora/9/) and install it. Click here (http://ftp.jaist.ac.jp/pub/Linux/Fedora/releases/9/Everything/i386/os/repoview/fedora-release.html) to access the rpm on the JAIST mirror (Japan).

If you want a totally clean repo config, delete everything in the /etc/yum.repos.d/ directory before installing the fedora-release rpm.

Hope this helps

rmmartins
26th May 2008, 10:07 PM
Indeed it helped! I used "rpm -Uvh --force" to install it, couldn't do it otherwise.

Thanks a lot!

mrbear
26th May 2008, 11:45 PM
I have similar problem.
I have tried this


# rpm -Uvh http://ftp.jaist.ac.jp/pub/Linux/Fedora/releases/9/Everything/i386/os/Packages/fedora-release-9-2.noarch.rpm


# uname -r
2.6.25-14.fc9.i686

But I still get the old fedora 8 repo

# yum repolist
Loaded plugins: refresh-packagekit
repo id repo name status
InstallMedia Fedora 8 enabled
fedora Fedora 8 - i386 enabled
livna Livna for Fedora Core 8 - i386 - Base enabled
updates Fedora 8 - i386 - Updates enabled

Any suggestion on how can I get fedora 9 repo?

Thanks.

marcrblevins
27th May 2008, 08:57 AM
I think you are suppose to saved off your old repo and then delete it. Then you install that Fedora Release 9 rpm version.

mrbear
27th May 2008, 11:18 AM
I remove the file elsewhere and tried. Nope not working.

mrbear
27th May 2008, 11:51 AM
can someone show me the file of /etc/yum.repo.d/fedora.repo?

Maybe I can replace that file to get the repos.

btw, mine is i386.

Thanks.

thirdlibrea
27th May 2008, 01:51 PM
Sure here you go..


[fedora]
name=Fedora $releasever - $basearch
failovermethod=priority
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/$releasever/Everything/$basearch/os/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-$releasever&arch=$basearch
protect=1
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY

[fedora-debuginfo]
name=Fedora $releasever - $basearch - Debug
failovermethod=priority
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/$releasever/Everything/$basearch/debug/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-debug-$releasever&arch=$basearch
protect=1
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY

[fedora-source]
name=Fedora $releasever - Source
failovermethod=priority
#baseurl=http://download.fedora.redhat.com/pub/fedora/linux/releases/$releasever/Everything/source/SRPMS/
mirrorlist=http://mirrors.fedoraproject.org/mirrorlist?repo=fedora-source-$releasever&arch=$basearch
protect=1
enabled=0
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora file:///etc/pki/rpm-gpg/RPM-GPG-KEY

mrbear
28th May 2008, 02:54 AM
thirdlibrea,

Thanks. I put the code at /etc/yum.repo.d/fedora.repo. It worked like magic.


# yum repolist
Loaded plugins: refresh-packagekit
repo id repo name status
fedora Fedora 9 - i386 enabled