PDA

View Full Version : Network +Samba on F9



PaulClarke
25th May 2008, 12:03 PM
Hello,

I have upgraded my two computer to F9 (a HP Laptop and a made at home PC) The laptop is fine but the made at home PC has two problems.

1. It boots up and the wired network connect does not connect. Going into services and restarting the network works each time but is there a way for this to work the first time?

2. I cannot "see" any of the other computers on the windows network nor can I mount them via FSTAB using the same line that worked in F8. The latop has the same SMB.conf file other than the name of the PC and this was working in F8.

Regards

Paul

scotty38
25th May 2008, 01:20 PM
Is your network card set to be controlled by NetworkManager? If not then set it to be so. If all else fails you can stop NetworkManager and start network instead.

MeMyself
26th May 2008, 07:34 AM
I've seen this problem also. It sucks, since Network Manager sometimes claims the nic is offline, and since I have 2 nics.... It may be either of them.

My solution may be a bit brute, but it works flawless. NM still complains one of my nics is offline though.

Here's what to do: create a script in which you use ifdown and ifup to kick the nic. Then you can create a cron job to kick the script at boot time.

PaulClarke
26th May 2008, 12:30 PM
Scotty,

Please excuse my ignorance but how do I tell if my card is set to be controlled by NetworkManager?

MeMyself. My wife thinks your third sentence is the best example of geekese we have seen in a long time. Did not understand of course ;} it but thank you for your input

Regards

Paul

scotty38
26th May 2008, 12:46 PM
Run system-config-network and after entering root credentials you should have a gui from which you can highlight and then edit the adapter in question. You should see a tick box with something like "Controlled by Network Manager" as an optionn.

Anniedog
26th May 2008, 01:02 PM
Just joining this thread as although I have desktop and disabled network manager and configured my eth0 manually so I have no problem with connection at boot etc. I have no wireless card so do not really need network manager. I have an outstanding problem with samba browsing network shares in f9
http://forums.fedoraforum.org/forum/showthread.php?t=187358
So interested in samba issues and solutions.

PaulClarke
26th May 2008, 01:51 PM
Scotty,

I have set the card to be controlled by NetworkManager and it makes no difference. So how do I stop NetworkManager and start network?

Regards

Paul

scotty38
26th May 2008, 02:16 PM
su -
chkconfig NetworkManager off
chkconfig network on

I'll leave you to work out how to reverse if necessary :)

A.Serbinski
26th May 2008, 03:22 PM
It is very rare for there to be a reason to use networkmanager on a desktop computer. Laptop yes, since it will likely be connecting to many networks, both wired and wireless, but a desktop generally sits on the same network all the time. The only thing that networkmanager gives you is an easy way to move between many networks.

As scotty38 mentioned, turn off networkmanager and turn on network. In your /etc/sysconfig/network-scripts/ifcfg-ethX file that corresponds to your main nic, make sure that the interface is configured to start at boot and to use DHCP. If you don't use DHCP, you need to specify your static network settings.

Shaky Start
26th May 2008, 03:49 PM
I'll join with Anniedog in this thread if I may, especially as I am totally dazed and more than slightly in need of a wash after trying to figure out when to put the boot into the NIC - or it it to give it a kick in the chron?

Really, it's quite tough on us newbies, you know.

My interest is in getting F9 on my laptop to be able to see the disks on the windows machines on my home network. Samba doesn't work, so perhaps I should be doing a Rumba or a FireFox Trot instead?

Right now I can't install Samba because fedora tells me I'm offline, even though Firefox is able to connect me to this forum in this state. Perhaps I should type small so that Firefox doesn't see that I'm actually off-line?

Actually I think Firefox already knows, because after I close it, it is truly off-line thereafter. The only work around I can find for this is to restart Fedora. Is there such a thing as a 'single shot browser'? If not, I think I've got one....

Shaky Start
26th May 2008, 04:11 PM
1 step for'ard..... 2 steps etc

Following the advice from scotty38 I have studied the relevant parts of the Personal Fedora9 installation guide at mjmwired.net. I have tried to start the network and received the following error message:

[asquared@localhost ~]$ sudo /etc/init.d/network start
Bringing up loopback interface: [ OK ]
Bringing up interface eth0:
Determining IP information for eth0...Can't create /var/run/dhclient-eth0.pid: Permission denied
cp: cannot remove `/etc/resolv.conf.predhclient.eth0': Permission denied
done.
[ OK ]

Where should I be reading to understand why this error has arisen and how I should be responding to it?

Or is it better for my sanity to take photos of the documents I want to transfer from Windows, hook up a scanner to Linux and read them in that way? (assuming there is an equivalent to ReadIris under Linux....)

grosminet
26th May 2008, 09:41 PM
to srart the network , please use command under root like
service network start
The problem resultat that samba use the resolution by the DNS for browse Share.
Secondly, some paquet are not installed in standard configuration.
And when you browse your network , you see a empty window.
I thinck that you laptop was in wireless. And generaly, the interface run with networkmanager. Or networkmanager use dhcpclient and the DNS of your IFA.
To see the network, you must use a wins server and include the wins server in your file smb.conf.
you must control
yum list |grep smb
[root@seth ~]# yum list |grep smb
fuse-smb.i386 0.8.7-1.fc8 installed
gnome-vfs2-smb.i386 2.20.1-1.fc8 installed
libsmbclient.i386 3.0.28a-0.fc8 installed
libsmbios-bin.i386 0.13.13-1.fc8 installed
libsmbios-libs.i386 0.13.13-1.fc8 installed
pam_smb.i386 1.1.7-7.2.2 installed
smb4k.i386 0.8.5-1.fc8 installed
smbldap-tools.noarch 0.9.4-1.fc8 installed
libsmbclient-devel.i386 3.0.28a-0.fc8 updates
libsmbios-devel.i386 0.13.13-1.fc8 updates
libsmbios-unsupported-bin.i386 0.13.13-1.fc8 updates
nagios-plugins-disk_smb.i386 1.4.11-2.fc8 updates
python-smbpasswd.i386 1.0.1-6.fc8 fedora
smb4k.i386 0.8.7-1.fc8 updates
smb4k-devel.i386 0.8.7-1.fc8 updates

PaulClarke
27th May 2008, 10:19 AM
Hello all,

Turning off Networkmanager and Network on worked for me. The PC now boots up with the NIC working.

Now for Samba...........

Thank you all for your assistance

Regards

Paul

PaulClarke
27th May 2008, 12:57 PM
Hello,

I have managed to mount the windows share but I still cannot "see" the windows PCs in the network window and other cannot access my share. This will do for now but is not the best.

Thank you again for your support

Paul

Anniedog
27th May 2008, 04:57 PM
You seem to be catching me up now. Its a waiting game I think. I have just checked fedora testing repo and although there is a samba update coming up it does not as yet seem to be fixing windows network browsing.

As for others not being able to access your f9 shares, that is more a configuration in smb.conf I think as I have as yet not had a problem accessing the f9 from a vista box. Though I have as yet to check the xps and f8 yet. I have cheated a bit and opted for security share option. I have made the guest account my account and so far access to the f9 has not been a problem. Heres the output of my testparm command:
testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[printers]"
Processing section "[All_Music]"
Processing section "[All_Photo]"
Processing section "[All_Films]"
Processing section "[Homevideo]"
Processing section "[general]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
workgroup = MYWORKGROUP NAME HERE
server string = Samba Server Version %v
security = SHARE
encrypt passwords = No
passdb backend = tdbsam
guest account = MYACCOUNT HERE
log file = /var/log/samba/log.%m
max log size = 50
wins server = 192.168.0.1 (THIS IS MY ROUTER WHICH PROVIDES DCHP)
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
guest ok = Yes
hosts allow = 127., 192.168.0. (THIS IS ADDED THE NETWORK MACHINES ON 192.168.0.)
cups options = raw

[homes]
comment = Home Directories
read only = No
browseable = No

[printers]
comment = All Printers
path = /var/spool/samba
printable = Yes
browseable = No

[All_Music]
path = /media/musicphoto/All_Music
read only = No

[All_Photo]
path = /media/musicphoto/All_Photo
read only = No

[All_Films]
path = /media/filmvideo/All_Films
read only = No

[Homevideo]
comment = Home Video Files
path = /media/filmvideo/Homevideo
read only = No

[general]
path = /media/data/general
read only = No
Basic and not the best but it does seem to work. The only other thing I have done is to add the wins to /etc/nsswitch.conf in the below section
# To use db, put the "db" in front of "files" for entries you want to be
# looked up first in the databases
#
# Example:
#passwd: db files nisplus nis
#shadow: db files nisplus nis
#group: db files nisplus nis

passwd: files winbind
shadow: files winbind
group: files winbind

#hosts: db files nisplus nis dns
hosts: files wins dns

Make sure you set the context for selinux and ownership of the shares on the f9 box. This is described in smb.conf.
You may be able to adapt some of this and give it a try when you have time for your use.

The only thing I was going to play with was reserving all the IP addresses in the router and see if the /etc/resolve.conf would have any impact( it seems that the problem is that f9 cannot resolve the names so it was a thought), but as machines are coming and going at the moment I will leave that. But if someone has tried would be interested to know if this helps in anyway. Though as above it is just a matter of waiting for the bug fix to make its way I suppose. There is supposed to be a patch for the i386 but not any good for me to try as running the x86 64.

EDIT
The error I see for this network browsing bug in f9 is seen in messages log eg:
May 27 12:27:47 LINSERVER kernel: gvfsd-smb-brows[5602]: segfault at 0 ip c6c1d8 sp 40fbd000 error 6 in libnss_wins.so.2[c35000+152000]

EDIT
Just streamed a film from network share on f9 to my f8 wireless box , played ok so network shares access seems to be fine from other boxes. One thing I did not mention is that I had enabled authentication for samba and winbind although I have not configured the latter yet (future set up plans). This I did from gnome desktop system>administration>authentication and choosing authentication tab checking the boxes. Only thing I have noticed when copying a couple of 700mb files to the f9 from my vista box, the speed seems to be a bit slow, but access is there ok. That is it for this post I hope this all may help.

charactermatter
31st May 2008, 07:12 AM
Can anyone explain how I can keep my laptop from trying to get the network during boot? My wifi doesn't come around until the computer is started and I would be just fine with it not trying to get an address until it's started, or at least until x is started. It hangs during the boot trying to connect to the wifi.

grosminet
31st May 2008, 08:48 AM
If I have unstanding what you use , you wanted to active the connection to wifi without open a session X.
The problem is fonction the configuration of the wireless card.
Some card like ipw2200 , the connect run after session because choice must be run by user.
On Fc5, I was rt2500, the session was active on boot. But NetworkManager was not supported.
I thinck the solution :
Don't run NetworkManager
Install the parameter of on icard on root
The config must be enter manualy.
I suppose that your machine use like a server because this solution have no interest

glennzo
31st May 2008, 08:51 AM
Can anyone explain how I can keep my laptop from trying to get the network during boot? My wifi doesn't come around until the computer is started and I would be just fine with it not trying to get an address until it's started, or at least until x is started. It hangs during the boot trying to connect to the wifi.
From the command line run sudo system-config-network or choose System > Administration > Network. Both the same. Select the nic, click edit and make sure that Activate device when computer starts is un-checked.

Anniedog
31st May 2008, 11:25 AM
Samba browse problem in desktop has now been fixed on x86_64 with the latest samba updates(r1 14). I can now see and access networked machines in nautilus

PaulClarke
31st May 2008, 01:06 PM
Hello,

Yes so can I - woo hoo. That is about all the problems that came with F9 fixed

Paul

charactermatter
31st May 2008, 03:38 PM
Thanks glennzo, for the reply and help.

glennzo
31st May 2008, 04:48 PM
No problem. All fixed up now?

nspmangalore
30th July 2008, 03:02 PM
Hi all,
I am using F9 on a 32 bit machine. with a 32bit installation.
I am having exactly the same problem.
It still is not fixed.
I have updated to the latest version of samba (3.2.0-2.17.fc9)

jolun
10th August 2008, 05:18 PM
Hi

I have had similar problem as some of you have had. I can access my linux share from a windows box but I can't copy any thing to that folder (I can copy from the linux share to the windows box). I have run chmod 777 test1 (test1 is the share). Any one having any suggestion on what to do?