PDA

View Full Version : DESPERATE! could not open default font 'fixed'



lavatube
25th May 2008, 09:18 AM
Hi all.

First; just to clear it up -> this is my first crack at a non-MS OS and I'm struggling.

I installed F8 on my HP dv2000. I ran some yum updates and all was cracking along nicely.
Then I noticed that my external monitor wasn't working ...

... so I read a few posts, no biggy, and loaded the latest Nvidia Drivers.

Well .... that when things went pear shaped. Since loading the new drivers I get the famous .. "could not open default font 'fixed'" error and cant start X. Its driving me crazy - no forums have been able to help.

Most forums say adjust your xorg.conf or font.alias file in the [font path]/misc/ directory others suggest reinstalling 'xyz' package and going from there. I have tried everything and nothing works. I removed the entire X Windows Library and reinstalled it. I remove and reinstalled the various nvidia drivers ... nothing.

One thing that seems to be different is that I don't have a MISC font directory anywhere, this seems important. I tried removing and reinstalling the various X font packages - including font-misc - nothing.

xorg.conf is below;

Please help - I'm losing my motivation here ...

LAVATUBE


XORG.CONF
-------------------
# Xorg configuration created by livna-config-display

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
FontPath "/etc/X11/fontpath.d/xorg-x11-fonts-Type1"
FontPath "/etc/X11/fontpath.d/"
EndSection

Section "Module"
Load "type1"
Load "freetype"
Load "glx"
Load "dbe"
Load "extmod"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
Option "AIGLX" "on"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from data in "/etc/sysconfig/keyboard"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "us"
Option "XkbModel" "pc105"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "HP w19b/w19e"
HorizSync 30.0 - 83.0
VertRefresh 55.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8400M GS"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "CRT: nvidia-auto-select +0+0, DFP: nvidia-auto-select +0+100; CRT: nvidia-auto-select +0+0, DFP: 640x480 +0+0"
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

lavatube
25th May 2008, 09:55 AM
OK ... you wont believe it ...


I had a stab at just deleting everything in "FILES" section of the xorg.conf file.

It worked ... I'm as happy as a pig in s__t!

TB