PDA

View Full Version : Frostwire won't start



boflo971
25th May 2008, 02:56 AM
Hi

i have installed Java following the instruction on Install Java Plugin on http://www.mjmwired.net/resources/mjm-fedora-f9.html#java everything went fine . I installed frostwire but when i launch it i have this message

Starting FrostWire...
Java exec not found in PATH, starting auto-search...
OOPS, unable to locate java exec in /usr/lib/ hierarchy
You need to upgrade to JRE 1.5.x or newer from http://www.java.com
ls: cannot access /usr/java/j*: No such file or directory
OOPS, unable to locate java exec in /usr/java/ hierarchy
You need to upgrade to JRE 1.5.x or newer from http://www.java.com
Java exec found in /opt/jre1.6.0_01/bin/
Suitable java version found [/opt/jre1.6.0_01/bin/java = 1.6.0_01]
Configuring environment...
Loading FrostWire:
java.lang.UnsatisfiedLinkError: /opt/jre1.6.0_01/lib/i386/motif21/libmawt.so: libXp.so.6: cannot open shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.load0(Unknown Source)
at java.lang.System.load(Unknown Source)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(Unknown Source)
at java.lang.ClassLoader.loadLibrary(Unknown Source)
at java.lang.Runtime.loadLibrary0(Unknown Source)
at java.lang.System.loadLibrary(Unknown Source)
at sun.security.action.LoadLibraryAction.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Toolkit.loadLibraries(Unknown Source)
at java.awt.Toolkit.<clinit>(Unknown Source)
at com.limegroup.gnutella.gui.Main.showInitialSplash( Main.java:67)
at com.limegroup.gnutella.gui.Main.main(Main.java:39)

/opt/jre1.6.0_01/bin/
************************************************** ****************
Something went wrong with FrostWire.
Maybe you're using the wrong version of Java?
(FrostWire is tested against and works best with with Sun's JRE, Java 1.4+)
The version of Java in your PATH is:
/usr/lib/frostwire/runFrostwire.sh: line 134: java: command not found

thanks

Py

Wayne
25th May 2008, 02:59 AM
Ummm, there's a big hint in that error message... and this topic has been covered on several occasions and the answer has always been the same.... Here's the hint, something needs installing.....

"libXp.so.6: cannot open shared object file: No such file or directory"

Wayne

boflo971
25th May 2008, 03:24 AM
thanks Wayne

it is working

Py

Wayne
25th May 2008, 03:26 AM
Good news! Not sure about the first part of the error message, never seen it before, but as long as it's finding Sun's JRE and is working.... :)

Wayne