PDA

View Full Version : Black Screen of Death at gdmgreeter (help!)



Boricua
24th May 2008, 08:51 PM
I have searched the net and these forums without success. Mi wife's machine is an intel core duo that has been running Fedora 9 (and 8 before that) without any issues. I keep it updated. After some recent updates, however, something odd happened. The first sign of problems started after a wpa_supplicant error during boot. Then, the gdmgreeter started only showing the login window with a black background. Once you log in, the screen remains black with only the mouse cursor showing up. I tried the following solutions, but neither seems to work:

http://forums.fedoraforum.org/showthread.php?t=157819&page=1&pp=15
http://www.linuxquestions.org/questions/linux-desktop-74/fedora-8-black-screen-after-boot-loading-cursor-displaying-632672/

I have tried from the command prompt to issue commands like yum (after killing x and login as root), but the system stops responding. I suspect the problem has something to due with ndiswrapper because it stopped working with my wireless card more or less at the same time
I don't know what else to try so any advice/guidance will be greatly appreciated. :(

Boricua
26th May 2008, 12:58 AM
After no answer was received to my post, I knew that my best shot was to rescue the data from the hard drive and reinstall. It was then that I found out that Fedora was not the problem, but hardware related. A Fedora 9 live cd failed to upload (it worked fine in my laptop), so I opened the case, took off the wireless card and voila!, the computer was up and running :D . It was obvious that this D-Link AirPlus G DWL-G510 died, after several years of good service courtesy of ndiswrapper. What I don't understand is why it allowed the boot up only to disrupt the desktop :confused: . Anyway, I provide this report just in case someone else finds this issue in the future :) .