PDA

View Full Version : yum missing dependencies



ChrisAkeley
23rd May 2008, 03:30 PM
Hey, Howdy. I'm on FC7 on a GoDaddy box. When I run

yum update

The outputs ends with a message 'Missing Dependency: mod_jk >= 1.2.0 is needed by package turbopanel-tomcat'. I have mod_jk 1.2.26-1.fc7.gdg installed. Why would it say such things?

lazlow
23rd May 2008, 04:37 PM
Three things I can think of:

1. You are mixing repos (generally a bad idea). The version of the "missing" package that is on your system(from repo A) is not quite the same as the one required by the package being installed (from repo B).

2. Sometimes you really need the -devel version of the required package. Just yum package-devel.

3. Sometimes yum gets stuff caught in it throat. Do a "yum clean all" and try again.

ChrisAkeley
29th May 2008, 12:01 AM
Thanks. I tried the -devel option, but there is no mod_jk-devel or turbopanel-tomcat-devel. Tried 'clean all' with no luck. Not sure if I'm mixing repositories. How can I tell?

lazlow
29th May 2008, 01:08 AM
Where did you get turbopanel-tomcat from? It does not appear to be in the standard repos.