PDA

View Full Version : Desktop Effects broken on only one account?



Karmaflute
23rd May 2008, 08:08 AM
I somehow broke Desktop Effects. Every time I try to enable it it says "Desktop effects could not be enabled".

When I run gtk-window-decorator from the terminal I get this:


gtk-window-decorator: Screen 0 on display ":0.0" already has a decoration manager; try using the --replace option to replace the current decoration manager.

When I try to use "gtk-window-decorator --replace" the terminal locks.

I can enable Desktop Effects just fine on my root account. I've just broken it for my user account and I don't know how I did it! I've even tried uninstalling and reinstalling all of compiz. I don't use Emerald or any other decoration manager that I am aware of.

Karmaflute
24th May 2008, 12:12 AM
I reinstalled gnome and the gtk-window-decorator no longer reports this error but Desktop Effects still won't enable for this one account!

When running "compiz --replace" I get this error:


[Karmaflute@localhost ~]$ compiz --replace
compiz (core) - Error: Another window manager is already running on screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

Karmaflute
30th May 2008, 11:01 PM
I still can't enable desktop effects on my user account. Does anyone know how to fix this?

fizy
30th May 2008, 11:07 PM
have you tried to start compiz just by running desktop-effects yet?

Karmaflute
30th May 2008, 11:13 PM
Yes. It doesn't work on this account. I can enable it fine as root.

I uninstalled compiz and deleted any configuration files and folders in my home directory that have the word "compiz" in it. That still did not solve the problem.

I even reinstalled gnome (by mistake I accidentally removed it).

Karmaflute
27th July 2008, 03:38 PM
I solved the problem. Xhotkeys conflicts with compiz. The two can coexist if you enable desktop effects first. This fixed it for me.

A.Serbinski
28th July 2008, 06:23 AM
Try this to clear the compiz settings:
rm -rf ~/.gconf/apps/compiz