PDA

View Full Version : Fedora 9 noob problems



sysope
22nd May 2008, 07:37 PM
Hi there :D
I just installed Fedora 9 under a pen drive (using Fedora Live USB Creator) which I'm very happy cus I already used other distro but fedora looks pretty much faster and have all the tools I need. I just get the following problems which makes me sad.

1- After I change the keyboard layout to United Kingdom I don't know why but I as soon I reboot the pc I get the us layout instead :(

2- In Terminal I cant perform the sudo command. Always get this message: "fedora is not in the sudoers file. This incident will be reported".

3- After I install flash plug-in I don't get any sound :( I have installed the plug-in manually. (I have tried to use "yum install libflashsupport" but since I don't get root access I can't run that command).

Hope there's somebody who can help me fixing this. And thank you very much in advanced :D

dan.btown
22nd May 2008, 07:52 PM
Hello SYSOPE,

i see you are new here. So:
Welcome aboard!

Regarding your point 1:

Are you talking about the keyboard layout used in a terminal *outside* a graphical desktop (as shows up when you say [CTRL] + [ALT] + F1), or is this the behaviour of your KDE or GNOME install?

Forum members here and in the german Fedora Forum (http://www.fedoraforum.de) have reported that KDE4 in F9 behaves somewhat ignorant about system settings like display resolution and language settings, which appear to be kept alive only for the running session (if at all) and are gone after reboot.

Thx.

-- Dan

juanfgs
22nd May 2008, 08:09 PM
2- In Terminal I cant perform the sudo command. Always get this message: "fedora is not in the sudoers file. This incident will be reported".

Fedora doesn't configure sudo by default you have to login as root with "su -" and type your root password



3- After I install flash plug-in I don't get any sound :( I have installed the plug-in manually. (I have tried to use "yum install libflashsupport" but since I don't get root access I can't run that command).

Hope there's somebody who can help me fixing this. And thank you very much in advanced :D
Install libflashsupport

yum install libflashsupport

sysope
22nd May 2008, 08:09 PM
Hello SYSOPE,

i see you are new here. So:
Welcome aboard!

Regarding your point 1:

Are you talking about the keyboard layout used in a terminal *outside* a graphical desktop (as shows up when you say [CTRL] + [ALT] + F1), or is this the behaviour of your KDE or GNOME install?

Forum members here and in the german Fedora Forum (http://www.fedoraforum.de) have reported that KDE4 in F9 behaves somewhat ignorant about system settings like display resolution and language settings, which appear to be kept alive only for the running session (if at all) and are gone after reboot.

Thx.

-- Dan

I'm talking about graphic mode which is gnome. The default is US then i change to United Kingdom (seems to work fine) as soon i reboot the pc don't know why but the keyboard changes to US again (the keyboard configuration its always set to United Kingdom).

thx 4 the reply :D

dan.btown
22nd May 2008, 11:31 PM
Pls. also obeserve these threads:
http://forums.fedoraforum.org/showthread.php?p=1017038&posted=1#post10170388,
http://forums.fedoraforum.org/showthread.php?p=1017044#post1017044,
as the problems may be related.

-- Dan

ryptyde
22nd May 2008, 11:38 PM
Hi there :D
I just installed Fedora 9 under a pen drive (using Fedora Live USB Creator) which I'm very happy cus I already used other distro but fedora looks pretty much faster and have all the tools I need. I just get the following problems which makes me sad.

1- After I change the keyboard layout to United Kingdom I don't know why but I as soon I reboot the pc I get the us layout instead :(

2- In Terminal I cant perform the sudo command. Always get this message: "fedora is not in the sudoers file. This incident will be reported".

3- After I install flash plug-in I don't get any sound :( I have installed the plug-in manually. (I have tried to use "yum install libflashsupport" but since I don't get root access I can't run that command).

Hope there's somebody who can help me fixing this. And thank you very much in advanced :D

Are you saying that you have installed Fedora 9 to a USB pendrive if so did you use the script which creates a "persistant overlay" if not your changes will not b saved on subsequent boots.

sysope
23rd May 2008, 05:09 PM
Are you saying that you have installed Fedora 9 to a USB pendrive if so did you use the script which creates a "persistant overlay" if not your changes will not b saved on subsequent boots.

I have made a persistent overlay of 1 G so I think its enough to save the keyboard layout :(
In the Keyboard layout configuration the UK language is enable and default (its the only one) only problem is I always get eh US layout :(

dan.btown
23rd May 2008, 05:15 PM
In the Keyboard layout configuration the UK language is enable and default (its the only one) only problem is I always get eh US layout :(

Pls. also observe this thread (http://forums.fedoraforum.org/forum/showthread.php?t=189320), as the problems may be related.

What does

# echo $LANG
return for you?

Thx.

-- Dan

sysope
23rd May 2008, 05:27 PM
Pls. also observe this thread (http://forums.fedoraforum.org/forum/showthread.php?t=189320), as the problems may be related.

What does

# echo $LANG
return for you?

Thx.

-- Dan

Yes its related.

[fedora@localhost ~]$ echo $LANG
en_US.utf8

just need to know how to fix it :D thx a lot