PDA

View Full Version : Fedora 9 boot fails after udev



stop7b
22nd May 2008, 05:05 PM
Tried upgrading Fedora Core 5 to Fedora 9 last night, upgrade was successful, but boot failed immediately following the "udev OK" message. Screen goes blank, disk activity stops, have to reset to start boot again.

My system has a Radeon X1600 video card and has 2 SATA hard drives- one Maxtor in removable bay, and on Western Digital data drive in internal mount.

Tried reinstalling Fedora 9, this time opting for clean install, removing and recreating the Linux directories. Both drives showed up, and I selected to install to the Maxtor drive. Installation was successful again, but boot failed at exact same point.

Saw some posts that indicated grub might mix up drives, so I disconnected the internal data drive and reinstalled a basic system. Boot failed again at the same point.

Did some more research, checked my grub.conf file, which looks ok. Saw some info that indicated SATA drives might have RAID info interfering, so I tried the dmraid -Er command, which indicated I had no RAID info. Saw a post indicating the Radeon card could be a problem, so I edited my xorg.conf to load a VESA driver instead of Radeon.

After booting again, the display disappeared at the udev screen, but I continued to see disk activity while the monitor showed a resolution problem message.

I've seen some posts in FedoraForum that show how to config Radeon cards, and I've grabbed those notes to try this evening.

I'm a little confused, since the old FC5 installation booted and ran the same hardware config as I tried to install 9 to. I have a fair amount of Linux experience, but essentially none at troubleshooting boot and hardware issues. I'd really appreciate any suggestions you have about how to sort this problem out.

Thanks!

Dan
22nd May 2008, 05:24 PM
Just out of curiosity, is the monitor a 14 or 15 inch BenQ based DELL monitor?

stop7b
22nd May 2008, 07:31 PM
Thanks for your reply, Dan!

No, the monitor is a 19-inch Samsung.

Dan
22nd May 2008, 08:00 PM
Dang!

Not what I suspected then.

I had a Dell that started doing that about a week before it quit running entirely. But I've had great luck with Samsungs. In fact, I'm staring at these typos on a Samsung SyncMaster 171v right now. I have a 19" SyncMaster wide screen (941BW) on the graphics machine and it just works like a trooper too.

I guess we're back to square one here, but someone will be along in a while who knows more about this than I do. And if not, I'll bump it once in a while to keep it in the mix.


Dan

stop7b
1st June 2008, 09:13 PM
Found that when editing xorg.conf to vesa driver that drive activity continued past udev message, even though monitor showed resolution error message.

Edited xorg.conf again to provide modes (1024x768 and 800x600) and got complete boot with X running.

Don't know if I need to close this thread, but moving to Hardware forum to troubleshoot Radeon issue.

Dan
1st June 2008, 09:38 PM
OK. I'll close this one and you can continue on there.

Thread closed.