PDA

View Full Version : Fedora 9 and GRUB



icole
22nd May 2008, 03:27 AM
I first tried upgrading my FC7 to Fedora 9. The installation said it was a success and to reboot. Well the reboot resulted in an error 15 file not found. I upgraded again and once again I got the Congratulations the upgrade was successful. When I rebooted the word GRUB fills the screen and it scrolls GRUB forever. Tried another pass at upgrade. Same results. So then I did a fresh install, still GRUB GRUB GRUB ...... GRUB GRUB. Boy this makes a person appreciate Windows!!! This is 2008 not 1989. Ubuntu installs easily as well as SUSE. I've been using RedHat since about release 2 and have suffered off and on through the years. Anyone have any idea how to get past the continuous GRUB GRUB GRUB. Boy whoever came up with the bright idea of displaying GRUB continuously instead of giving some one a clue as to what the problem might me is a genius. Fedora doesn't have a chance being the desktop of choice as long as it take us nerds to install it! I really do want a real alternative to Windows, but until there's ONE LINUX that is as painless as Windows to install and use I don't see Linux being the one. Maybe Apple has the answer.

Just now another 'successful' install completed, this time I deleted all partitions and still get the darn GRUB GRUB GRUB. Can someone dig me out of this mess? Or better yet WOULD someone dig me out of this mess?

stoat
22nd May 2008, 03:51 AM
Hello icole,

That is one of the rarer and more interesting GRUB screw ups. It's far more common to see the GRUB _ system hang or just a grub> prompt. Anyway, instead of re-installing the whole system again (you've proved that won't help), I would just re-install GRUB using linux rescue.

You didn't say anything about how many drives, what other systems are installed, where GRUB was installed, etc. I am going to assume that you have one drive and you chose to install GRUB in the master boot record. If that is wrong, maybe you should clear it up. Otherwise, here is the way to re-install GRUB in the master boot record of a single drive system in linux rescue...
Boot with the Fedora installation disk or the Rescue CD.
Select Rescue installed system.
Follow directions & respond to prompts.
At the sh prompt enter: chroot /mnt/sysimage
At the sh prompt enter: grub-install /dev/sda
If you get a "No corresponding drive in BIOS" error, then do it again like this: grub-install --recheck /dev/sda
At the sh prompt enter: exit
Enter exit again to reboot.
Remove the CD or DVD.

No promises. Good luck.

P.S.: I have reproduced (for fun and study) all of these GRUB anomalies except this one of yours here. I can do the GRUB _ system hang. I can make it go to a grub> prompt. But I have only been able to read reports about the GRUB GRUB GRUB endless loop. It is the rarest of them all.

P.P.S.:



Boy whoever came up with the bright idea of displaying GRUB continuously instead of giving some one a clue as to what the problem might me is a genius.That word GRUB is printed on the screen by stage1 which is so tiny and simple that it can do only the simplest of error handling and messaging. Caught in a loop like that, it is helpless to tell you anything. When things go normally, the subsequent stage prints the remainder of the complete phrase such as "GRUB Loading stage1.5" or "GRUB Loading stage2". It's sort of like the way LILO prints "L" then "I" then "L" then "O" as its stages succeed. When LILO fails, you can tell were it got stuck by how much of the word "LILO" got printed on the screen. Anyway, GRUB stage1.5 and stage2 are big and more complex. They have more error handling and messaging capabilities. Compare stage1 error messages to stage1.5 and stage2 error messages (http://www.uruk.org/orig-grub/errors.html). On second thought don't. You sound mad right now.

icole
22nd May 2008, 04:20 AM
Thanks for the reply. I've been fooling around with rescue and have gotten to point where I now get the file not found error 15 message. Think I can edit the etc/grub.conf and get past this. I'm tired tonight so will do that some other time. MY WINDOWS SYSTEM IS RUNNING as that's what I'm using on this forum. It is really beyond me why in 2008 we should have these kinds of problems. I'm an old guy, been in the computer world since 1968 starting with IBM mainframes and later PC's. I've written a lot of code for the PC and even did some PC BIOS work back in the early 90's. Even have done a few microcontroller projects and did a lot of 6502 coding for the Commodore VIC 20 and 64. In my younger days I had more patience and that's when I started with RedHat. I'm at the point where I don't want to mess around, just want to install and have it work. I've chased my share of bugs:-) Sometimes I wonder why I still fool with Linux, but really would like to see a viable alternative OS on the desktop. Ubuntu is close, but for some reason they chose to not let me log in as root. What Linux needs is ONE distribution with some controls and direction. I realize that for a small number in the computer world that being able to fool around with Linux is important and fun, but for the majority of folks that USE computers they just want it to be like an appliance, turn it on and it works which is what Microsoft has accomplished for the most part. Oh well, off my soap box. Tomorrow maybe I'll get Fedora 9 working!

stoat
22nd May 2008, 02:59 PM
Hello again icole,

Your main problem really is with GRUB in particular, not necessarily with Linux in general. I have to admit that GRUB is responsible for a lot of threads here. Part of that is because GRUB is so versatile and offers choices and options. It's complex. Just look at the manual. And with options comes the responsibility to learn how to use them (a source of some of the GRUB troubles people have here). The rest of the GRUB issues are caused by those stages (IMO). That is what caused your problem yesterday. Below I will offer an idea for you to boot Linux without the GNU GRUB stages. But first...



I realize that for a small number in the computer world that being able to fool around with Linux is important and fun, but for the majority of folks that USE computers they just want it to be like an appliance, turn it on and it works which is what Microsoft has accomplished for the most part.I've thought about this before, too. I believe that sentence is a true and fair statement. But it implies the Linux has somehow failed where Windows succeeded. And that I don't think is true. Now, I consider myself neutral on the "MS issue" around here. I am not an MS hater. But consider for a moment this situation from a different perspective...

I already made the assertion that complexity, versatility and options often lead to confusion and frustration and forum posts about GRUB. Your (and my) Microsoft systems deal with complicated issues like this boot loader stuff by simply not offering many boot loader options during installation. Have you ever thought of that? Windows insists that there be a compatible (FAT, NTFS) active partition on the boot drive for its boot loader files. If one is not there when XP, for example, is being installed, XP Setup stops dead in its tracks until one is created for it. And MS systems will universally install boot code in the master boot record of the boot drive. You may get notified of it, but you don't have any real say in the matter other than to quit. And you are never asked if you want to install NTLoader in a boot sector to be booted by another boot loader. To this Vista day, MS has never acknowledged even the possibility that we might have another system and boot loader working that we want to keep. MS has gotten a little better about about booting other systems with its boot loader, but it still has the irrevocable requirement during installation that it be "in charge" of all boot loader chores. Therefore and in conclusion, I believe that you cannot have it both ways. You cannot have choice, options, and versatility in a boot loader system and at the same time sit back and daydream while the installer installs your system for you. You must do one or the other of these: 1) study a manual and learn to control a complex system, or 2) purchase a rigid option-less system that installs itself without your help, and you can then just "turn it on and it works" as you said. This is not bad. It's good. It's a form of choice in itself. So don't be angry anymore about this. Just choose.

Back to your problem (the GRUB stages)...

GRUB stage1 is so simple (only a few hundred bytes) that it can find the subsequent stage only by having that stage's block location embedded in it when it is created. If something, anything happens to change the block address of the next stage (or make it wrong to begin with), the whole thing is busted. In your case, an endless loop of stage1 starting and being sent right back to itself occurred. I think stage1 is the weakest link in the GRUB chain of events and related in some way to most GRUB troubles. Secondly, stage1.5 is installed in the so-called DOS Compatibility Region which is a normally unused area between the master boot record and the start of the data sectors. It is generally the 62 sectors following the master boot record, and stage1.5 uses about 20 sectors of it. But other (only a few) software apps use that area, too. So there is at least the potential for conflicts in that sort of "lawless" region of the drive that can lead to GRUB trouble.

Anyway, if your Windows system is one that boots with NTLoader and is now booting directly from BIOS again, you can boot Fedora using the Windows boot loader. There are several variations of the idea, and all are easy to do. One of these well-known methods completely eliminates the GNU GRUB stages from the process. I didn't think it all up, but I gathered it all together in one spot here (http://www.fedoraforum.org/forum/showthread.php?t=188378). You sound like a good candidate for this idea. Maybe you should at least look.

icole
23rd May 2008, 03:29 AM
The PC that I use for Linux only has Linux installed. I'm using my Windows 2000 PC right now since my Linux box is dead. I realize that Grub is complex and to be honest I'd just as soon no see GRUB, I only want to have one OS on the PC, that being Linux. As stated in my earlier post, there is some percentage of PC users that enjoy messing around with things like Grub and I'll admit that earlier in my life things like this appealed to me. Now I'd like to insert a DVD in the driver boot from it and install Linux and it works. This certainly isn't the case right now. I've attempted to follow the instructions from a number of posts and still have the Error 15 File not found. I'll admit that I'm ignorant to the details of Grub, but in the same breath I'll admit I'd just as soon remain ignorant about Grub. I don't have to do any of this stuff when I install Windows 2000 or XP and this far into the life of Linux don't know why I should need that level of knowledge for Linux. Yes, I can see benefits to folks like yourself that don't mind digging into things like Grub and again earlier in my life this would have been OK with me. I work every day with professionals, managers, developers, etc. and only a small percentage use Linux because they don't want to go through learning about things such as Grub, rather they want to install an OS and start using it to be productive. I apologize for stepping on anybody's toes. Don't get me wrong I'm not anti-Linux and have for years held out hope that it would be a viable alternative to Windows as true competition is good for all. I hung on to OS/2 for years partly due to having a client that ran OS/2 and still do. Hopefully someday there will be a distribution of Linux that meets the appliance test. Ubuntu may end up being the distribution that sets the defacto Linux desktop standard. And if you read my earlier posts you'll see that I've already contradicted myself in that Ubuntu want let me log in as root and that bothers me:-) Guess I want my cake and eat it too!!

My next step is to boot DOS and do an fdisk /mbr to get the mbr back correct and then do a fresh install of FC9. Hopefully all will work then. I really appreciate your response and respect your views.

stoat
23rd May 2008, 03:45 AM
I apologize for stepping on anybody's toes.Hello again icole,

I can understand your point of view. I think if you could have Linux with a Windows-style boot loader arrangement and installation process you would be happier with it overall. I can't really disagree with that actually. It would be ten times harder to dual boot it with Windows though. One of the two has to give way to the other and be more configurable in order for them to co-exist.



...and then do a fresh install of FC9.If you're willing to do it, I think it will solve your problem.

P.S.: On your single system computer, you should be able to install Fedora allowing all of the default partitioning and boot loader options to happen, and the result should be an almost Windows-like installation and startup.

icole
23rd May 2008, 04:02 AM
I'm working on a fresh install right now. Only thing for some reason W98 fdisk /mbr didn't seem to get rid of Grub so it still may not work. Don't know if I have a utility left around that will fix this or not. Once again, I appreciate your time and responses.

jcarter
24th May 2008, 12:36 AM
...and then do a fresh install of FC9.

I can add a bit - I saw this on a system with a single boot drive - Fedora after an upgrade from F8 to F9. I was on VMWare, but had symptoms similar to others with physical hardware. I restored the system back to F8 and redid the upgrade to F9 - this time instead of picking
"Upgrade Grub Boot installation"

I picked
"New Grub Boot Installation" , answered questions with default answers, and installed into MBR.

Then when I did a Yum update, it continues to boot. But of course there could have been a bum update coming down via Yum that screwed things up.

Since you already retried a fresh install of FC9, it may be good to select the "New Grub Boot installation" during install to make sure to fully install the correct Grub boot process. If that makes a difference, it points to something in the Grub boot chain not being upgraded properly during install.

sk1
9th June 2008, 11:53 PM
Coming from vacuum tube triggers era (39 years in computers) would like to reprimand fc9 developers. They basically change format of ext3 FILESYSTEM from 128 b inode (which is understood by most grub versions) to 256 b inode ext3 filesystem. Fc9 installs patched GRUB loader and leaves users of other GRUB versions in the dark. Shame. That's very bad behavior in OPEN source.
Yes you can browse code and find that. But asking many users to browse code to find out why multiple Linux installs aren't working is too much.
My 2 cents and respects to icole.

sk1
10th June 2008, 12:10 AM
P.S.: .... But I have only been able to read reports about the GRUB GRUB GRUB endless loop. It is the rarest of them all.

Simple. Leave fc9 grub installed mbr and delete partition where grub was installed.

GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUBGRUB GRUB GRUB

stoat
11th June 2008, 01:23 AM
Fc9 installs patched GRUB loader and leaves users of other GRUB versions in the dark. Shame. That's very bad behavior in OPEN source.Hello sk1,

I don't think this 256-byte inode thing is such a big deal. The so-called patched GRUB that comes with F9 boots it perfectly fine. It boots the older Fedoras normally. And there are simple ways to make the older GRUBs boot F9. So you're covered from about every angle on this, but you sound angry. I consider this "situation normal" for Fedora. There is an eruption of panic perfectly timed to every new Fedora release for one reason or another. I recommend that you get used to this kind of thing if you want to use Fedora.




Yes you can browse code and find that. But asking many users to browse code to find out why multiple Linux installs aren't working is too much.You could also just read the release notes (http://docs.fedoraproject.org/release-notes/f9/en_US/) and other related documentation (http://fedoraproject.org/wiki/Features/Ext4). Probably easier than deciphering code.




Simple. Leave fc9 grub installed mbr and delete partition where grub was installed.

GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUB GRUBGRUB GRUB GRUBI tried what you said there. It didn't happen. I got this...
GRUB Loading stage1.5.

GRUB loading, please wait...

Error 22That first phrase is (I have always believed) partly written by stage1 (the GRUB and the space), and the remainder is written by stage1.5 (the Loading stage1.5 part). Those two parts of that phrase can be viewed in the stage1 and stage1.5 image files with a hex editor like ghex. And that "GRUB loading, please wait..." phrase can be found in its entirety (including the three dots) amongst the messages in stage1.5. So when I deleted the F9 partition as you suggested, stage1 and stage1.5 both appear to have been loaded and run, but stage2 understandably did not. But no endless GRUB loop happened. Everything just stopped (also understandably). I didn't really see how that would have produced the endless loop, but I am willing to try anything that sounds reasonable. That endless GRUB loop thing really is rare compared to other GRUB "anomalies" IMO. When it does happen, it is usually blamed on BIOS settings or multiple and/or botched attempts at installing or re-installing GRUB.

http://forums.gentoo.org/viewtopic-p-799346-highlight-grub.html#799346
http://www.trilithium.com/johan/2005/06/grub-grub-grub/
http://www.linuxquestions.org/questions/ubuntu-63/booting-my-new-ubuntu-install-grub-grub-grub-grub-grub-etc.-518849/

To me, the most common GRUB "anomaly" is the GRUB _ system hang. It is my belief that it occurs when the stages don't all run for various possible reasons. But for an example, when stage1 is installed in a boot sector and the stage2 file is moved to a new block location for any reason, then stage1 cannot find it like stage1.5 can. The GRUB _ system hang often results. The next most common one that I read about is landing at a working grub> prompt, and that is well-known to occur when the stages all run but the grub.conf file is missing or badly misconfigured.

Anyway, If you have some way of proving your original statement about the endless GRUB loop, I'm still interested and listening. Until then, I remain unconvinced.

whyohwhyohwhyoh
2nd August 2008, 11:18 AM
stoat, big thanks for the instructions. that's fixed my GRUB GRUB GRUB... error too :-D

FYI i got the error after upgrading my old K7 athlon system from F8 to F9 from the DVD. the disk arrangement is a bit odd - xfs and raid. but that shouldn't worry grub, right?

hope that's of some use. thanks again.

regarding the discussion about flexibility and the size of stage 1 - i suggest it should be possible to apply rigorous methods to prove that the only way stage 1 could fail would be by hardware error. and then it might just be possible to squeeze a numeric (hex?) error code into the program. or a single error message - "disk error" ... i think that's what Windows' 'stage 1' loader does.

pedora
2nd August 2008, 11:06 PM
icole, I think you have to be really careful when installing Fedora 9 because it has so many options for installing including grub. I think it's a nice installer and everything but I had to click where I wanted it to install and to install GRUB to the first sector of the root partition. I was really paying attention and watching for the options. It sounds like something went amiss and one of the stages was left out of your grub config file? I could be wrong about that.

I'm just learning but I found learning how to create a separate grub partition and then chain loading each OS to be my grub heaven for now. I even had grub errors that I was able to fix. I forget the eror number(s) now but I was able to solve the problems and fix my grub.

I think when you're learning, you absolutely MUST MUST have another computer handy that is connected to the internet (to research and look things up) or failing that, have a LiveCD that you can boot up to fix your grub issues. I think the LiveCD is even better since you can have it right in the same computer and solve the problems on the fly.