PDA

View Full Version : Problem booting FC 9 with 2.6.25.3-18 kernel



sidebrnz
22nd May 2008, 03:14 AM
My system was acting a tad funny, so I decided to reboot and see if it cleared things up. This is the first time since the 2.6.25.3-18 kernel was installed. Three times it got to the blue Fedora screen then hung, requiring a rest each time. Selecting the earlier, 2.6.25.3-14 kernel got me up and running. Don't know what's wrong, as I'm not using any special drivers or anything. (Yes, I have an ATI card, but it's an old one and works with the generic driver.) Has anybody else had this problem?

ebelog
22nd May 2008, 04:09 AM
Try to make it a point to reboot soon after installing a new kernel. It's nice to know if there are any problems sooner rather than later.

There are a few things you can try:
1. Rebuild the initial ram disk for the new kernel. Even if this doesn't work, it sometimes points out errors that you didn't notice. Note that the version number is a guess based on the kernel version you provided. Check the files in /boot to get the exact kernel version your system is using.

/sbin/mkinitrd /boot/initrd-2.6.25.3-14.fc9.i686.img 2.6.25.3-14.fc9.i686


2. If that doesn't work, reinstall the new kernel. You'll probably need to remove it before reinstalling it.

3. Modify /boot/grub/grub.conf so that it boots to the previous kernel by default.

sidebrnz
22nd May 2008, 04:29 AM
The numbers I gave were based on the entries in grub.conf. Checking in /boot, they're correct. Thanx, however, for the reminder. I'll try what you suggest and report back...

sidebrnz
22nd May 2008, 04:43 AM
Checking further, your instructions would do the rebuild for the older kernel, the one that works. I'll try it for the newer one.

After backing up the current version, I tried it and got an error that the file already exists. I'm not willing to remove them completely until i know more about what I'm doing. Can somebody point me to an explanation of exactly what's going on here, so that I'm not working blindly. Note that the system's usable right now, so it's not urgent.

ebelog
23rd May 2008, 03:22 AM
The initrd file is the "initial ram disk" which is used to load the drivers necessary to boot the system. It's built based on the kernel version and the /etc/modprobe.conf file to load those drivers so the system can fully boot up.

Sorry about the version numbers; I grabbed the wrong one from your post. It's safe to backup the initrd file that is there, and rebuild it. Putting the old one back is as easy as renaming it back to the original name.

Here's a safer version:

cd /boot
cp initrd-2.6.25.3-18.fc9.i686.img initrd-2.6.25.3-18.fc9.i686.img.bak
/sbin/mkinitrd /boot/initrd-2.6.25.3-18.fc9.i686.img 2.6.25.3-18.fc9.i686

This will not prevent the working 2.6.25.3-14 kernel from booting, because it's only associated with the 2.6.25.3-18 kernel. If there is any problem at all, you just need to put the original back in place:

cd /boot
mv initrd-2.6.25.3-18.fc9.i686.img.bak initrd-2.6.25.3-18.fc9.i686.img

If it makes you uncomfortable, I would suggest just sticking with your working kernel, unless you are running into a problem that you think the newer kernel would solve.

amfpg
23rd May 2008, 04:12 AM
maybe you can disable selinux too
at grub menu select your fedora core 9, then press "e" and then
add this


selinux=disabled

sidebrnz
23rd May 2008, 06:53 AM
Thanx for your help, but alas, it turned out not to be needed. I found with experiment that given about five minutes, either kernel would boot. This made me suspect that something wasn't starting properly and timing out. Then, I lost my mouse cursor although I could tell that the mouse was still moving. I was able to get to another desktop and use it to reboot, but it hung.

I have a USB mouse that was connected through a PS2 adapter because I dual-boot Win98. I took out the adapter, put the mouse on a proper port and it's working. *Sigh!* So it goes. I suspect that all of my "Oh, it's working now" problems I've had with Fedora 9 had the same cause.