PDA

View Full Version : FC8 Install: Can ping externally but can't do yum update...



vfulco
21st May 2008, 07:52 PM
Dear Fedora Experts-

An auto update for my FC7 box trashed it and I was forced to do an upgrade to FC8 (not full clean install). It went without a hitch but my Nvidia settings (which were perfect previously) have gone haywire on my 7100 GS card. Running the NVIDIA installer states that my kernel and kernel-devel need to be updated. I've tried to do a 'yum update' but get either "cannot retrieve repository metadata' error or 'cannot find host' error. I vaguely recall having a static IP but I'm not very good at the networking issues/settings. I've used most of the tips on the site including 'yum clean all', etc. to no avail. Would prefer not to go the Livna route and complicate things in the future although I did try that as well already. Also tried adding a 'module' section to my /etc/X11/xorg.conf with no response.

I would do a clean install but it took forever to get all the settings right and concerned my backups to DVD are not recent enough.

Running this on a Tyan Quad Core H2000M with 4GB DRAM.

Would appreciate any trailheads.

TIA,

Vince

juanfgs
21st May 2008, 08:12 PM
Are you saying that you can ping for example yahoo.com and it works? or are you doing ping to a IP outside?
If it's the latter, Do you have DNS correctly configured? check your /etc/resolv.conf

vfulco
21st May 2008, 08:16 PM
I can ping to www.yahoo.com and the like. When I try 'yum update', I receive the transaction summary but then a <urlopen error (113, 'no route to host')> error for each package which needs upgrading.

vfulco
21st May 2008, 09:44 PM
Thanks for your consideration. I'm going to backup my home directory and do a clean install even if a painful process. The conflicts are still too numerous to address even though I was able to finally get yum update to work.