PDA

View Full Version : Monitor woes F9 First boot



Daniel114
20th May 2008, 07:45 PM
Hello,

been away from the fedora scene for a while, and I must say I think its the first time the whole 'riding a bike metaphor' isnt ringing true, I'm completely lost again :rolleyes:

Okay so I'm trying to install Fedora 9 on my PC. I changed the monitor resolution during the install and it seemed to display at 1680x1050, all went well and much rejoicing was had

However on my first boot teh monitor went into powersave and wouldn't come out. This is the first time I've tried using this monitor on a nux install, I realise there are issues with it (Dell LCD 20" Widescreen) however I was going to tinker with that once I got my memory back, furthermore I've lost my bible I was compiling of useful work arounds, I know I've had this happen before on me.

All I remmembered was to boot into rescue mode, mnt sysimage, backed up and opened xorg.conf. Where monitor is it simply says

section "screen"
identifier "screen 0"
device "videocard 0"
default depth 24
subsection "display"
viewport 0 0
depth 32
end subsection
end section

I'm going from memory there so might not be 100% correct. I know the monitor can only be displayed at 60hz, so I'm looking to change that, however I can only remmember to change stuff once the values are already in there

as they say, a little bit of knowledge...

Thanks for all your help

majikthise
20th May 2008, 08:15 PM
For reference here is a copy of the relevant sections from my /etc/X11/xorg.conf
my TFT is also 60Hz


Section "Monitor"
Identifier "Monitor0"
ModelName "LCD Panel 1024x768"
HorizSync 31.5 - 48.0
VertRefresh 56.0 - 65.0
Option "dpms"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Daniel114
20th May 2008, 09:09 PM
Thanks for that,

I tried applying the relevant parts to my xorg file, yet it still goes into powersave as udev starts

fyrie
20th May 2008, 09:16 PM
Try setting the driver to "vesa" in xorg.conf

If that doesn't work, boot to runlevel three (search to find out how to do that) and then login as root. then
su yourUserName
startx -- -ignoreABI

If that works, you'll may have to do that every time you boot up.