PDA

View Full Version : How do I get F9 to install to a USB External ?



OralDeckard
20th May 2008, 05:06 PM
I have a 1TB Fantom Drive that works perfectly as a storage device.

This is my first attempt at installing to a USB external drive, and searches on the subject say it is no problem. Yet when I try it I select Custom Install, and Anaconda can't fina any drives. Bios shows the drive just fine, but it does not show up in Anaconda.

Does anyone know of a problem with Fantom Drives ? Or has anyone experienced a failure to locate USB external drives during installaition ?

majikthise
20th May 2008, 05:12 PM
I don't know if this will help. But how about checking the BIOS for legacy USB support. ENABLE it

OralDeckard
20th May 2008, 06:09 PM
Thank you MajikThise. I checked, and Legacy USB Support is enabled. Still no go. :(

stoat
20th May 2008, 06:18 PM
Hello OralDeckard,

Did you know that you posted this twice (http://forums.fedoraforum.org/forum/showthread.php?t=189201)? Probably an accident caused by the long delays.

majikthise
20th May 2008, 06:25 PM
Did the Fantom drive come pre-formatted?

What's it formatted as - NTFS?

OralDeckard
20th May 2008, 06:27 PM
No,I didn't. After trying once to post it, I got New Post open in Gedit :O
I checked for a double post and didn't see onw. Sorry.

So my next effort will be to attached a Maxtor external and see what happens, then attach each of them to different computers and see how they react.

stoat
20th May 2008, 07:05 PM
Sorry.Well, I only meant that I wrote in the other one.

OralDeckard
20th May 2008, 07:15 PM
No Magikthise, the drive was not formatted NTFS. It had empty space up front for the installation I had intended to make, and one ext3 and one fat32 partion in an extended partition.

I took it to a Dell and it was recognized. So now the install is proceding.

Fingers crossed.

OralDeckard
20th May 2008, 08:31 PM
Well I got it installed on the Dell. Then I re-attached it to the original computer where I tried to install it initially, and when I boot all I get is "Grub hard disk error." I suspected it wouldn't recognize it to boot if it couldn't recognize it to install, even though BIOS tells its name quite accurately. Its kind of like the problem I had earlier with SATA drives being recognized by BIOS, but not by Fedora 8 or Fedora 9 Preview to install. The final relese of F9 installed and ran, but still not F8.

So it has to be something with the MB or BIOS. Like with the SATA problem I will start with updating the BIOS, thoghh that never did work for the SATA problem.

majikthise
20th May 2008, 08:58 PM
Looks like your BIOS doesn't support 48bit LBA. Or it just doesn't like the partitioning scheme.

OralDeckard
21st May 2008, 05:33 PM
As stated, it is a 1 terebit drive that works fine as a storage drive. It wouldn't if BIOS did not support 48 bit LBA. The partitioning scheme is:
/boot 101 MB
/home 25 GB
/ 10 GB
extended 896 GB
swap 2 GB
ext3 373 GB
fat32 520 GB

So I updated the BIOS. No change.
So I tried it on another computer. Hung during BIOS, even when the BIOS was set to boot the Windows HD.
So I tried it on another computer. Got through BIOS, then put 'GRUB" on the screen and hung.

Dangermouse
21st May 2008, 05:47 PM
Hi
i dont know if this is any use to you or not but, i installed f9 live on a thumdrive, it will boot off any computer as the live cd does, and any changes you make files/extra programs are saved, works very well and is easy to set up etc... and you get to keep anyfiles already on the drive.
https://fedorahosted.org/liveusb-creator

OralDeckard
21st May 2008, 06:00 PM
And is handier than lugging around a clucky external with cords :|

But my purpose includes using dd and tar to image various systems, and thumb drives just aren't big enough yet. So I have to use a hand drive.

But for removing virii from Windows System32 where they are protected by Windows, a thumb drive sounds great. My problem with the various live CDs is that, even in root and with ntfs-3g installed, they don't have the authority to remove a file. I have to remove the Laptop HD, hook it up with a laptop IDE adaptor, and do it with Fedora 8.

OralDeckard
21st May 2008, 08:39 PM
So I have tried this now on 5 different computers, and all have failed to boot it. Each can access the 520 GB fat32 partition from Windows, so they can all see and use the drive.

The search showed all kinds of success stories, so I tried it, and no joy :(

OralDeckard
21st May 2008, 09:08 PM
So, Dangermouse, what size thumb drive you got? 32 gig or what?

They don't make thumb drives big enough huh? Better say I spect! I just got back from NewEgg where you can pick up a 32 gig Patriot for $153 :O

But could I boot Fedora from it?

Dangermouse
21st May 2008, 09:15 PM
Hi did you mark the drive as bootable
http://fedoraproject.org/wiki/FedoraLiveCD/USBHowTo#head-dfb47e634ded82b5a32a5203e88d20508069b350