PDA

View Full Version : Install F9 & F8



kraseef
20th May 2008, 01:20 PM
I have given up and it is time to ask for help!

I have been trying to install F9 along side F8. I do have F8 running prefectly with Four kernels. When I came to install F9 I reached to to "Disk Druid". The installation utility did not allow me to resize the windows partition so I deleted it. Using the free space I manged to creat a partition with mount point "/". The said partition is known to Fedora as sda1. It installed F9 on it and it is working but it Halts some times when decompressing the Kernel.

In the grub menu it does not show the kernels of F8. The problem is F9 does not see F8 at all. I could not edit the grub.conf !

I booted on to rescue mode using F9 installation DVD and directed it to F8 VolumeGroup.

I managed to mount F9 partions, sda1 and edited F9 grub.conf to include F8 kernels. This has enabled grub to list F9 and F8 kernels.

The problem still remains as follows:
1. When booted to F9, it cannot see F8 installation.
2. F9 sometimes halts when strting to decompress the kernel.


I have tried to creat a LVM group for F9 but it does not seem to accept to install F9 in it calming that boot partition cannot be inside a logical drive.

The way I see things happening here is the boot partition can be common for F8 & F9.

I just do not knwo who to configure things properly !!

CAN ANY BODY HELP?
_________________________________________
The curren setup is as follows:

LVM
VolGroup00
LogVol00: ext3
LogVol01: swap
Hard Drives
SDA
sda1 /
free space
sda2 /boot
sda3 extended
sda5 volgroup00
sda4 ntfs (system restore for windows)
__________________________________________

sideways
20th May 2008, 01:52 PM
You might wipe the F8 /boot partition if you select it as the /boot partition for F9 (I'm not sure what anaconda will do, but best to be on the safe side)

Either create the default layout in the free space (a /boot partiton + a LVM group with / and swap) or just create one ext3 partition containing / and /boot. Now boot into F9 and then mount /dev/sda2

su -
mkdir /mnt/sda2
mount /dev/sda2 /mnt/sda2


Now copy all the title stanzas from /mnt/sda2/boot/grub/grub.conf to your F9 grub.conf (/boot/grub/grub.conf) and you should be set to boot F8 (all 4 kernels) and F9 all from grub.

kraseef
20th May 2008, 02:13 PM
Sideways,
Thaks for the reply.

When I tried to creat /boot partition it is not allowing me claiming that it cannot creat more than 4 primary. When I tired to put it in the LVM logicalVol it objects. This japardizes the hole operation.

As I said in my original post, I have done all that and now I can boot to F8 & F9. But F9 Can not see F8 and but F8 can see and mount the F9 (sda1).

I am to afraid to delete /boot of F8 as I am not sure how anaconda would react to it.

sideways
20th May 2008, 02:22 PM
Sorry, I thought sda4 and sda5 were both in the extended partition sda3, you should post fdisk -l. But no matter, you said you installed F9 in one ext3 partition, sda1? (Where did you put the swap partition?)

F9 doesn't need to see F8, it just needs to see F8's /boot partition sda2, and then you just copy the F8 grub stanzas to the F9 grub.conf and reboot.(you may need to run grub-install /dev/sda if you didn't install grub to the mbr when you installed F9)

kraseef
20th May 2008, 02:23 PM
For clarity I am attaching here the Gparted partiton layout.

Below is the result of fdisk -l from within F9.


[root@localhost ~]# fdisk -l

Disk /dev/sda: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x80028002

Device Boot Start End Blocks Id System
/dev/sda1 * 1 6374 51199123+ 83 Linux
/dev/sda2 23091 23115 200812+ 83 Linux
/dev/sda3 23116 29464 50998342+ 5 Extended
/dev/sda4 29465 30401 7526452+ 7 HPFS/NTFS
/dev/sda5 23116 29464 50998311 8e Linux LVM

Disk /dev/dm-0: 50.0 GB, 50096766976 bytes
255 heads, 63 sectors/track, 6090 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00000000

Disk /dev/dm-0 doesn't contain a valid partition table

Disk /dev/dm-1: 2080 MB, 2080374784 bytes
255 heads, 63 sectors/track, 252 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x30307800

Disk /dev/dm-1 doesn't contain a valid partition table