PDA

View Full Version : dependency resolution failed



bob_knab
20th May 2008, 05:45 AM
alas-
i have upgraded from F8 to F9
from Deluge -Bit Torrent client
individual CD disk files 1 to 6 down load
and have no problems with the
F9 upgrade did not do a new install
the F9 seams to be bright and shiny
internet works well -
however -- when i go to use
Update System -
to install the 3-bug fixes and 59 updates available

i get ------- a flag saying ------------------------------------

MISSING DEPENDENCY
libcrypto.so.6
nccped by deluge-0.5.9.0-1.fc.i386 (updates )
missing dependency : libss I so6 is needed
by package deluge - 0.5.9.0.-1 FC8 386 ( updates )

how is this missing dependency installed
is it on one of the new F9 disk and did it
get deleted during the up grade -----

thank you
bob_knab

knab@twlakes.net

Seve
20th May 2008, 05:49 AM
Hello:
Try using yum and

yum update deluge

Then give the 59 updates a whirl again

Seve

bob_knab
20th May 2008, 07:58 AM
THANKS for the reply
this is what i did
su ------------------------------------------------------------------
[root@localhost bob]# yum update deluge
Loaded plugins: kmdl, refresh-packagekit
livna | 2.1 kB 00:00
fedora | 2.4 kB 00:00
fedora-debuginfo | 1.9 kB 00:00
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package deluge.i386 0:0.5.9.0-1.fc8 set to be updated
--> Processing Dependency: libssl.so.6 for package: deluge
--> Processing Dependency: libcrypto.so.6 for package: deluge
--> Finished Dependency Resolution
deluge-0.5.9.0-1.fc8.i386 from updates has depsolving problems
--> Missing Dependency: libcrypto.so.6 is needed by package deluge-0.5.9.0-1.fc8.i386 (updates)
deluge-0.5.9.0-1.fc8.i386 from updates has depsolving problems
--> Missing Dependency: libssl.so.6 is needed by package deluge-0.5.9.0-1.fc8.i386 (updates)
Error: Missing Dependency: libcrypto.so.6 is needed by package deluge-0.5.9.0-1.fc8.i386 (updates)
Error: Missing Dependency: libssl.so.6 is needed by package deluge-0.5.9.0-1.fc8.i386 (updates)
[root@localhost bob]#

i keep getting

file -- libssll.so.6 -- is needed

i looked on the web and other fedora
users have this problem it seams that
this is a needed install file
any ideas

thanks again for your time bob_knab

Seve
20th May 2008, 08:00 AM
Hello:
What is the output of

yum repolist


Seve

bob_knab
20th May 2008, 08:27 AM
Hello

yum repolist output

root@localhost bob]# yum repolist
Loaded plugins: kmdl, refresh-packagekit
repo id repo name status
InstallMedia Fedora 8 enabled
fedora Fedora 9 - i386 enabled
fedora-debuginfo Fedora 9 - i386 - Debug enabled
livna Livna for Fedora Core 9 - i386 - Base enabled
livna-testing-source Livna for Fedora Core 9 - i386 - Testing enabled
updates Fedora 8 - i386 - Updates enabled
updates-debuginfo Fedora 8 - i386 - Updates - Debug enabled
updates-source Fedora 8 - Updates Source enabled
[root@localhost bob]#

back to you again Seve

Seve
20th May 2008, 08:38 AM
Hello:

Did you not update to Fedora 9 ?

If so, I'm not sure how you did it, but you still have Fedora 8 repos active ...... which is not a good thing :)

Try disabling the following repos

InstallMedia Fedora 8
fedora-debuginfo Fedora 9
updates-debuginfo Fedora 8
livna-testing-source Livna for Fedora Core 9
updates Fedora 8 - i386 - Updates
updates-debuginfo Fedora 8 - i386 - Updates
updates-source Fedora 8 - Updates Source


from a terminal

cd /etc/yum.repos.d
and then use your favourite editor and set (for each of the repos)

enabled=1
to
enable=0

When you are finished, try
yum clean all
then
yum check-update

Seve

bob_knab
20th May 2008, 10:50 AM
i am out of here for tonight
till later
bob_knab

bob_knab
21st May 2008, 05:45 AM
THANKS STEVE *
for all your help
i could not get all the bugs out
i did a new install to avoid the
ghosts of fedora8 past -
f9 is working with no problems -
blessings
bob_knab