PDA

View Full Version : Fedora 9 Upgrade Freeze



rabbuhl
19th May 2008, 04:01 PM
I tried upgrading from Fedora 8 to Fedora 9 last night. All of the packages installed correctly but during the last part of the install it hung during the boot loader creation. I rebooted the machine and tried to reinstall Fedora 9 but it would not proceed because of an error reading the library (something like that). My system does not boot any more so I need to figure out a way to either go back to Fedora 8 or to re-install Fedora 9. Any suggestions?

rabbuhl
19th May 2008, 08:31 PM
I followed advice from another thread and used recovery mode to get a command prompt. At the command prompt I typed
# chroot /mnt/sysimage
# grub-install /dev/sda

After that I rebooted and it told me to run fsck without -a or -p. Following the fsck the system was able to finally boot!!

However, it now shows the message: "Cannot retrieve repository metadata" for fedora.

sideways
20th May 2008, 12:01 AM
Do you have an internet connection? The fedora repo mirrors may be slow this week.

rabbuhl
24th May 2008, 10:57 AM
I had numerous problems but they are all fixed. Not a smooth upgrade.

1. Received a "BadName" error which prevented the UI from working correctly. Needed to rename /etc/X11/xorg.conf to /etc/X11/xorg.conf.old
2. Dhcp would not start because it did not like "host betti" in the dhcpd.conf file.
3. Ssh did not work because ListenAddress was set to :: in sshd_config.
4. My intranet would not start because eth1 was not a trusted interface in ip6tables.

Why did FC9 overwrite my firewall settings?
There is now iptable and ip6tables. Are both of these required for FC9?