PDA

View Full Version : no boot after update fedora 9



sergiorosales
18th May 2008, 05:28 PM
Hello

After install update fedora 9 from fedora 8 in my lapton (acer, travel mate 4420) the grub fail and repair using grub-install. Then work fine and the system made the first update (kernel, etc), and when reboot I obtaine the next message:

Decompressing Linux .... done.
Booting the Kerne.
REd Hat Version nash version 6.0.52 starting
hub 1-0:1-0: unable to enumatrate USB device on port 8
Unable to access resume device (/dev/dm-1)
mount: could noty find filesystem '/dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc/: Nos such file or directory
...
...

And stop the booting.

I apreciated any help

Thanks

sergiorosales
18th May 2008, 09:07 PM
Hi

I continue cheking, and when booting with the previous kernel don't have the problem, only in the last kernel

My machine is a Acer Lapton Intel coredou with 2 Gb of RAM

stevea
18th May 2008, 09:50 PM
The messages indicate that grub loaded the kernel & initrd, but could not find your root file system (an LVM).

Did you just select a different kernel at the grub prompt and then succeed ?
If so I'd suggest you use yum and erase the newer kernel and re-install it.
You'll probably get the same result, but it's just possible that the new initrd wasn't
properly outfitted.

Can you explain the "usb" message ? Are you using a usb drive ?

lynnevan
8th June 2008, 07:06 AM
The messages indicate that grub loaded the kernel & initrd, but could not find your root file system (an LVM).

Did you just select a different kernel at the grub prompt and then succeed ?
If so I'd suggest you use yum and erase the newer kernel and re-install it.
You'll probably get the same result, but it's just possible that the new initrd wasn't
properly outfitted.

Can you explain the "usb" message ? Are you using a usb drive ?
STEVEA
I have the same problem as "sergiorosales". Running Fed8 on a desktop updatingto latest kernel -> from 2.6.24.7-92.fc8 -> 2.6.25.4-10.fc8. The USB message is only a symptom. In my case it's a scanner. I unplug it and that message goes away, but still fails as seriorosales points out. I can still boot the old kernel. Have already used yum to uninstall new kernel, then downloaded it again via the automatic update facility (pirute?). Same problem - panic before the console finishes loading. No LVM here. fed8 is (hd1,1). Through grub> during boot, no problems setting root, kernel, or initrd. But after typing boot, -->>

mount: could not find filesystem '/dev/root'
setuproot: moving /dev failed: No such file or directory
setuproot: error mounting /proc/: No such file or directory

Have twice run "e2fsck -f -y -v /dev/sdb2" w/ no surprises.

Any help, suggestions, ideas greatly appreciated!!

ps: upgraded kernel of another desktop fed8 (same mobo, cpu, ram, video card) and biggest problem was getting NVIDIA running again. No kernel problems.

Thanks for any ideas or leads.

lynnevan

lynnevan
8th June 2008, 08:18 AM
FIXED!!

My problem was self-inflicted. I never let the OS write to my mbr, so I was saving time by copying the new boot kernel into my grub floppy & pendrive from the computer that had already upgraded. The problem was in the root=LABEL= ******. The one that was upgraded was root=LABEL=fedright. The one I was having trouble with is called "fedleft". So when fedleft went looking for "fedleft" and found "fedright", it naturally freaked out.
After I fixed that, I ran nvidia-installer -a --update and I'm up and running!!

Hope sergiorosales problem is as simple.

Here's and easy was to rewrite the mbr (stolen from mandriva) called install.sh run from the grub dir -

Put this in a text editor and chmod 755 and copy it into /boot/grub.

grub --device-map=/boot/grub/device.map --batch <<EOF
root (hd1,1) --------------------------------------------<<<<<change this as necessary!!
setup --stage2=/boot/grub/stage2 (hd0)
quit
EOF

Then just run "sh install.sh."

Hope this helps.

good luck!

lynnevan

JotaBr
27th December 2008, 11:19 PM
I had fixed that changing entry for swap into /etc/fstab. It's now:

tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
/dev/dm-0 / ext3 defaults 1 1
#Entry for /dev/sda3 :
UUID=f1e13c99-da4e-4d12-85cb-fffea6aff49d /boot ext3 defaults 12
#Entry for swap
/dev/VolGroup01/LogVol01 swap swap defaults 0 0
#Entry for /dev/sda2 :
UUID=2C88743C8874071C /media/HP_RECOVERY ntfs-3g ro,locale=en_US.UTF-8 00
#Entry for /dev/sda1 :
UUID=9C08795108792B80 /media/Vista ntfs-3g defaults,locale=en_US.UTF-8 00

Then I had executed (for x86_64):

/sbin/mkinitrd -f initrd-2.6.27.7-134.fc10.x86_64.img 2.6.27.7-134.fc10.x86_64