PDA

View Full Version : F9 and grub error 2



daneel971
18th May 2008, 10:39 AM
I just performed an hard disk install of F9 in my usual way: I have two fedora partition so I keep F(x-1) when I install F(x).
In this case, I have F8 on sda2 and I placed F9 on sda1 (in place of F7). Grub was installed with F8 so I didn' reinstall it and just added an entry in the existing configuration.
When booting, I get

Error 2: Bad file or directory type
I suspected having mispelled the kernel/initrd file names, so I checked at the grub command prompt, but the problem is different. Even if grub does see the F9 partition , it doesn't see the files on it.
Back in F8, I can mount sda1 and browse the filesystem with no problem at all.
Does anybody have a clue? :)

stevea
18th May 2008, 12:11 PM
What does the grub command "find" see ?
find (hd0,0)/<tab><tab>

daneel971
18th May 2008, 12:56 PM
Absolutely nothing. It gives the same error. It works fine with (hd0,1), that is my F8 partition.

daneel971
18th May 2008, 01:43 PM
I took a look at the grub srpm: there's a huge patch in it - so I suspected that this particular version of grub is needed - I reinstalled grub from F9 and...
well, it worked. :)