PDA

View Full Version : m4a for xmms



fusion1275
16th May 2008, 04:53 PM
Hi all,

Can anyone point me to an up-to-date way of getting xmms playing m4a music files? I am pulling my hair out trying all sorts of links/files/rpm's etc etc and they are too old or just dont actually work.

I am running Fedora 8 and xmms version 1.2.10

Many thanks in advance.

PabloTwo
16th May 2008, 05:45 PM
There was a fairly recent thread on this very subject. Closest thing I could find on the net is a plug-in for xmms to play acc (m4p) files in rpm form for F7. Maybe you could get that to work, or maybe you've already tried (?). Be sure to look at the "requires" list on the link below.

http://www.rpmfind.net/linux/RPM/freshrpms/fedora/7/xmms-aac/xmms-aac-2.5-1.fc7.i386.html

nacross
26th May 2008, 08:11 PM
I just installed a xmms plugin to play m4a. I was looking for the name of the plugin or codec needed and this post gave me the answer.


Firts enable livna repos

Go to http://rpm.livna.org/rlowiki/ and click on the right version or just get the file with a command like:


wget http://rpm.livna.org/livna-release-9.rpm

and install the aplication... I did a double click on the file and typed root password when I was asked. But I think that you may use the following command as su.


rpm -i livna-release-9.rpm

Then I installed the package that I wanted from livna, I did the whole thing in one line (again as su)


yum install xmms xmms-mp3 xmms-aac

Actually it does not installs xmms-acc but instead installs xmms-faad2.
I really didn't care much, as finishing the install I opened one m4a file and it worked.

Hope it works for you

Neville