PDA

View Full Version : Fusion-Icon gives White Screen, Desktop Effects OK?



CraigWatson
16th May 2008, 04:24 PM
Hi everyone,
I apologise in advance if this is in the wrong forum - technically I guess it should be Software but I guess it could also be hardware-related!

I installed the 64bit version of Fedora 9 last night and it's up and running with no problems at all, except fusion-icon. The standard Desktop Effects works fine, which suggests that it isn't a hardware computability issue (also, fusion-icon worked fine on the same laptop on Fedora 8 32bit - details in signature).

When I run fusion-icon from the command-line, it seems to load, then produces a completely white screen.


# Xorg configuration created by pyxf86config
Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "TouchPad" "CorePointer"
EndSection

Section "InputDevice"
Driver "synaptics"
Identifier "TouchPad"
Option "SendCoreEvents"
Option "Protocol" "auto-dev"
Option "SHMConfig" "on"
Option "TapButton1" "1"
Option "TapButton2" "2"
EndSection

Section "InputDevice"
# keyboard added by rhpxl
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "intel"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

Any help would be greatly appreciated :)

Cheers,
Craig

Olcay
16th May 2008, 06:23 PM
Hi,
Take a look here : http://forums.fedoraforum.org/showthread.php?p=1010055#post1010055

Enabling indirect rendering solved white screen problem but compiz-fusion is very slow with firefox and menus.

https://bugzilla.redhat.com/show_bug.cgi?id=444328

Olcay
18th May 2008, 02:31 PM
I fixed firefox and menus slowness problem with indirect rendering enabled.

Added this to xorg.conf in section device


Option "AccelMethod" "xaa"