PDA

View Full Version : Fedora 9 VNC Server



ov10fac
16th May 2008, 01:52 PM
I have upgreded Fedora 9 and have attempted to get the vnc server running. Unfortunately I keep getting errors that won't allow the server to run. (VNC worked fine on this machine under 8)

Here is the log file dump.

Xvnc Free Edition 4.1.2
Copyright (C) 2002-2005 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
Underlying X server release 10499901,


Fri May 16 07:17:08 2008
vncext: VNC extension running!
vncext: Listening for VNC connections on port 5903
vncext: created VNC server for screen 0
SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/3560,unix/unix:/tmp/.ICE-unix/3560
Could not launch dbus-daemon
dbus-daemon exited unexpectedly
**
** ERROR:(gsm-dbus.c:118):gsm_dbus_daemon_start: assertion failed: (dbus_daemon_
pid != 0)

There appears to be a problem in the c code some place. Anybody else seeing this problem? Anyone have a solution?

Thanks in advance.

marcher
16th May 2008, 11:01 PM
Hi,

I'm seeing the same thing. Any help would be much appreciated.

[root@localhost .vnc]# !tail
tail -f /root/.vnc/localhost.localdomain:1.log
Underlying X server release 10499901,


Sat May 17 01:54:07 2008
vncext: VNC extension running!
vncext: Listening for VNC connections on port 5901
vncext: created VNC server for screen 0
Failed to execute message bus daemon /bin/dbus-daemon: Permission denied. Will try again without full path.
Failed to execute message bus daemon: Permission denied
EOF in dbus-launch reading address from bus daemon


Cheers,

Marc

Firewing1
16th May 2008, 11:04 PM
Do you have any SELinux errors in your /var/log/messages file?
Firewing1

ov10fac
17th May 2008, 04:29 AM
Nothing in the SELinux log. Thanks.

Firewing1
17th May 2008, 03:40 PM
dbus-daemon exited unexpectedly
That's the part that's worrying me. Have you checked in the /var/log/Xorg.*.log to check for errors? The error may appear in /var/log/messages as well.
Firewing1

ov10fac
17th May 2008, 07:27 PM
I do have one error in the Xorg file. Here it is:

(EE) R128(0): No DFP detected

the messages log has these errors, none of which seem to be associated with vnc.

May 15 06:43:43 stargazer nm-system-settings: ifcfg-fedora: error: Ignoring loopback device config.
May 15 06:50:15 stargazer kernel: tomboy[2960]: segfault at 2dc2548 ip 02dc2548 sp bfeb3d8c error 4 in libbonoboui-2.so.0.0.0[3033000+65000]
May 15 07:00:58 stargazer kernel: end_request: I/O error, dev fd0, sector 0
May 15 07:01:01 stargazer kernel: end_request: I/O error, dev fd0, sector 0
May 15 07:01:16 stargazer kernel: end_request: I/O error, dev fd0, sector 0
May 15 07:40:05 stargazer kernel: tomboy[2867]: segfault at 4c45548 ip 04c45548 sp bfd8a81c error 4 in libjpeg.so.62.0.0[4c90000+22000]
May 15 07:51:02 stargazer kernel: tomboy[3048]: segfault at 72d8548 ip 072d8548 sp bf988a7c error 4 in libstdc++.so.6.0.10[7319000+e5000]
May 15 07:55:22 stargazer kernel: tomboy[3270]: segfault at 2172548 ip 02172548 sp bf95436c error 4 in libkeyutils-1.2.so[225c000+2000]
May 16 06:48:34 stargazer kernel: tomboy[18283]: segfault at 9291548 ip 09291548 sp bfa68dcc error 4

Many thanks

dogbert_2001
18th May 2008, 02:12 PM
I get the same thing.

If I run vncserver as a user from the commandline, I get the desktop.
If I run vncserver as a service, I get a gray screen.

As user:

vncext: VNC extension running!
vncext: Listening for VNC connections on port 5901
vncext: created VNC server for screen 0
SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/21524,unix/unix:/tmp/.ICE-unix/21524
Window manager warning: Failed to read saved session file /home/xxx/.metacity/sessions/default1.ms: Failed to open file '/home/xxx/.metacity/sessions/default1.ms': No such file or directory
Window manager warning: Log level 32: could not find XKB extension.
Failure: Module initalization failed
libnm_glib_nm_state_cb: dbus returned an error.
(org.freedesktop.DBus.Error.ServiceUnknown) The name org.freedesktop.NetworkManager was not provided by any .service files

** (nm-applet:21567): WARNING **: <WARN> applet_dbus_manager_start_service(): Could not acquire the NetworkManagerUserSettings service as it is already taken. Return: 3


(nm-applet:21567): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

** (nautilus:21544): WARNING **: Unable to add monitor: Not supported

** (gnome-panel:21543): WARNING **: panel-applet-frame.c:1285: failed to load applet OAFIID:TomboyApplet:
System exception: IDL:Bonobo/GeneralError:1.0 : Child process did not give an error message, unknown failure occurred

NetworkManager is disabled.

As service:

vncext: VNC extension running!
vncext: Listening for VNC connections on port 5901
vncext: created VNC server for screen 0
Failed to execute message bus daemon /bin/dbus-daemon: Permission denied. Will try again without full path.
Failed to execute message bus daemon: Permission denied
EOF in dbus-launch reading address from bus daemon
SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/26555,unix/unix:/tmp/.ICE-unix/26555
** Message: another SSH agent is running at: /tmp/ssh-PxXOW26555/agent.26555
Could not launch dbus-daemon
dbus-daemon exited unexpectedly
**
** ERROR:(gsm-dbus.c:118):gsm_dbus_daemon_start: assertion failed: (dbus_daemon_pid != 0)

xstartup:

#!/bin/sh

vncconfig -iconic &
# Uncomment the following two lines for normal desktop:
unset SESSION_MANAGER
exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
twm &

seths97
19th May 2008, 06:08 PM
Same issue here. Disabled selinux and firewall - thought i was doing something wrong until i came across this thread and realized it's a bigger issue.

Here is the log when i start a session:

Xvnc Free Edition 4.1.2
Copyright (C) 2002-2005 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
Underlying X server release 10499901,


Mon May 19 12:51:18 2008
vncext: VNC extension running!
vncext: Listening for VNC connections on port 5901
vncext: created VNC server for screen 0
Started none

No errors there, but did find this in messages at startup:

May 19 12:47:58 fedora9 bonobo-activation-server (root-8786): could not associate with desktop session: Failed to connect to socket /tmp/dbus-5oMhTjyfYi: Connection refused


and of course the viewer times out saying a socket operation was attempted to an unreachable host

:confused:

spk037
19th May 2008, 07:31 PM
i just installed F9 on my lappy but havent attempted vmware yet. Do you guys have xinetd installed ??

twhchan
20th May 2008, 03:40 PM
Same problem here, any help would be appreciated, thank.

------------------------------------------------------------------------------
Xvnc Free Edition 4.1.2
Copyright (C) 2002-2005 RealVNC Ltd.
See http://www.realvnc.com for information on VNC.
Underlying X server release 10499901,


Wed May 21 06:45:07 2008
vncext: VNC extension running!
vncext: Listening for VNC connections on port 5901
vncext: created VNC server for screen 0
Failed to execute message bus daemon /bin/dbus-daemon: Permission denied. Will try again without full path.
Failed to execute message bus daemon: Permission denied
EOF in dbus-launch reading address from bus daemon
SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2545,unix/unix:/tmp/.ICE-unix/2545
** Message: another SSH agent is running at: /tmp/ssh-KEltMi2545/agent.2545
Could not launch dbus-daemon
dbus-daemon exited unexpectedly
**
** ERROR:(gsm-dbus.c:118):gsm_dbus_daemon_start: assertion failed: (dbus_daemon_pid != 0)

topping
20th May 2008, 09:55 PM
Same problem here as well. Has anyone filed a bug on this yet?

What's strange is there are no messages being put into selinux logs or in dmesg. A selinux error that isn't logged? Isn't that a security issue?!?

AcidMoo
21st May 2008, 01:44 AM
I have experienced this problem too. I ended up disabling selinux. Putting selinux into permissive mode didn't solve it, oddly, but disabling it seemed to. Running GNOME in vncserver now works fine, but I still can't get the KDE desktop, which is my preferred desktop, to start.

twhchan
23rd May 2008, 08:51 AM
No guru can help? :confused:

dogbert_2001
25th May 2008, 04:10 PM
https://bugzilla.redhat.com/show_bug.cgi?id=446604
https://bugzilla.redhat.com/show_bug.cgi?id=447631

Lp3
28th May 2008, 01:07 AM
hello, i've just installed F9 on my machine from F7. trying to run vncserver as normal user I get:

[test@redtac ~]$ vncserver
You will require a password to access your desktops.
Password:
Verify:
sh: /home/test/.vnc/redtac:1.log: Permission denied
sh: /home/test/.vnc/redtac:1.pid: Permission denied

New 'redtac:1 (test)' desktop is redtac:1
Starting applications specified in /home/test/.vnc/xstartup
Log file is /home/test/.vnc/redtac:1.log

sh: /home/test/.vnc/redtac:1.log: Permission denied [
test@redtac ~]$

If I attempt to login via an windows machine (realVNC-client ver.4), I get "unable to connect to host:Connection refused (10061)

If I run the vncserver as root, seems to run normal:
[root@redtac ~]# vncserver

New 'redtac:1 (root)' desktop is redtac:1

Starting applications specified in /root/.vnc/xstartup
Log file is /root/.vnc/redtac:1.log

[root@redtac ~]#

And then attempt to login via same windows vnc-client, i get a grey screen saying "This session is running as a privileged user..., selecting Continue logs me in as root.

I don't recall having issues like this before under F7 or F5. I would rather run vncserver as normal user. Is this possible? Any ideas?

Thanks,
Lp3 :confused:

Firewing1
28th May 2008, 10:00 PM
If your use Gnome, I would use the build-in Vino (Preferences > Internet & Network > Remote Desktop) system instead. It's more secure and configures the vnc server on a per-user basis.
Firewing1

manofsloth
30th May 2008, 12:50 AM
https://bugzilla.redhat.com/show_bug.cgi?id=446604
https://bugzilla.redhat.com/show_bug.cgi?id=447631

The answer to both of those seems to be to upgrade to selinux-policy-3.3.1-56, however
yum update selinux-policy --enablerepo=*

only takes me to 3.3.1-55.

How can I get the newest version?

brebs
30th May 2008, 03:30 AM
In the build history (http://koji.fedoraproject.org/koji/packageinfo?packageID=32).

manofsloth
31st May 2008, 01:08 AM
Got it working. Thanks brebs and dogbert_2001.

b10h4ck3r
7th June 2008, 05:09 AM
i see and copy the instruction from https://bugzilla.redhat.com/show_bug.cgi?id=446604

[root@asdf ~]# rpm -q selinux-policy
selinux-policy-3.3.1-55.fc9.noarch
[root@asdf ~]# rpm -e selinux-policy
[root@asdf ~]# yum install selinux-policy
...
Complete!
[root@asdf ~]# /sbin/restorecon /usr/bin/vncserver
[root@asdf ~]# service vncserver start
...
and work perfectly

thx to all

ianm
10th June 2008, 03:32 AM
I can start vncserver from the command line but not from xinetd. Using the same configuration as on F8 (with xfs installed and running (*) and with selinux disabled) gets a gray screen. /var/log/messages shows:

xinetd[1942]: START: vnc-1024x768 pid=3093 from=...
xinetd[1942]: EXIT: vnc-1024x768 status=0 pid=3093 duration=126(sec)

(timeout after 126 sec was automatic).

There's nothing else relevant in any other logs that I could find.

ppeiris
7th August 2008, 05:49 PM
I try the same but didn't work. I have FC9 installed in mac-mini. There are no errors it simply fail to start the service.

I installed selinux-policy-3.3.1-84.fc9.noarch

no luck so far.... :(

Thank you for your help in advance.

briantan
7th August 2008, 07:42 PM
hello, i've just installed F9 on my machine from F7. trying to run vncserver as normal user I get:

[test@redtac ~]$ vncserver
You will require a password to access your desktops.
Password:
Verify:
sh: /home/test/.vnc/redtac:1.log: Permission denied
sh: /home/test/.vnc/redtac:1.pid: Permission denied

New 'redtac:1 (test)' desktop is redtac:1
Starting applications specified in /home/test/.vnc/xstartup
Log file is /home/test/.vnc/redtac:1.log

sh: /home/test/.vnc/redtac:1.log: Permission denied [
test@redtac ~]$


$ su -
# chown -R test ~test/.vnc
# chmod -R u+w ~test/.vnc

http://forums.fedoraforum.org/forum/showthread.php?t=194101

ppeiris
8th August 2008, 03:56 PM
$ su -
# chown -R test ~test/.vnc
# chmod -R u+w ~test/.vnc

http://forums.fedoraforum.org/forum/showthread.php?t=194101


Thank you for the info. But still out of luck. it worked perfect under FC8.

still it won't give me any errors or any messages, it simply fail to start the service


[root@localhost prabath]# /sbin/service vncserver restart
Shutting down VNC server: 2: prabath [FAILED]
Starting VNC server: 2: prabath [FAILED]
[root@localhost prabath]#


thank you again

briantan
8th August 2008, 07:29 PM
[root@localhost prabath]# /sbin/service vncserver restart
Shutting down VNC server: 2: prabath [FAILED]
Starting VNC server: 2: prabath [FAILED]
Your earlier message showed that ~/test/.vnc is not writable by user test.

Did you do the same for user prabath?


# chown -R prabath ~prabath/.vnc
# chmod -R u+w ~prabath/.vnc

Gnome/F8 works well with VNC-server for me too. But you probably won't have much luck with Gnome/F9. Use KDE or XFCE instead.


# vi /etc/sysconfig/desktop
DESKTOP=KDE
or

# vi ~prabath/.vnc/xstartup
#!/bin/sh

vncconfig -iconic &
# Uncomment the following two lines for normal desktop:
# unset SESSION_MANAGER
# exec /etc/X11/xinit/xinitrc

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
# xterm -geometry 80x40+10+10 -ls -title "$VNCDESKTOP Desktop" &
# twm &
startxfce4 &

Edit: I mistook ppeiris as lp3. This post was meant for lp3 and not realised lp3 may be long gone.

ianm
10th August 2008, 10:52 PM
I try the same but didn't work. I have FC9 installed in mac-mini.

Seems like a solution depends on this being fixed:

https://bugzilla.redhat.com/show_bug.cgi?id=452528

Lp3
17th December 2008, 12:09 AM
Hello,

Its been awhile since I last looked into this....pretty much gave up there for some months.

But I finally tried what BrianTan suggested below and it got rid of those Permission Denied messages when starting VNCServer as regular user.

And now I can normally log in to this box with VNC and as a regular user with no issues.

I did look into my selinux-policy version and it is:

[test@redtac home]$ rpm -q selinux-policy
selinux-policy-3.3.1-42.fc9.noarch

Not sure if I need to update this or not.

After a reboot, I tried getting a yum update of selinux-policy but it finds nothing.

For now its seems to work as it did back in the day....
Thanks!