PDA

View Full Version : Bluetooth mouse won't reconnect after being idle for a while.



alarm9k
16th May 2008, 11:58 AM
I'm using Logitech MX1000 Bluetooth mouse with my laptop.

When left for a while the mouse goes into a sleep mode and disconnects, but if I come back and grab the mouse again, the cursor won't move.

The words 'won't reconnect' are not quite right (probably) because the BT icon shows that the mouse _is_ connected, but the cursor still doesn't move. Restarting bluetooth service makes things work until the mouse goes to sleep again.

I cannot figure out how to start fixing the problem because I'm not even getting any error messages in log files. Confused :confused:

Fedora 8 + all appropriate updates, KDE.

Jaydax
23rd June 2008, 08:11 AM
I had the same problem with my Microsoft wireless notebook presenter mouse 8000 used with Vista Ultimate on a Dell Inspiron 1720 laptop. The problem was supposed to be cured by service pack 1 but it made no difference. It took a while to find the cause but it seems that when the laptop goes to sleep the bluetooth mouse waits for a while then powers down to save power. When the laptop re-wakes it expects the mouse to be in the same state as when it went to sleep - and it isn't.
Sometimes its possible to switch the mouse off and on again to restore the connection but this (and removing the batteries) doesn't always work. The cure is to manually switch off the mouse before putting the computer to sleep. If you forget then you either restart the laptop or switch the bluetooth receiver off and on again.

alarm9k
23rd June 2008, 07:19 PM
Interesting.

In my case the laptop does not go to sleep (hybernate, suspend to hard drive). It's the bluetooth devices that go into 'sleep' (power save) mode after not being used for a while.
By the way I haven't found a solution yet.

I also discovered that Logitech MX5000 bluetooth keyboard doesn't connect after 'parking' (or whatever it's called) either.

I am not yet sure whether this problem is specific to bluetooth hardware used in Vaio. I will perform more testing using different hardware when I have time.

epperson
25th June 2008, 02:23 AM
This _is_ rather interesting. I'd thought that my losing the Bluetooth mouse (Iogear on a Dell D600 with Dell TruMobile Bluetooth) was a suspend/resume issue. I'll have to test further to see if it happens with the mouse unattended for a while but the pc not suspended.

Only way to reconnect that I've found without rebooting is turn the mouse off, use the Fn-F2 wireless toggle to turn the card off then back on, then turn the mouse back on. Have done this for so long on resume that it's habit. Funny thing, it never happened with the old ACPI-based S3 suspend, just started when pm-utils took over and ever since.

dustyasher
25th September 2008, 04:35 AM
Any help with this would be greatly appreciated. I have tried almost everything including bouncing the bluetooth service and it still doesn't work. The keyboard works fine.

leif81
6th November 2008, 04:34 AM
Happening to me too with my logitech ps3 keyboard. Odd thing was my keyboard + mouse was working fine for a month and now after 20mins or so it loses connection every time. Pressing the reset button on my keybaord and then running hidd --search seems to restore connectivity temporarily.

foltzp9
29th April 2009, 03:34 AM
Has anyone found a solution to this problem - in whatever form? Does FC9 or FC10 fix this?

leif81
29th April 2009, 02:29 PM
An upstream fix should be on the way soon. If interested you can follow the bug in launchpad. Supposedly Ubuntu 9.0.4 has improvements. I'm going to try F11 preview release this week and see if it has the same.

https://bugs.launchpad.net/bugs/268502

epperson
30th April 2009, 12:10 AM
I forgot to post back. I hope F11 fixes this, but in the interim I found that with F10, my Iogear BT mouse does exhibit this behavior even without suspending/resuming. And I've found that toggling to a console (CTRL-ALT-F2), clicking the mouse a couple of times, and toggling back to X (CTRL-ALT-F1) will _usually_ wake it up.