PDA

View Full Version : F9 won't boot into X (init level 5), ignores /etc/inittab



daw617
16th May 2008, 06:29 AM
I just upgraded from Fedora 9 Beta to Fedora 9 using yum. My machine will no longer automatically boot into X mode (i.e., init level 5). Does anyone have any idea why?

Here's the deal. After the upgrade, /etc/inittab somehow acquired 3 as the default initlevel. I edited it to use initlevel 5, like this:

id:5:initdefault:

But now when I boot, it just boots into initlevel 3 (i.e., no X; I get a text console with a login: prompt). I can log in as root and run "telinit 5", and it will start up X and give me the graphical login screen (gdm greeter, or whatever), but I have to do that manually.

Is there any way to get this to work automatically? Does anyone have any clue why Fedora is ignoring my /etc/inittab? Is this some aspect of the new upstart packages? Do I have to edit some other configuration file?

Does anyone have any debugging suggestions for me? Thanks in advance for any ideas or help you might be able to provide!


P.S. By the way, some other background information: I also edited to my /etc/grub.conf to boot without using the rhgb parameter. (If I boot with rhgb, X freezes. But if I boot without rhgb, log in to the text console, and then run "telinit 5", X works fine.) For more information, including my xorg.conf file and other symptoms, you can reference the following bugreport, in case it's relevant:

https://bugzilla.redhat.com/show_bug.cgi?id=446307

Seve
16th May 2008, 06:38 AM
Hello:
I could be mistaken, but if you just updated as you say, are you sure that you are not running Rawhide instead of F9?

What is the output of

cat /fedora-release
and
yum repolist

Seve

daw617
17th May 2008, 05:47 PM
Nope, I'm not sure -- but it does look that way. Here's the output of the commands you mentioned:

# yum repolist
Loaded plugins: fastestmirror, priorities, refresh-packagekit
repo id repo name status
adobe-linux-i386 Adobe Systems Incorporated enabled
fedora Fedora 9 - x86_64 enabled
livna-development Livna for Fedora Core 9 - x86_64 - Devel enabled
updates Fedora 9 - x86_64 - Updates enabled

# cat /etc/fedora-release
Fedora release 9 (Sulphur)

I presume that is Fedora 9, not Fedora 9 Beta, right? (I've run "yum upgrade" and accepted all upgrades.)

sidebrnz
17th May 2008, 09:56 PM
Take a look at your grub.conf and see what the kernel line reads. It might just have init=3 in there somewhere. If so, remove it. If not, try adding init=5. It might just work.

daw617
18th May 2008, 09:53 PM
Well, that was a good suggestion. I tried booting and entering "init=5" as a kernel argument using grub, and I discovered that booting fails. I get the following error at the console (hand-transcribed):

WARNING: Can't access 5
exec of init(5) failed!!!: No such file or directory
booting has failed
/bin/sleep: invalid option -- '1'
try `/bin/sleep --help' for more information.
Kernel panic - not syncing: Attempted to kill init!

That's a new one for me.

Let me share some additional information, in case it's relevant. There is only one non-commented out line in my /etc/inittab. It used to be as follows:

id:3:initdefault:

I tried changing it to this:

id:5:initdefault:

but that had no effect.

The top of my /etc/inittab says:

# inittab is only used by upstart for the default runlevel.
#
# ADDING OTHER CONFIGURATION HERE WILL HAVE NO EFFECT ON YOUR SYSTEM.

OK, so where do I look to see where the default runlevel is set? How do I control this? Can anyone else verify that this is what is in your /etc/inittab file, on Fedora 9? What's this "upstart" business? Did Fedora 9 change out the init scripts system, and how am I supposed to administer things in the new scheme of things? I have to say that the man pages on init and upstart are not helpful...

Any help would be gratefully appreciated!

daw617
18th May 2008, 10:12 PM
Well, that was a good suggestion. I tried booting and entering "init=5" as a kernel argument using grub, and I discovered that booting fails. I get the following error at the console (hand-transcribed):

WARNING: Can't access 5
exec of init(5) failed!!!: No such file or directory
booting has failed
/bin/sleep: invalid option -- '1'
try `/bin/sleep --help' for more information.
Kernel panic - not syncing: Attempted to kill init!

That's a new one for me.

Let me share some additional information, in case it's relevant. There is only one non-commented out line in my /etc/inittab. It used to be as follows:

id:3:initdefault:

I tried changing it to this:

id:5:initdefault:

but that had no effect.

The top of my /etc/inittab says:

# inittab is only used by upstart for the default runlevel.
#
# ADDING OTHER CONFIGURATION HERE WILL HAVE NO EFFECT ON YOUR SYSTEM.

OK, so where do I look to see where the default runlevel is set? How do I control this? Can anyone else verify that this is what is in your /etc/inittab file, on Fedora 9? What's this "upstart" business? Did Fedora 9 change out the init scripts system, and how am I supposed to administer things in the new scheme of things? I have to say that the man pages on init and upstart are not helpful...

Any help would be gratefully appreciated!

heat84
17th September 2008, 04:00 AM
I just did a fresh install of FC9 and I get "Input not supported" from my monitor (an Acer monitor) when I try to boot up. I just need to get to a point where I can edit xorg.conf. I tried adding init=3 to the kernel argument but it says not found and then kernel panic.

sidebrnz
17th September 2008, 04:32 AM
Try this: at boot, add single to the kernel line in Grub to get into single user mode, then init 3 or telenit 3 to go to a regular CLI interface. Yes, it's going around Robin Hood's Barn to get there, but in the words of Frodrick Fronkenstein, "It just might work!"

Hlingler
17th September 2008, 04:39 AM
Wasn't that Fronkenschtien?

:D
V

JohnVV
17th September 2008, 04:44 AM
"Fronkenschtien?"
with a note to Ted Turner " please do not colorize"