PDA

View Full Version : Problems Updating FC8 to FC9



Raptor13
16th May 2008, 05:43 AM
Hello.

I just upgrade my system FC8 to FC9, but has presented a problem, the machine tends to freeze, it's something random can happen at any time, I do not understand why this happens, I hope some of you can help me.

I also realize that repositories Livna 9 do not have kmod-nvidia, and my card is an nVidia GeForce 6150 are therefore not be done to install the drivers.

Thank you for your attention.

RokleM
21st May 2008, 01:21 PM
I'm having the exact same thing on two hosts I upgraded. A third hosts works fine, but is a different hardware platform. The boxes appear online (ping), but just randomly won't accept any http or ssh connections. They also appear to have the issues at the same time, however one machine appears to stay in that hung state for longer.

Did you find any further feedback/ideas on this one?

RokleM
21st May 2008, 02:17 PM
Additional note. I grabbed iotop, successfully connected to the machine, and don't see any IO thrashing which I assumed was likely the issue.

RokleM
23rd May 2008, 02:48 AM
Well, I found the issue. It looks like apache has some sort of massive memory leak from what I can tell. I noticed this when I logged into cacti. You can see the 4-5 times it's locked/paused as memory/swap came to basically 0 free and I've rebooted . It's also obvious where I upgraded to FC9 :rolleyes:

srv01:~# free
total used free shared buffers cached
Mem: 1025640 986384 39256 0 9016 89784
-/+ buffers/cache: 887584 138056
Swap: 2048276 2021492 26784

srv01:~# /etc/init.d/httpd restart
Stopping httpd: [ OK ]
Starting httpd: [ OK ]

srv01:~# free
total used free shared buffers cached
Mem: 1025640 201736 823904 0 9252 91384
-/+ buffers/cache: 101100 924540
Swap: 2048276 53840 1994436

http://mad-skillz.com/mem_leak.jpg