PDA

View Full Version : Downgrading Xorg (in Fedora 9) for nvidia support



Erikina
16th May 2008, 05:39 AM
I've tried nv, nouveau - even tried getting livna experimental nvidia drivers. But nothing really cuts it.

I'm also unable to find a guide, to downgrading the necessary Fedora 9 packages to allow me to run nvidia drivers. Does anyone have a link, or some pointers?

Thanks very much,
Eric.



Solution
Since I imagine a lot of people will be having this issue, here is the solution. (Big thanks to brebs)

Go to http://www.fedoraforum.org/forum/showthread.php?p=1003106#post1003106
Brebs shows you how to get to an old version of xorg.


Now, you'll want to stop the updater trying to update back to the normal xorg. So in /etc/yum.conf add the following line:

exclude=mesa-libGL,synaptics,xorg-x11-drv-evdev,xorg-x11-drv-evdev,xorg-x11-drv-keyboard,xorg-x11-drv-mouse,xorg-x11-drv-vesa,xorg-x11-drv-void,xorg-x11-server-Xorg

(your line might be different?)


Now, the livna nvidia binaries will not work. Because you either use the Fedora 8 .. but the kernel is wrong. Or the Fedora 9 testing, but the xorg is wrong.


So go to the nvidia site, and download the nvidia binary. ( http://www.nvidia.com/object/linux_display_ia32_169.12.html for the normal nvidia drivers )

Go to http://www.nvnews.net/vbulletin/showthread.php?t=110088 to grab the patch, to patch nvidia for the new linux kernel.

You simply can do it with:
$ su
# sh /path/to/NVIDIA-Linux-x86_64-169.12-pkg2.run \
--apply-patch /path/to/NVIDIA_kernel-169.12-2286310.diff.txt

(the names will be slightly different)


Make sure you have installed the kernel development stuff

# yum install kernel-devel


Now log out. And login in text mode. Navigate to where the nvidia is, and run it with:
# sh NVIDIA-Linux-x86_64-169.12-pkg2-custom.run


Restart your computer. Run nvidia-settings if you need to, to configure everything.

brebs
16th May 2008, 06:48 AM
See my post (http://www.fedoraforum.org/forum/showthread.php?p=1003106#post1003106).

I've done this both on 32-bit and 64-bit. Works fine.

Erikina
16th May 2008, 08:33 AM
Hey, thanks very much brebs.

Worked perfectly. Which way did you install nvidia? Did you download the nvidia drivers from the offial site, do the patch for the current kernel? Or did you manage somehow to get the livna ones to work?

Thanks a lot,
Eric.

brebs
16th May 2008, 09:14 AM
Heh, I used nvidia's drivers. Even though I've ranted about *not* using them, in Gentoo & Arch.

But, whatever works, I'm a relative newbie to Fedora, and have the ability to undo whatever damage the nvidia drivers might have done.

Erikina
16th May 2008, 12:59 PM
Ok. Thanks. Got it all working fine (yay!). I've added the solution to the first post, incase some people stumble upon it.

Sydius
18th May 2008, 05:15 AM
This worked for me as well, thanks!

yousifnet
18th May 2008, 09:35 AM
Excellent stuff brebs & Erikina !

Tried removing xorg-x11 server and messed up my F9 install. Did a fresh F8 install and a yum upgrade with --exclude=xorg-x11-server-Xorg but yum complained and I just init 0 :D .

Will try it your way :)

lmcogs
18th May 2008, 11:54 PM
This worked for me

http://forums.fedoraforum.org/forum/showthread.php?t=188645&highlight=lottc