View Full Version : Adobe Reader 8.12 Plugin won't work in Fedora 9

16th May 2008, 04:53 AM
Hi- I just installed Fedora 9 from the Gnome Live CD. I downloaded Adobe Reader 8.12 for Linux from Adobe's site to my Download folder, then double-clicked on it to install (I believe it used Package Manager). It shows up under my program menu, and Reader works when it is clicked on.

However, using Firefox 3.0 beta 5, the Reader plugin does not work. When clicking on a pdf file, the browser goes to a blank page and reads "Done" in the info bar at the bottom. Also, the Reader menu does not show up in Firefox.

I browsed the forums before posting, and it looks like there was a conflict with SELinux in previous versions of Fedora. But, I've disabled SELinux, so I don't think that is it. Has anyone else had this problem and solved it. I need to use Reader in order to add edits to pdfs that others have made.

Thanks for any assistance, Fw

16th May 2008, 05:22 AM
You may want to have a read through this guide, if you have not already done so.


16th May 2008, 06:00 AM
Thanks, Seve. I will check that site out, as well as the others in your sig. These are what I was looking for in order to get more info. --Fw

17th May 2008, 12:16 AM
I found the solution to the problem. With Acrobat 8.12, the stand-alone reader seems to work OK, but the plug-in has some sort of memory leak when using Firefox (I'm using FF3.0B5 with FC9). You'll know it is happening if you click on a pdf in Firefox, the browser goes to another page (as if it is loading the pdf), then says "Done" in the lower status bar.


If a terminal is opened and top is used to look at processes, you'll find that ld-linux.so2 is using 30-50% of CPU time. If one uses the back button, then tries to load another pdf, another instance of ld-linux.so2 opens and uses another 30-40% of CPU time. At this point, the computer is pretty unresponsive, but if the ld-linux.so2 processes are killed (kill -9 pid) everything returns to normal.

I tried this with Acrobat Reader from Adobe's web site, and pretty much the same thing happens but the process that hogs the CPU is acroread.

So, my workaround was to keep acorread installed, but delete the browser plugin (nppdf.so) as root from the plugin directory (/usr/lib/mozilla/plugins). Then make sure that evince is used by FF (edit -> preferences -> applications, then select Document Viewer as PDF preference). This workaround will allow viewing of pdfs from FF using evince, but if you need acroread the pdf link can be right clicked on, saved to the computer, and viewed with acroread. In my limited testing, acroread used as a stand-alone app doesn't cause this problem, but YMMV.

Good luck, Fw