PDA

View Full Version : fc9 yum failed, who can tell me what't the meaning?



comain
16th May 2008, 03:58 AM
sudo yum update

--------------------------------------------------
Downloading Packages:
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libcrypto.so.7 is needed by (installed) openldap-2.4.8-3.fc9.i386
libcrypto.so.7 is needed by (installed) mysql-libs-5.0.51a-1.fc9.i386
libcrypto.so.7 is needed by (installed) distcache-1.4.5-17.i386
libcrypto.so.7 is needed by (installed) bind-libs-9.5.0-29.b2.fc9.i386
libcrypto.so.7 is needed by (installed) libwvstreams-4.4.1-4.fc9.i386
libcrypto.so.7 is needed by (installed) cyrus-sasl-md5-2.1.22-13.fc9.i386
libcrypto.so.7 is needed by (installed) elinks-0.11.4-0.4.rc1.fc9.i386
libcrypto.so.7 is needed by (installed) httpd-tools-2.2.8-3.i386
libcrypto.so.7 is needed by (installed) php-cli-5.2.5-7.fc9.i386
libcrypto.so.7 is needed by (installed) php-mysql-5.2.5-7.fc9.i386
libcrypto.so.7 is needed by (installed) bind-utils-9.5.0-29.b2.fc9.i386
libcrypto.so.7 is needed by (installed) wget-1.11.1-1.fc9.i386
libcrypto.so.7 is needed by (installed) tcpdump-3.9.8-4.fc9.i386
libcrypto.so.7 is needed by (installed) libflashsupport-000-0.5.svn20070904.i386
libcrypto.so.7 is needed by (installed) vsftpd-2.0.6-3.fc9.i386
libcrypto.so.7 is needed by (installed) openssl-devel-0.9.8g-6.fc9.i386
libcrypto.so.7 is needed by (installed) python-2.5.1-25.fc9.i386
libcrypto.so.7 is needed by (installed) wpa_supplicant-0.6.3-5.fc9.i386
libcrypto.so.7 is needed by (installed) python-ldap-2.3.1-3.fc9.i386
libcrypto.so.7 is needed by (installed) transmission-1.06-1.fc9.i386
libcrypto.so.7 is needed by (installed) openssh-5.0p1-1.fc9.i386
libcrypto.so.7 is needed by (installed) cyrus-sasl-2.1.22-13.fc9.i386
libcrypto.so.7 is needed by (installed) sendmail-8.14.2-4.fc9.i386
libcrypto.so.7 is needed by (installed) fetchmail-6.3.8-6.fc9.i386
libcrypto.so.7 is needed by (installed) openssh-clients-5.0p1-1.fc9.i386
libcrypto.so.7 is needed by (installed) openssh-server-5.0p1-1.fc9.i386
libcrypto.so.7 is needed by (installed) mod_ssl-2.2.8-3.i386
libcrypto.so.7 is needed by (installed) php-5.2.5-7.fc9.i386
libcrypto.so.7 is needed by (installed) gnome-vfs2-2.22.0-1.fc9.i386
libcrypto.so.7 is needed by (installed) evolution-data-server-2.22.1-2.fc9.i386
libcrypto.so.7 is needed by (installed) openoffice.org-core-2.4.0-12.8.fc9.i386
libcrypto.so.7 is needed by (installed) net-snmp-libs-5.4.1-14.fc9.i386
libcrypto.so.7 is needed by (installed) ntp-4.2.4p4-6.fc9.i386
libcrypto.so.7 is needed by (installed) lftp-3.6.3-2.fc9.i386
libcrypto.so.7 is needed by (installed) crypto-utils-2.3-10.i386
libcrypto.so.7 is needed by (installed) net-snmp-5.4.1-14.fc9.i386
libcrypto.so.7 is needed by (installed) squid-3.0.STABLE2-2.fc9.i386
libcrypto.so.7 is needed by (installed) stunnel-4.22-1.i386
libcrypto.so.7 is needed by (installed) xorg-x11-server-Xorg-1.4.99.901-29.20080415.fc9.i386
libssl.so.7 is needed by (installed) openldap-2.4.8-3.fc9.i386
libssl.so.7 is needed by (installed) mysql-libs-5.0.51a-1.fc9.i386
libssl.so.7 is needed by (installed) distcache-1.4.5-17.i386
libssl.so.7 is needed by (installed) libwvstreams-4.4.1-4.fc9.i386
libssl.so.7 is needed by (installed) elinks-0.11.4-0.4.rc1.fc9.i386
libssl.so.7 is needed by (installed) httpd-tools-2.2.8-3.i386
libssl.so.7 is needed by (installed) php-cli-5.2.5-7.fc9.i386
libssl.so.7 is needed by (installed) php-mysql-5.2.5-7.fc9.i386
libssl.so.7 is needed by (installed) wget-1.11.1-1.fc9.i386
libssl.so.7 is needed by (installed) nss_ldap-259-3.fc9.i386
libssl.so.7 is needed by (installed) libflashsupport-000-0.5.svn20070904.i386
libssl.so.7 is needed by (installed) vsftpd-2.0.6-3.fc9.i386
libssl.so.7 is needed by (installed) openssl-devel-0.9.8g-6.fc9.i386
libssl.so.7 is needed by (installed) python-2.5.1-25.fc9.i386
libssl.so.7 is needed by (installed) wpa_supplicant-0.6.3-5.fc9.i386
libssl.so.7 is needed by (installed) python-ldap-2.3.1-3.fc9.i386
libssl.so.7 is needed by (installed) transmission-1.06-1.fc9.i386
libssl.so.7 is needed by (installed) sendmail-8.14.2-4.fc9.i386
libssl.so.7 is needed by (installed) fetchmail-6.3.8-6.fc9.i386
libssl.so.7 is needed by (installed) mod_ssl-2.2.8-3.i386
libssl.so.7 is needed by (installed) php-5.2.5-7.fc9.i386
libssl.so.7 is needed by (installed) gnome-vfs2-2.22.0-1.fc9.i386
libssl.so.7 is needed by (installed) evolution-data-server-2.22.1-2.fc9.i386
libssl.so.7 is needed by (installed) openoffice.org-core-2.4.0-12.8.fc9.i386
libssl.so.7 is needed by (installed) lftp-3.6.3-2.fc9.i386
libssl.so.7 is needed by (installed) squid-3.0.STABLE2-2.fc9.i386
libssl.so.7 is needed by (installed) stunnel-4.22-1.i386
openssl is needed by (installed) openssl-devel-0.9.8g-6.fc9.i386
Complete!

bob
16th May 2008, 11:29 AM
I'd do 'yum clean all' and then try 'yum update' again. You can see that it's complaining about libssl.so.7, which is a key part of those packages.

dannyxyz22
18th May 2008, 11:53 PM
The same happened to me.
Even though I made a 'yum clean all'.
I still can't update the system through yum.
I have made an upgrade from fc8 and not a clean install. Anything related?
Thanks in advance,
Daniel

PabloTwo
19th May 2008, 01:07 AM
What happens when you try,

yum update openssl

The two lib files being complained about are installed by the openssl package.

dannyxyz22
19th May 2008, 01:21 AM
Sorry Pablo, I hadn't seen your message, and I just started removing openssl...
I know lots of libraries depend on it, but I was just not finding other way around. It's pretty weird, because the libcrypto.so.7 was already installed...
So, I'm removing now...
By the way, I'm attaching the full message I was receiving.
It's also very weird that I can't find Fedora 9 repositories on my "Software Resources". The only ones related to Fedora 9 are the test ones... I had just disabled them...
Well, I'll tell what happens when I finish removing openssl and installing it again.
Thanks for the help,


**************************************************

[root@localhost Download]# yum update
Loaded plugins: refresh-packagekit
file:///tmp/sdk/CellSDK-Devel-Fedora/x86/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/tmp/sdk/CellSDK-Devel-Fedora/x86/repodata/repomd.xml'
Trying other mirror.
CellSDK-Devel-Fedora-x86 | 1.1 kB 00:00
primary.xml.gz | 5.6 kB 00:00
CellSDK-De: ################################################## 29/29
fedora | 2.1 kB 00:00
primary.sqlite.bz2 | 4.9 MB 00:40
updates | 2.3 kB 00:00
primary.sqlite.bz2 | 2.8 MB 00:27
livna-testing | 951 B 00:00
primary.xml.gz | 16 kB 00:00
livna-test: ################################################## 121/121
fedora-source | 2.1 kB 00:00
primary.sqlite.bz2 | 1.4 MB 00:13
file:///tmp/sdk/CellSDK-Open-Fedora/x86/repodata/repomd.xml: [Errno 5] OSError: [Errno 2] No such file or directory: '/tmp/sdk/CellSDK-Open-Fedora/x86/repodata/repomd.xml'
Trying other mirror.
CellSDK-Open-Fedora-x86 | 1.1 kB 00:00
primary.xml.gz | 5.4 kB 00:00
CellSDK-Op: ################################################## 26/26
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package lua.i386 0:5.1.3-6.fc8 set to be updated
---> Package paps.i386 0:0.6.8-6.fc8 set to be updated
---> Package paps-libs.i386 0:0.6.8-6.fc8 set to be updated
---> Package amarok.i386 0:1.4.9.1-3.fc8 set to be updated
--> Processing Dependency: libssl.so.6 for package: amarok
--> Processing Dependency: libcrypto.so.6 for package: amarok
--> Running transaction check
---> Package openssl.i386 0:0.9.8b-17.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Updating:
amarok i386 1.4.9.1-3.fc8 updates 13 M
lua i386 5.1.3-6.fc8 updates 227 k
paps i386 0.6.8-6.fc8 updates 32 k
paps-libs i386 0.6.8-6.fc8 updates 23 k
Installing for dependencies:
openssl i386 0.9.8b-17.fc8 fedora 1.4 M

Transaction Summary
================================================== ===========================
Install 1 Package(s)
Update 4 Package(s)
Remove 0 Package(s)

Total download size: 15 M
Is this ok [y/N]: y
Downloading Packages:
(1/5): openssl-0.9.8b-17.fc8.i386.rpm | 1.4 MB 00:09
(2/5): amarok-1.4.9.1-3.fc8.i386.rpm | 13 MB 01:26
(3/5): paps-libs-0.6.8-6.fc8.i386.rpm | 23 kB 00:00
(4/5): lua-5.1.3-6.fc8.i386.rpm | 227 kB 00:01
(5/5): paps-0.6.8-6.fc8.i386.rpm | 32 kB 00:00
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
libcrypto.so.7 is needed by (installed) openldap-2.4.8-3.fc9.i386
libcrypto.so.7 is needed by (installed) mysql-libs-5.0.51a-1.fc9.i386
libcrypto.so.7 is needed by (installed) ruby-libs-1.8.6.114-1.fc9.i386
libcrypto.so.7 is needed by (installed) postgresql-libs-8.3.1-1.fc9.i386
libcrypto.so.7 is needed by (installed) php-cli-5.2.5-7.fc9.i386
libcrypto.so.7 is needed by (installed) pwlib-1.10.10-6.fc9.i386
libcrypto.so.7 is needed by (installed) wget-1.11.1-1.fc9.i386
libcrypto.so.7 is needed by (installed) opal-2.2.11-3.fc9.i386
libcrypto.so.7 is needed by (installed) redland-1.0.7-1.fc9.i386
libcrypto.so.7 is needed by (installed) libwvstreams-4.4.1-4.fc9.i386
libcrypto.so.7 is needed by (installed) bind-libs-9.5.0-29.b2.fc9.i386
libcrypto.so.7 is needed by (installed) openslp-1.2.1-9.fc9.i386
libcrypto.so.7 is needed by (installed) cyrus-sasl-md5-2.1.22-13.fc9.i386
libcrypto.so.7 is needed by (installed) elinks-0.11.4-0.4.rc1.fc9.i386
libcrypto.so.7 is needed by (installed) htdig-3.2.0-0.1.b6.fc9.i386
libcrypto.so.7 is needed by (installed) tcltls-1.5.0-16.fc9.i386
libcrypto.so.7 is needed by (installed) php-mysql-5.2.5-7.fc9.i386
libcrypto.so.7 is needed by (installed) httpd-tools-2.2.8-3.i386
libcrypto.so.7 is needed by (installed) mysql-connector-odbc-3.51.24r1071-1.fc9.i386
libcrypto.so.7 is needed by (installed) bind-utils-9.5.0-29.b2.fc9.i386
libcrypto.so.7 is needed by (installed) tcpdump-3.9.8-4.fc9.i386
libcrypto.so.7 is needed by (installed) qca-tls-1.0-13.fc9.i386
libcrypto.so.7 is needed by (installed) vsftpd-2.0.6-3.fc9.i386
libcrypto.so.7 is needed by (installed) lynx-2.8.6-13.fc9.i386
libcrypto.so.7 is needed by (installed) python-2.5.1-25.fc9.i386
libcrypto.so.7 is needed by (installed) gnome-vfs2-2.22.0-1.fc9.i386
libcrypto.so.7 is needed by (installed) php-5.2.5-7.fc9.i386
libcrypto.so.7 is needed by (installed) cyrus-sasl-2.1.22-13.fc9.i386
libcrypto.so.7 is needed by (installed) sendmail-8.14.2-4.fc9.i386
libcrypto.so.7 is needed by (installed) openssh-5.0p1-1.fc9.i386
libcrypto.so.7 is needed by (installed) qca-ossl-2.0.0-0.4.beta3.fc9.i386
libcrypto.so.7 is needed by (installed) wireshark-1.0.0-2.fc9.i386
libcrypto.so.7 is needed by (installed) openssh-clients-5.0p1-1.fc9.i386
libcrypto.so.7 is needed by (installed) wpa_supplicant-0.6.3-5.fc9.i386
libcrypto.so.7 is needed by (installed) wireshark-gnome-1.0.0-2.fc9.i386
libcrypto.so.7 is needed by (installed) openssh-server-5.0p1-1.fc9.i386
libcrypto.so.7 is needed by (installed) fetchmail-6.3.8-6.fc9.i386
libcrypto.so.7 is needed by (installed) vnc-server-4.1.2-30.fc9.i386
libcrypto.so.7 is needed by (installed) python-ldap-2.3.1-3.fc9.i386
libcrypto.so.7 is needed by (installed) evolution-data-server-2.22.1-2.fc9.i386
libcrypto.so.7 is needed by (installed) perl-DBD-MySQL-4.005-8.fc9.i386
libcrypto.so.7 is needed by (installed) net-snmp-libs-5.4.1-14.fc9.i386
libcrypto.so.7 is needed by (installed) net-snmp-5.4.1-14.fc9.i386
libcrypto.so.7 is needed by (installed) hpijs-2.8.2-2.fc9.i386
libcrypto.so.7 is needed by (installed) w3m-0.5.2-10.fc9.i386
libcrypto.so.7 is needed by (installed) git-1.5.4.5-3.fc9.i386
libcrypto.so.7 is needed by (installed) openoffice.org-core-2.4.0-12.8.fc9.i386
libcrypto.so.7 is needed by (installed) ntp-4.2.4p4-6.fc9.i386
libcrypto.so.7 is needed by (installed) lftp-3.6.3-2.fc9.i386
libcrypto.so.7 is needed by (installed) hplip-2.8.2-2.fc9.i386
libcrypto.so.7 is needed by (installed) libsane-hpaio-2.8.2-2.fc9.i386
libcrypto.so.7 is needed by (installed) mysql-5.0.51a-1.fc9.i386
libcrypto.so.7 is needed by (installed) jpilot-0.99.9-6.fc9.i386
libcrypto.so.7 is needed by (installed) mysql-server-5.0.51a-1.fc9.i386
libcrypto.so.7 is needed by (installed) net-snmp-utils-5.4.1-14.fc9.i386
libcrypto.so.7 is needed by (installed) stunnel-4.22-1.i386
libcrypto.so.7 is needed by (installed) xchat-2.8.4-15.fc9.i386
libcrypto.so.7 is needed by (installed) zoneminder-1.22.3-12.fc9.i386
libcrypto.so.7 is needed by (installed) inkscape-0.46-2.fc9.i386
libcrypto.so.7 is needed by (installed) xorg-x11-server-Xorg-1.4.99.901-29.20080415.fc9.i386
libssl.so.7 is needed by (installed) openldap-2.4.8-3.fc9.i386
libssl.so.7 is needed by (installed) mysql-libs-5.0.51a-1.fc9.i386
libssl.so.7 is needed by (installed) ruby-libs-1.8.6.114-1.fc9.i386
libssl.so.7 is needed by (installed) postgresql-libs-8.3.1-1.fc9.i386
libssl.so.7 is needed by (installed) php-cli-5.2.5-7.fc9.i386
libssl.so.7 is needed by (installed) pwlib-1.10.10-6.fc9.i386
... removed because message was too long ...
libssl.so.7 is needed by (installed) python-ldap-2.3.1-3.fc9.i386
libssl.so.7 is needed by (installed) evolution-data-server-2.22.1-2.fc9.i386
libssl.so.7 is needed by (installed) perl-DBD-MySQL-4.005-8.fc9.i386
libssl.so.7 is needed by (installed) w3m-0.5.2-10.fc9.i386
libssl.so.7 is needed by (installed) kdelibs-4.0.3-7.fc9.i386
libssl.so.7 is needed by (installed) kdenetwork-libs-4.0.3-6.fc9.i386
libssl.so.7 is needed by (installed) openoffice.org-core-2.4.0-12.8.fc9.i386
libssl.so.7 is needed by (installed) kdebase3-3.5.9-10.fc9.i386
libssl.so.7 is needed by (installed) lftp-3.6.3-2.fc9.i386
libssl.so.7 is needed by (installed) mysql-5.0.51a-1.fc9.i386
libssl.so.7 is needed by (installed) mysql-server-5.0.51a-1.fc9.i386
libssl.so.7 is needed by (installed) stunnel-4.22-1.i386
libssl.so.7 is needed by (installed) xchat-2.8.4-15.fc9.i386
libssl.so.7 is needed by (installed) inkscape-0.46-2.fc9.i386
Complete!

PabloTwo
19th May 2008, 01:46 AM
I don't run F9, so I can't be sure what is happening. But you're comment about not seeing any F9 repos in your Software Resources, plus, seeing there are several F8 packages to be updated, including openssl, would suggest to me that you have active F8 repos but no F9 repos. I'm not sure how to advise you at this point.