PDA

View Full Version : cifs mounts in fstab after Fedora 9



kpj104
15th May 2008, 07:49 PM
So I've been looking around all morning to try and figure this one out. I have a couple lines copied from my f8 fstab which I put in my f9 tab. I've installed samba-client and can manually mount the cifs partitions with the user name and password I have in my credentials file. However, when I have the line in my fstab:

//server/share$ /mount/point cifs credentials=/etc/credentials.smb 0 0

It doesn't mount specifying a login failure. the credentials file has the following format:

username=myusername
password=mypassword

as I said, I can mount it just fine doing this:

mount -t cifs //server/share$ /mount/point -o username=myusername,password=mypassword

I've not yet tried to put spaces in between the '=' signs in the file, but I wanted to see if anyone else has seen this problem in F9?

thanks :rolleyes:

ogetbilo
15th May 2008, 08:13 PM
I don't know the answer to your question. It's been a long while since I mounted a samba share.

But there is an alternative method if you are using KDE. Open konqueror, and on the address bar type:

smb://x.x.x.x

Replace x.x.x.x with the host's IP address and hit enter. You will be asked for the username and password. This way you don't need to mount it.

But again this may or may not suit your needs.

mooninite
15th May 2008, 08:41 PM
Here's my fstab line.

\\computername\share /media/foldername cifs user=username,pass=password 0 0

kpj104
15th May 2008, 10:05 PM
Here's my fstab line.

\\computername\share /media/foldername cifs user=username,pass=password 0 0


Yup, this works... just looks like using the credentials is broken :(

Thank you for the suggestions! I do, unfortunately, want to mount to use as a source for local mail... if only I could convince the department to go to linux I wouldn't need a samba share ;)

dejan.kitic
15th May 2008, 11:17 PM
Man mount.cifs says:


OPTIONS
user=arg
specifies the username to connect as. If this is not given, then the environment variable USER is
used.


Same is for password argument, if not set it uses enviroment variable PASSWD. Belive all this happens before consulting cred file.Check what those env variables hold, that might be the answer.

kpj104
15th May 2008, 11:45 PM
Man mount.cifs says:


OPTIONS
user=arg
specifies the username to connect as. If this is not given, then the environment variable USER is
used.


Same is for password argument, if not set it uses enviroment variable PASSWD. Belive all this happens before consulting cred file.Check what those env variables hold, that might be the answer.

environment variable is unset and the username is the same as user variable and should override. Thanks though!

kpj104
16th May 2008, 02:30 PM
Looks like there was a bug reported for those interested.

Bugzilla Report #445623 (https://bugzilla.redhat.com/show_bug.cgi?id=445623)