PDA

View Full Version : For the life of x org in FC9...



djgemz
15th May 2008, 06:01 AM
Upgraded to FC9 now x will not come back to life here is my conf file:


Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "EN7410e"
DisplaySize 310 230
HorizSync 31.0 - 83.0
VertRefresh 56.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "i810"
VendorName "Videocard vendor"
BoardName "Intel Corporation 82845G/GL[Brookdale-G]/GE Chipset Integrated Graphics Device"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "800x600"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection


Here are the errors I get within /var/log/messages see the attached text alot with x's log.

Bottom line error:


Fatal server error:
no screens found

Do note that this worked fine from FC 3 up to FC 8 and now 9 it's not working...

Any work around here? I can't seem to nip this in the bud or figure this one out, I read something about fonts being updated and etc, however any advice or tips feel free to shoot them this way!

djgemz
15th May 2008, 06:04 AM
Anything I found GDM related within yum was the following:


gdm i386 1:2.22.0-1.fc9 installed 6.5 M
fedorainfinity-gdm-theme noarch 8.0.1-1.fc8 installed 1.1 M
gdm-user-switch-applet i386 1:2.22.0-1.fc9 installed 76 k

JEO
15th May 2008, 07:23 AM
Try renaming your /etc/X11/xorg.conf file. The new xorg.conf created by system-config-display is much smaller than it used to be and could be the cause of the trouble. If that doesn't help, try changing the Driver in the device section to the vesa driver instead of i810.

djgemz
15th May 2008, 05:46 PM
Getting somewhere so far the only problem I found with this using vesa:


(WW) VESA(0): Unable to estimate virtual size


which I'm researching on this now and will report back after this, seems that vesa worked thus far, but the sizing isn't working right. Anyhow I'm a read up later about it, it's only my daughter's work station :P and she can live without it for a day (I hope till the drama kicks in.)

djgemz
15th May 2008, 07:49 PM
Fixed.

Removed all of KDE and Gnome

Backed up the xorg.conf to xorg.conf.old

installed all KDE and Gnome again using groupinstall via yum

went ahead and did a clean reboot and all is fixed. Guess there was something conflicting, anyhow all is well.

MrGroover
16th May 2008, 09:41 PM
Did you restore the xorg.conf file or did you start X without the file? For me, X server starts sucessfully if I either enable the intel modesetting driver or simply don't use a xorg.conf file. Selecting the i810 driver causes the start of the X server to fail. I also tried reinstalling the Gnome and KDE packages, but it didn't help.

djgemz
16th May 2008, 10:28 PM
No I didn't restore it at all. Seemed to work itself out...

cristianox
18th May 2008, 08:32 PM
Fixed.

Removed all of KDE and Gnome

Backed up the xorg.conf to xorg.conf.old

installed all KDE and Gnome again using groupinstall via yum

went ahead and did a clean reboot and all is fixed. Guess there was something conflicting, anyhow all is well.


I'm also facing problems using i810 driver after I changed from Fedora 8 to 9.
When I set the driver "intel", it works, but I only have the 1280x764 screen resolution.
When I set the driver as "i810" the X server doesn't start.
Are you with a working driver "i810" or "intel" after gnome and kde reinstall?
Thanks

djgemz
18th May 2008, 09:39 PM
make a backup copy of your conf file within /etc/ for x11 then remove the conf file, reboot the system and it should rebuild this for you automatically, try this and see if that works.


I'm also facing problems using i810 driver after I changed from Fedora 8 to 9.
When I set the driver "intel", it works, but I only have the 1280x764 screen resolution.
When I set the driver as "i810" the X server doesn't start.
Are you with a working driver "i810" or "intel" after gnome and kde reinstall?
Thanks

cristianox
19th May 2008, 06:04 PM
I did as it was told: removed the xorg.conf and restarted the system.
A new xorg.conf file was created but, again, with the "intel" driver.
I changed to "i810" but it didn't work. The x server couldn't start.
I also tried removind the xorg intel drivers and reinstalling them, but didn't work too.
I think an update will be lauched soon. By now, I'll go on using the experimental "intel" driver.

djgemz
19th May 2008, 06:37 PM
change the i810 to vesa and try that and see if this helps...

MrGroover
20th May 2008, 08:43 PM
I did as it was told: removed the xorg.conf and restarted the system.
A new xorg.conf file was created but, again, with the "intel" driver.
I changed to "i810" but it didn't work. The x server couldn't start.
I also tried removind the xorg intel drivers and reinstalling them, but didn't work too.
The i810 is currently not working at all. No matter what you try, X won't start. I also tried reinstalling Gnome and KDE, the driver package itself at least twice, manually edited the xorg.conf file, let system-config-display create the xorg.conf file, but nothing helped. The intel driver is at least showing a desktop and one can work with it. But nothing is as fluent as it was in F8 with the i810 driver. I get the best results if I don't use a xorg.conf file at all. For me, it wasn't re-created after renaming it and letting X decide, which settings it wanted to use.

JEO
21st May 2008, 01:00 AM
I looked at the contents of this xorg-x11-drv-i810-2.2.1-24.fc9.i386 package and the /usr/lib/xorg/modules/drivers/i810_drv.so is just a symbolic link pointing to intel_drv.so and also the man page for i810 seems to be linking to the man page for intel. So that explains why trying to use the i810 driver won't work. It wants to be called intel now.

diedo
21st May 2008, 02:33 AM
The same problem i have faced with the new fedora (9) i did goes and edit xorg.conf to versa and it work probably but the screen resolution is 800x600 i've installed f9 on my laptop Dell Inspiron 1300 with i915GM the resolution should be up to 1280x800 . but i did remove the f9 and reinstalled clean i formmated the root partition and resolution was 1280x800 that's good for me but there's another thing i don't how to small the icons and font it's looks like biggie more than i want :(


Thanx ... sorry my english it's not good but it's me :(

diedo
21st May 2008, 02:42 AM
sorry i forgetten my xorg file


# Xorg configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
# keyboard added by rhpxl
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "intel"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection

JEO
21st May 2008, 07:36 AM
If you are using gnome and you want to change the display resolution go to system, administration, display or start system-config-display in a terminal window. If you want to change the resolution for each user then go to system, preferences, hardware, screen resolution. If you want to change the font size scaling go to system, preferences, look and feel, appearance, fonts tab, details button, then type over the resolution in dots per inch, I usually type 96 on mine and hit close.

AltGrendel
21st May 2008, 05:22 PM
FYI:

Just for fun I tried djgemz's xorg.conf listed above and changed Driver "i810" to Driver "intel". It worked fine.