PDA

View Full Version : FC8 [NIS+NFS] automount cannot mount /home



Jaxom
15th May 2008, 05:56 AM
Hi,
We've been using NFS+NIS for some time now, the map files and shared directories are served by a CentOS computer and this configuration have worked successfully on various Linux distros including some past Fedora versions.

We've just installed Fedora Core 8 on a new computer and while NIS works OK for authentication, we have trouble with aumount which cannot mount /home.

All I got from autmount are theses three lines from /var/log/messages



May 15 11:12:09 <PCNAME> automount[1979]: mount_autofs_indirect: failed to read map for /home
May 15 11:12:09 <PCNAME> automount[1979]: handle_mounts: mount of /home failed!
May 15 11:12:09 <PCNAME> automount[1979]: master_do_mount: failed to startup mount


I can ypcat auto.home without trouble (and it displays the same content than on the other computers) and I can manually mount the NFS share into the local /home without trouble.

While searching the web, I've come to similar issues linked to NIS (or LDAP) and autmount but there was either no answer or their suggestions did not work for us. I tried several things like setting LOCALOPTIONS="udp" in /etc/sysconfig/autofs or even using a config file from a working client computer and then stopping and restarting the autofs daemon to no avail (still does not work and same errors in the log file).

Do you have any idea?

Thanks