PDA

View Full Version : Type Languages other than English



hin
15th May 2008, 03:57 AM
Sorry I guess I'm posting the right place.

I'd like to ask how to type other languages rather than english [for example Chinese/Japanese]

If it is possible, provide links whenever necessary.

Thank you very much.

Seve
15th May 2008, 04:08 AM
( Threads Merged )

Please don't double / cross post.

See the Posting Guidelines (http://www.fedoraforum.org/?view=guide)

Seve

hin
15th May 2008, 04:13 AM
( Threads Merged )

Please don't double / cross post.

See the Posting Guidelines (http://www.fedoraforum.org/?view=guide)

Seve

Thanks, Modified

Wayne
15th May 2008, 04:39 AM
Use the forum advanced search function and look for either Chinese or Japanese and my name. I have a UK English setup and can easily input Japanese when needed.

Wayne

woden
15th May 2008, 04:41 AM
Very simple. The easiest way to do it is to go System → Preferences → Devices → Keyboard; than choose 'layout', click on 'plus sign' to add a new layout. In a layout section pick 'Japan', in 'Variant' - those variant you want to use (kana or OADG). When I chose 'kana' variant it did not allow me to pick kanji, stick only to katakana.

Wayne
15th May 2008, 04:47 AM
Well, there's a bit more to it than that and it's not necessary to change the keyboard layout. If you add either Japanese or Chinese support scim-anthy gets installed and an icon appears in your Panel where you can select input method. I use my UK English keyboard just fine:

http://www.fedoraforum.org/forum/showthread.php?t=143651&highlight=japanese

Wayne

hin
15th May 2008, 05:49 AM
Very simple. The easiest way to do it is to go System → Preferences → Devices → Keyboard; than choose 'layout', click on 'plus sign' to add a new layout. In a layout section pick 'Japan', in 'Variant' - those variant you want to use (kana or OADG). When I chose 'kana' variant it did not allow me to pick kanji, stick only to katakana.

Is Internet connections necessary to do these steps?

[Cabling is one of my biggest problem ]

Sorry one more question,

From Wayne's link, he says Japanese fonts are a must to install, is this already built-in?
When I play some J-Pop in Rhymebox, some Japanese are perfectly shown but some chinese character has been "????" [Kanji I mean here]

woden
15th May 2008, 01:31 PM
It seems to me that Japanese and Chinese kanji belong to different fonts (it's obvious enough) though some of them look the same. When you install language support, it installs everything to display and type on chosen language, as well as check spelling and so on.
Japanese and Chinese and Arabic and whatever characters are displayed well by default (at least when Fedora have been installed from DVD, don't know 'bout Live media). Typing and spell-checking may require additional downloading.

Edit: the question marks in your id3tags could be the encoding issue. I have encountered this many times because we have three Cyrillic encodings as standard: CP1251, KOI8-R and mostly and widely used UTF8. And if you mount USB stick without specifically tell it to mount with option iocharset=UTF8 it displays all of the Russian characters as question marks. The same is going for CD disk drives and so on. So if you playing your media from a removable storage, you should check mount options. The id3tag itself may have wrong encoding which doesn't concern mount options and stuff, I mean there are a lot of reasons why it may happen.

Wayne
15th May 2008, 03:20 PM
Well, if you check the link I posted, it installs scim-anthy as well as Japanese (or Chinese fonts) It's also a good idea to install the MS Mincho and MS Gothic Japanese fonts as well as Meiryo and Arial Unicode MS. You should be well covered then.

Edit: These last couple of fonts are available with a bit of Googling...

Wayne

kujirasan
7th July 2008, 02:26 PM
Hope you know what you are talking about! I have installed the keyboard and the language but it only shows small squares and keeps on typing Latin.
To type Japanese I use this website
http://ajaxime.chasen.org/
But it is not as good having the computer running completely Japanese

scottro
7th July 2008, 09:49 PM
Did you view the links we gave last night?

If it's only typing squares, that means you don't have the fonts.

kujirasan
8th July 2008, 01:14 AM
Thanks for your information, the Brew Master and Scottro,
1.http://www.fedoraforum.org/forum/sh...hlight=japanese, this link is incorrect and does not work at all,
2.My key board does not type squares it types LATIN and my key board is JAPANESE , There Japanese Linuxes
like Vine and Berry which are red hat based, those two guys know what to do, but they don't reply to messages.
On this computer I also have Russian, and use a Russian Keyboard when needed, and these is no problem, I used the KDE's 18i to install few languages the only one that causes problem is Japanese, believe been there and done most of that!
Thank you very much for your relies, and I do sincerely appreciate it.

scottro
8th July 2008, 03:39 AM
I'm not sure how to do it with a Japanese keyboard layout. I only know how to make it work with a standard English keyboard.
I remember trying Berry at one point, and its default was for a Japanese keyboard layout, whereas Fedora's default is probably for the US English.

You might try playing with the keyboard layout settings in Gnome, but I'm afraid I can't be of much help with that.

Wayne
8th July 2008, 03:48 AM
I think I've read other posts regarding problems with KDE and Japanese input... I only use Gnome and it works fine.

Wayne