PDA

View Full Version : Failed to initialize TTM buffer manager



Consequence_9
15th May 2008, 12:56 AM
After updating to F9, compiz-fusion git gives me the white screen of death upon start up. DRI is enabled, however I get the same error as the guy in this (http://forums.fedoraforum.org/forum/showthread.php?t=187060&page=2&highlight=ttm+buffer+manager) thread.


[Dylan@localhost ~]$ uname -r
2.6.25-14.fc9.i686
[Dylan@localhost ~]$ glxinfo |grep direct
Failed to initialize TTM buffer manager. Falling back to classic.
direct rendering: Yes
[Dylan@localhost ~]$ cat /etc/X11/xorg.conf | grep Driver
Driver "kbd"
Driver "intel"

I tried to install the corresponding koji drivers suggested by leigh, but the installation failed (although they didn't work for the other guy with this problem when he installed them). Can anything be done?

Hobashira
17th May 2008, 09:06 PM
Same error for me on a Sony Laptop VGN-FS52B (+F9)

I have not found a proper solution to this :( , unless someone has an idea :rolleyes: .

Consequence_9
18th May 2008, 04:24 AM
Actually, I seem to have found a solution =D

The error went away after installing mesa-libGL & mesa-libGLU (along with corresponding -devel files) from the updates-testing repo.

unfortunately I still get the white screen of death when trying to start compiz-fusion =[

diedo
23rd May 2008, 08:47 PM
man i got the same problem and mesa libs are already installed what's going on ?

i can 't play my videos and most of compiz effects

meowdin
24th May 2008, 01:04 AM
Actually, I seem to have found a solution =D

The error went away after installing mesa-libGL & mesa-libGLU (along with corresponding -devel files) from the updates-testing repo.

unfortunately I still get the white screen of death when trying to start compiz-fusion =[


Hi, your problem might be caused by compiz-fusion cant run in direct rendering mode.

run as user

fusion-icon -n // which means no loadinf compiz yet

then right click on the fusion-icon select compiz option and tick the indirect rendering

thx for the solution on the TTM buffer thinny, gona give it a try

meowdin
24th May 2008, 01:52 AM
Actually, I seem to have found a solution =D

The error went away after installing mesa-libGL & mesa-libGLU (along with corresponding -devel files) from the updates-testing repo.

unfortunately I still get the white screen of death when trying to start compiz-fusion =[


HOLLYS**T! ITS SOLVED! I LUV U MAN!

This buffer thinny is affecting my google earth, never winter night and perhaps fire fox!

(ok not never winter night since it just crashed) , but realy thx for the info.


BTW, I think i have a good compiz thutorial on f9 from leigh here

: http://forums.fedoraforum.org/forum/showpost.php?p=894799

Hope it helps, as for video, not sure is that codec thinny?

http://www.my-guides.net/en/content/view/103/26/#video