PDA

View Full Version : GDM Face Browser in Fedora 9



skerb1
14th May 2008, 11:45 PM
It seems that the gdm face browser in Fedora 9 does not function properly. I set my user image in the System -> Preferences -> Personal -> About Me tool. This seems to have created a ~/.face file. This works nicely with the "User Switch Applet" in my toolbar as well as in my screensaver. However the unknown user image still shows up in the gdm face browser.

After I also noticed that the gdmsetup application has been removed due to a gdm rewrite. It seems there is no other tool for configuring the gdm (need to edit xml by hand?)...Anyhow I ended up trying to put the face image at /usr/share/pixmaps/faces/<username> and changed the mode to 0644. The gdm face browser still did not pick up the image properly.

Any help with this issue would be appreciated. It is not a big deal, but a nice little feature I would like to have. Thanks.

skerb1
15th May 2008, 10:51 PM
...bump...

msrinath80
15th May 2008, 11:03 PM
It seems that the gdm face browser in Fedora 9 does not function properly. I set my user image in the System -> Preferences -> Personal -> About Me tool. This seems to have created a ~/.face file. This works nicely with the "User Switch Applet" in my toolbar as well as in my screensaver. However the unknown user image still shows up in the gdm face browser.

After I also noticed that the gdmsetup application has been removed due to a gdm rewrite. It seems there is no other tool for configuring the gdm (need to edit xml by hand?)...Anyhow I ended up trying to put the face image at /usr/share/pixmaps/faces/<username> and changed the mode to 0644. The gdm face browser still did not pick up the image properly.

Any help with this issue would be appreciated. It is not a big deal, but a nice little feature I would like to have. Thanks.

I'll second that.

mlavalle
16th May 2008, 04:07 AM
I am also seeing the same behaviour, and have been searching for a fix. Curiously, my own account shows the proper icon in the face browser, but none of the other accounts. I tried creating a new one, just in case it was something that went bad in the upgrade, but the same behaviour occurs.

DCOH
17th May 2008, 02:06 AM
That does not work in the GDM of F9 yet. It seems to be one of the minor things not finished yet in F9, I seen mention that it is a work in progress to be updated later. Hope that may explain it.

juanfgs
17th May 2008, 02:53 AM
For some reason it does for me, but I have my old configuration of the face browser.

Oh, and I'm using one of the default faces (the cat).

CrystalCowboy
22nd May 2008, 02:20 PM
For some reason it does for me, but I have my old configuration of the face browser.

Oh, and I'm using one of the default faces (the cat).

Did you do a fresh install of F9, or did you update an older system? I'm guessing the latter.

perja
22nd May 2008, 09:17 PM
Bug report is here https://bugzilla.redhat.com/show_bug.cgi?id=447430

weitjong
8th June 2008, 04:56 PM
I had the same problem. While waiting for the permanent fix, instead of setting my home folder permission to 711 (or just 701), I solve the problem by only granting 'gdm' to access my home folder as follows:


$ setfacl -m g:gdm:x ~

To revert it, simply run:


$ setfacl -b ~