PDA

View Full Version : Problems Binding "Open a Terminal" to keyboard shortcut



jon3k
14th May 2008, 06:15 PM
I'm unable to bind "Open a Terminal" under System -> Preferences -> Personal -> Keyboard Shortcuts to any key combination. For example, I tried to bind windows key + t to run terminal (after adjusting the Windows key behavior under Hardware -> Keyboard appropriately) but it doesn't do anything when I press it. However, I can bind the same key combination to something else ("Run an Application" for example) and it works fine.

ivancat
14th May 2008, 07:36 PM
Yes, noticed that too

jon3k
14th May 2008, 08:14 PM
I filed a bugzilla report for this one, I'll let everyone know what I find out.

Filed at:
https://bugzilla.redhat.com/show_bug.cgi?id=446478

Please post there if you're also experiencing this problem.

ivancat
14th May 2008, 09:14 PM
maybe it's gnome's 2.20 bug, because I've checked that in gnome 2.22 and it worked well

jon3k
14th May 2008, 10:43 PM
thanks ivancat

scottro
15th May 2008, 12:49 AM
I've always found that in gnome, you can't mix the Windows key with anything. Everytime I used their gui to try some keyboard combo like Windows + r for terminal, it just shows the binding as Super_L.

Probably a Gnome bug, as was said. The combos work with fluxbox and openbox.

jon3k
15th May 2008, 03:10 PM
Scottro -

I'm able to map windows key + (X) to other shortcuts, just not "Open A Terminal". The problem you're describing can be solved by:

Ssystem ->Preferences -> Hardware -> Keyboard

Click "Layout Options" tab

Under the "Alt/Win" section choose "Meta is mapped to win keys"

scottro
16th May 2008, 12:19 AM
Ah, handy to know. It enabled m to do Windows+Alt plus a few things.

Thank you very much. Despite my fears in our PM conversation, the Alt key also worked.

Thanks very much. I don't use Gnome too often, but this is good to know.

Edit--by the way, I was also able to use it to open a terminal. (My usual fluxbox/openbox shortcut is Mod4 R.)

jon3k
16th May 2008, 03:33 PM
This is pretty interesting, if I disable "Desktop Effects" the keyboard shortcut works!

Deonis
28th May 2008, 01:31 AM
Hello ! I have a same problem, but with binding "HOME FOLDER" with any shortcuts ....nothing helps even gconf. Shortcut is set but it does not works. As for terminal shortcut I have been able to set it correctly with gconf /apps/metacity/global-keybindigs. Any IDEA?!

Deonis
28th May 2008, 01:33 AM
I forget to tell. I am using Fedora 9 with last updates.