PDA

View Full Version : rm not deleting fedora 8 ( Solved )



tyront
14th May 2008, 07:59 AM
I am trying to backup my home directory to move to fedora 9 (Currently on fedora 8)

I already have a backup home directory and decided to remove it but when I tried I found that certain folders where not being removed.

command used rm -rf home(non active home)

I have moved in to the problem directory and tred again and I got this

rm -rf monkey/
rm: cannot remove directory `monkey/': Directory not empty

and then I used ls and it waited a long time and displayed this

ls
ls: cannot access MultiMailer.c: No such file or directory
MultiMailer.c

any help with this matter would be greatly appropriated

kind regards
tyront

savage
14th May 2008, 09:03 AM
I would unmount it and run fsck, if it's part of the root filesystem, you'll need to boot into single user mode, add -s to your kernel params in grub (press E at the menu).

tyront
14th May 2008, 01:58 PM
got rid of the problem by formatting and installing fedora 9

thanks for your help

kind regards
tyront

Jamwa
14th May 2008, 02:29 PM
you would have also forced a check on the hard disk on reboot by doing

su
shutdown now -rF