PDA

View Full Version : Strange Permissions on a CIFS mount



herr.schnegg
10th May 2008, 06:50 PM
Hello there

I'm relatively new to Fedora (using Fedora Core 8), used Ubuntu before.

I have a Samba server on the network, and under Ubuntu i've mounted that one using smbmount, which is not available in Fedora.

I read that I should use CIFS instead, so I've successfully mounted my fileserver by using:

mount -t cifs -o user=herrschnegg,password=schneckenhaus //10.0.0.200/share /mnt/fileserver

That worked!

But the permissions are horrible. I have no access to anywhere, but I should and using Nautilus (smb:// thing) I am able to write and read.

So on the server side I've created a test folder and chmod'ed it to 777. Then, on the client, I created a file there. But after I've created it, I can't access, or delete it anymore.

Permissions of the new created file are (on server side):

-rw-rw---- 1 herrschnegg users 0 2008-05-10 19:31

Does anyone have an idea what's going wrong?

bbfuller
10th May 2008, 07:26 PM
Hello herr.schnegg

Welcome to the forum.

Possibly you've already done this, but although you have mentioned Linux users, have you created the equivalent samba users and assigned then permissions to the share.

If you look in the tool:


system-config-samba

you will see the ability to create samba users and assign them permissions to shares.

the configuration tool can be installed if you haven't already got it with:


yum install system-config-samba

herr.schnegg
10th May 2008, 08:04 PM
Hi

Thank you. But this is not what I want. The server is set up correctly to my knowledge. I am able to connect to it via smb:// in nautilus, and I was also able to work this way for two years on the ubuntu box.

But CIFS does not work. I can mount it, but it does not seem to read/set permissions correctly.

bbfuller
10th May 2008, 10:23 PM
One more try then, I assume you are aware that Ubuntu numbers its users differently to Fedora?

If I create a "bbfuller" user in Fedora he is user id 500. If I create a "bbfuller" user id in Ubuntu he is 1000. When I integrate my ubuntu machine into my samba network I have to be careful to insist on creating a "bbfuller" user with an id of 500.

That can create all sorts of access problems as of course Linux uses the numbers not the names for its authorisation.

ebelog
11th May 2008, 08:08 AM
A file system mounted with cifs pays more attention to Windows security than smb did. What OS does the share //10.0.0.200/share live on? When you set it up, did you check the box which says "Allow network users to change my files"?

What happens when you connect to the share using the credentials herrschnegg/schneckenhaus from a Windows workstation? Do you have permissions problems then?

In my experience, if you have trouble with permissions and access to files in a Windows share mounted with cifs, the problem is more likely with the sharing and security settings in Windows rather than a problem on the Linux side.