View Full Version : Samba f9

1st May 2008, 10:57 AM
Has anyone successfully made samba work in f9? I have now managed to let the network see the shares on the f9 and even access them. I stll am unable to access the shares on these machines from the f9 box. I have disabled the firewall and set selinux to permissive for this testing but am a loss to work out what is happening. The samba log has thrown up
[2008/05/01 09:49:15, 0] auth/token_util.c:create_builtin_administrators(247)
create_builtin_administrators: Failed to create Administrators
[2008/05/01 09:49:15, 0] auth/token_util.c:create_builtin_users(213)
create_builtin_users: Failed to create Users
In messages i get
May 1 10:52:50 LINSERVER kernel: gvfsd-smb-brows[9733]: segfault at 0 ip 5fa91d8 sp 40d0b000 error 6 in libnss_wins.so.2[5f72000+152000]
googled but cannot find any reference to this at all.
Any ideas?

1st May 2008, 11:35 AM
Hello Anniedog

I've just tried samba on my f9 to confirm what I remembered.

Using the code:

mount -t cifs // /mnt -o username=bbfuller

Assuming that the boxroom samba share is created as:


enables me to access a share on the f9, machine.

Are you able to get that far?

The other difference here is that I've disabled SELinux not just set it to permissive.

There's a command for SELinux:

setsebool -P samba_enable_home_dirs=1

that needs to be specifically implemented to enable sharing off a home directory and may be blocking access even in permissive?

1st May 2008, 11:50 AM
I am getting no problem with sharing out files from the f9. I am just not able to access the network shares on other machines from the f9. If I remember I had this problem with f7 but for the life of me have no idea what I did. i have been checking back on my old f7 setup text file I kept as reference but I must have omiited this. I am unable to access the network printer on a vista box, as f9 will see all the other boxes but will not access them at all. Just throws up that wired error of segment fault in messages.

1st May 2008, 11:54 AM
Hello Anniedog

Sorry, misread that. I've also accessed my shares on other machines from the f9 box in the same way.

1st May 2008, 12:14 PM
Ok so I will play a little in the terminal a little later. i should have said that I am using nautilus in gnome. I have also tried gnome commander and have been playing around with the desktop options as much as i can. I have not really tried command line as the other machines are all ip addressed by dhcp. Just being too lazy I suppose to access the routing table.. The one difference I see in f9 as against the f8 is that I do not see the network icon in computer at all. I have enabled network servers on the desktop and that is the way I am able to see the other machines but no access to them, it will access its own shares here ok. Anyway if you are able to access the shares it must be an error on my machine and not a general bug, that is a little more comforting to know. Going to give it a break now but if anyone has anymore please post will get back later.
BTW I have just disabled SElinux no change same error in messages no change..

2nd May 2008, 09:32 AM

I have played around and I can mount shares on the network on the f9, using the command line. I just cannot seem to find out what is causing me not to be able to browse the network from the f9 desktop (gnome/nautilus). I suppose so long as I can access the shares from the f9 , it is not too much of a problem.
Once mounted I am able to browse ok. Just cannot work out what the problem is with the gnome desktop here. I am just so used to opening up the network and browsing that way. As I have machines joining and leaving the network all the time, it is going to be a pain if automount of smb shares is not going to function. But as this is preview I can only hope the final release will be ok.

2nd May 2008, 10:14 AM
Hello Anniedog

One of the features of KDE is that Konqueror in F8 has an address bar across the top like a web browser. One of the tricks you can play with it is to type:


where local is the name of my workgroup, and see all of the connected machines listed and access shares from there. I can do that still with my F9 shares from an F8 box.

Not time to try it from Gnome at the moment, I'll take a look later.

I make a small change to one of the configuration files to allow me to access my machines by name rather than ip address which makes the mounting of devices from the command line less problematic. It works fine as long as all the linux boxes are running full samba. It won't work from the F9 box to the rest of the network yet, but works from the network to the F9 box.

Can't make network browsing work from KDE F9 back to the network yet either, I'd assumed that was just a KDE thing.

Lot of rough edges still in F9 I'm afraid.

2nd May 2008, 10:44 AM
There was a thread on the fedora-testing list about this. I didn't follow it closely, but I believe that at least one or two people found that the latest upgrades fixed it for them. (It's a thread in April if you want to look through their archives.)

2nd May 2008, 12:53 PM
Strange while I was playing away from the forum I just installed KDE to give it a try. There is something wrong as I cannot even see samba f9 share there. The config for samba kde just fails to open. So I will stay with gnome.

I have all the updates installed so from scottro I am not hopeful but will spend sometime there. The real point I suppose is if this is a bug I should file it, but I have no idea what is failing. Samba will mount, so that I assume is not the problem. If it was a nautilus problem then I should not have the same problem with gnome commander. Just cannot boil down what I should look for. I have spent time comparing my working f8 against the f9 especially the /etc directory , autosamba etc , I have been trying to boil down exactly where the mount point for samba is in f9 . If I use connect to server from in places, I will get the shares mounted in computer, but I do not see any other mount point in /media or /mnt or anywhere under /. Obviously I can mount from terminal where I want. I actually had two directories mounted one in each for each method. I just do not know what controls the browse of network samba shares in gnome. May it will be some silly permissions on a file but I get the same running as root , so more likely an execute permission somewhere.

7th May 2008, 03:59 PM
There is a bug with samba when nsswitch.conf has wins in it.
Just have to wait to test out.

15th May 2008, 05:23 PM
I had my office machine mounting all my network shares on the workplace domain in FC1,2,3,4,5,6,7, and 8. The same /etc/fstab file that worked in FC8 won't allow me to mount my shares anymore since I upgraded to FC9. Something is messed up....plus I never liked cifs anyway. Wish we could go back to smbfs.

Edit: Apparently with FC9 I've determined that mount.cifs isn't reading the credentials file anymore. credentials is a 2-line file of the format:


My fstab file includes a line like this (which used to work):

\\servername\sharename /mnt/sharename cifs credentials=/home/foo/.filename,uid=500,gid=500,users,defaults 0 0

I am able to mount my network shares if I explicitly enter username and password in the mount options like this:

//servername/sharename /mnt/sharename cifs user=foo,domain=domainname,pass=barr,uid=500,gid=5 00,users,defaults 0 0

But the it seems samba/cifs in FC9 has brain farted its ability to utilize credentials files.

Anyone else having this problem?


15th May 2008, 06:38 PM
Found the answer on another forum. It is definitely a bug in the mount.cifs that comes with FC9:


The fix worked for me.

Good luck.

23rd May 2008, 08:25 AM
Not sure with have the same problem here. You seem to be wanting to mount a fixed share via fstab and cifs. My problem just relates to f9 not allowing me to browse the windows boxes on the network. It looks as if I could use this method to mount the shares ( I have no problem mounting them manually from command line) but as there are several windows machines on the network and with dhcp assigning the ip addresses this would be a lot of hassle which I do not have with f8, so I will continue to wait for the bug fix to make its way in f9.

Just for interest I have been away for a couple of weeks so missed the release. i have now downloaded and burnt a new x86 64 f9 dvd. As I intend to reinstall f9 to give myself a clean slate to work on shortly, however out of interest i have updated the current f9 it only had 2 updates that were required for this period!. My f8 update had loads of updates about 120mb which would be normal. As I am concerned about the samba side of f9.

I would be pleased if someone could confirm that this lack of updates on f9 is correct. I have checked that the fedora f9 base and updates repos are active (plus livna) and had disabled the testing repos some time ago, so this f9 should be current. As I really would like to get my f9 samba problem sorted before I do the clean sweep, this just seems a little strange to me.


Not to worry found the 552 !!! updates the rawhide repo was disabled. My mistake yet again.

27th May 2008, 09:06 PM
Just want to add to the list of woes on SAMBA and F9. I can't get it to mount any directory. This worked great for me on F7 and F8. I can ssh to the box so networking is ok on it. Both samba AND ftp (via vsftpd) don't work I get network not found issues. I turned off both firewall and SELinux (disabled) Still no luck. From what I can tell the port is in listening mode

tcp 0 0 :::32965 :::* LISTEN 500 14829 3007/httpd
tcp 0 0 :::139 :::* LISTEN 0 20286 3623/smbd
tcp 0 0 :::22 :::* LISTEN 0 5615 2409/sshd
tcp 0 0 :::445 :::* LISTEN 0 20284 3623/smbd

Curious why the :::* for the local address ? is this ipv6? I thought I turned IPV6 off. Should there be an entry for IPV4 interface too? :confused: If so how do I go about "fixing" ?

Anyone come by an solutions?

27th May 2008, 10:11 PM
I think, I just got it to work. Even though I had firewall off it seems not until I stopped the iptables daemon did it start working. arhg Is iptables just used for firewall ?

27th May 2008, 10:36 PM
You have to be careful to at least log in and log out after a change to network configs. I have had in the past where after a restart of the box would things only work (networked printers normally). Glad to know you seem to be getting there. I have joined another thread you might be interested in I have a 25% functioning f9 samba details on it and I am just still awaiting the bug fix to sort out the other 75%. That is my evaluation as I need to be able to access network shares from this box. Others may find my details suite their needs.


If you run imto my problem above of network browsing please join the bug

https://bugzilla.redhat.com/show_bug.cgi?id=445116 it may help if more people join it.

28th May 2008, 04:59 PM
Right I have the work around. I have reserved ip addresses for a couple of machines and added them to the /etc/hosts file. LINSERVER localhost.localdomain localhost
::1 localhost6.localdomain6 localhost6 LINSERVER (THIS IS THE F9 BOX) MARYANNE ADAM-LAPTOP

I can now browse these machines. I just ignore the authentication window and hit connect the only problem I can see is that the folders are then actually mounted in computer when I click on one. But at least this now gives me a temp fix until browsing is fixed.

31st May 2008, 11:29 AM

Samba browse problem in desktop has now been fixed on x86_64 with the latest samba updates(r1 14). I can now see and access networked machines in nautilus. I had just manged to get hold of the samba soucre and was going to teach myself a bit of programming when the x86_64 update with bug fix turned up. Now to see about the network printer!!

31st May 2008, 03:31 PM
Great, thanks for the info!
I wonder if they fixed their 'password length' bug too?