PDA

View Full Version : HELP! Cirrus Logic Sound Problems in FC2



Picomp314
5th July 2004, 09:05 AM
I have been working on my friend's computer for several nights now, to no avail. He has a Hercules Game Theater XP, based on the CS46xx chipset. It took me awhile to get this working back with FC1, but It finally did. Now with FC2 I have tried to recompiled the kernel three times trying different variations with no success.

the output of rpm -qa | grep alsa:
alsa-lib-1.0.3a-2
alsa-utils-1.0.3-1

lspci:
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 735 Host (rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS85C503/5513 (LPC Bridge)00:02.1 SMBus: Silicon Integrated Systems [SiS]: Unknown device 0016
00:02.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.3 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 07)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev d0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller (rev a0)
00:03.0 Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet (rev 90)
00:0b.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24 [CrystalClear SoundFusion Audio Accelerator] (rev 01)
00:0f.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 46)
00:11.0 Unknown mass storage controller: Promise Technology, Inc. 20268 (rev 02)00:13.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
00:13.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 50)
00:13.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 51)
01:00.0 VGA compatible controller: nVidia Corporation NV25 [GeForce4 Ti 4600] (rev a3)

I have tried both compiling in support for alsa and the respective driver, and compiling it as modules. I have turned up the volume in alsamixer so many times, this is driving me nuts. I have loaded the appropriate modules with modprobe.

lsmod:
Module Size Used by
snd_seq_oss 30912 0
snd_pcm_oss 49192 0
snd_mixer_oss 17600 3 snd_pcm_oss
nvidia 4816532 12
snd_seq_midi 6496 0
snd_seq_midi_event 5952 2 snd_seq_oss,snd_seq_midi
snd_seq 47888 5 snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_cs46xx 79336 3
snd_rawmidi 19876 2 snd_seq_midi,snd_cs46xx
snd_seq_device 6792 4 snd_seq_oss,snd_seq_midi,snd_seq,snd_rawmidi
snd_pcm 80328 2 snd_pcm_oss,snd_cs46xx
snd_timer 20356 2 snd_seq,snd_pcm
snd_ac97_codec 64004 1 snd_cs46xx
snd 43300 14 snd_seq_oss,snd_pcm_oss,snd_mixer_oss,snd_seq_midi ,snd_seq_midi_event,snd_seq,snd_cs46xx,snd_rawmidi ,snd_seq_device,snd_pcm,snd_timer,snd_ac97_codec
soundcore 6816 3 snd
snd_page_alloc 9032 2 snd_cs46xx,snd_pcm
gameport 3520 1 snd_cs46xx
sunrpc 127396 1
sis900 16132 0
usbhid 29632 0
ohci_hcd 14980 0
uhci_hcd 27728 0
ehci_hcd 24132 0

Perhaps there is something wrong with the driver in kernel 2.6.6 and 2.6.7 because when i started using the 2.6 series is when the problems began.

Thanks for any help in advance

Picomp314
10th July 2004, 09:06 AM
yeah... so far absolutely no help, but with some research i managed to find out that alsa version 1.04 has a problem with this particular driver, the mixers for the digital outputs are not shown in alsamixer, i am waiting for the new kernel (2.6.8) to be released, which will hopefully have alsa 1.05, which will hopefully have the problem fixed

Picomp314
11th July 2004, 03:10 AM
ok that fixed it,
I patched kernel-2.6.7 with the latest Alsa kernel patch (v1.05) recompiled; and the the volume controls that were missing in alsamixer have now reappeared; i haven't actually tested the stereo system yet, i will report back if they do

Picomp314
11th July 2004, 09:19 AM
Indeed the sound does work beautifully through digital output now
thanks for all your help... (yep...)
hopefully this conversation with myself will help someone solve their problems

imdeemvp
11th July 2004, 09:41 AM
hey pico.....i am happy to see you can answer your own threads.....and dude about the icon stealing stuff.....i am stil LOL....( i just hope they dont still mine now) :mad:

Picomp314
11th July 2004, 09:47 AM
its really frustrating... that icon was taken from a website that made icons originally, but i have customized it enough so now it is mine

i did some various checks to see if they were *exactly* the same thing
md5sum:
95f6e679a9c1c0df39c2493f925baf25 stolen.gif
95f6e679a9c1c0df39c2493f925baf25 original.gif
that shows me that every byte in the entire file is in the exact same spot... hmmmmmmm... i wonder

i opened both files with vi to look at the metadata imprinted by gimp
they were both the same

cyborg submitted the icon under the exact same name that i had originally redhat-icon50.gif