PDA

View Full Version : Cluster issue / question



scottincham
21st April 2008, 06:01 PM
Hi guys hope you can help with an issue I'm having setting up Redhat Cluster Suite. I think its a small issue but I've not been able to spot it.

I have three servers which at present are configured in a simple working cluster. Attached to each server is a SAN device, which is at present configured with ext2 filesystem. We plan to put GFS (Global Filesystem) on this SAN and share it across the three clustered nodes.

The setup is:

[root@wbproc01 ~]# clustat
Member Status: Quorate

Member Name ID Status
------ ---- ---- ------
wbproc01m 1 Online, Local
wbproc02m 2 Online
wbproc03m 3 Online

[root@wbproc02 ~]# cman_tool status
Version: 6.0.1
Config Version: 20
Cluster Name: Linux Nodes
Cluster Id: 55205
Cluster Member: Yes
Cluster Generation: 156
Membership state: Cluster-Member
Nodes: 3
Expected votes: 3
Total votes: 3
Quorum: 2
Active subsystems: 5
Flags:
Ports Bound: 0
Node name: wbproc02m
Node ID: 2
Multicast addresses: 23******5
Node addresses: 17*****1


I have started fenced on each node, with (at present) a manual fencing setup - just to see if I can get it up and running/working.

The next stage, according to the guidelines from redhat (http://sources.redhat.com/cluster/doc/usage.txt) is to start the 'clvmd' demon on each node, before building the GFS filesystem (I've updated lvm.conf as required).

When I run the clvmd command on the nodes, I get this error:

[root@wbproc01 ~]# clvmd
clvmd could not connect to cluster manager
Consult syslog for more information

In the messages/syslog:

Apr 21 17:41:06 wbproc01 kernel: dlm: no local IP address has been set
Apr 21 17:41:06 wbproc01 kernel: dlm: cannot start dlm lowcomms -12
Apr 21 17:41:06 wbproc01 clvmd: Unable to create lockspace for CLVM: Cannot allocate memory

This is obviously where I'm going wrong - I suspect its related to the bold'ed text. I've been playing around for a while and have not worked out if my error is in the cluster.conf file or elsewhere.

Anyone have any tips or pointers?

All the best,
Cheers, scott.


The system stats are (cluster suite installed is the default suite from redhat):

Linux wbproc01.*****.*** 2.6.18-8.el5 #1 SMP Fri Jan 26 14:15:21 EST 2007 i686 i686 i386 GNU/Linux

Cluster.conf:

<?xml version="1.0"?>
<cluster name="Linux Nodes" config_version="20">
<cman/>
<clusternodes>

<clusternode name="wbproc01m" votes="1" nodeid="1" ipaddr="17xxxx0">
<fence>
<method name="single">
<device name="human" nodename="wbproc01m" ipaddr="17xxxx0"/>
</method>
</fence>
</clusternode>


<clusternode name="wbproc02m" votes="1" nodeid="2" ipaddr="17xxxx1">
<fence>
<method name="single">
<device name="human" nodename="wbproc02m" ipaddr="17xxxx1"/>
</method>
</fence>
</clusternode>


<clusternode name="wbproc03m" votes="1" nodeid="3" ipaddr="17xxxx2">
<fence>
<method name="single">
<device name="human" nodename="wbproc03m" ipaddr="17xxxx2"/>
</method>
</fence>
</clusternode>

</clusternodes>

<fencedevices>
<fencedevice name="human" agent="fence_manual"/>
</fencedevices>

</cluster>