PDA

View Full Version : Problem installing emacs



Magnar
20th April 2008, 08:03 PM
I have a weird problem. I had previously installed emacs from source, but that was because I didn't know I should use yum, and now I wanted to install it using yum so I would get the latest version etc. I tried erasing the previous install (using "make uninstall" stuff). Then I did

yum install emacs
and it said it was already installed. So I did

yum remove emacs
and then

yum install emacs
Now I get the following error when trying to run emacs (I included the install output):

[root@localhost ~]# which emacs
/usr/bin/which: no emacs in (/usr/kerberos/sbin:/usr/kerberos/bin:/usr/lib/ccache:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin)
[root@localhost ~]# yum install emacs
Loading "priorities" plugin
48 packages excluded due to repository priority protections
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package emacs.i386 0:22.1-8.fc8 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Installing:
emacs i386 22.1-8.fc8 updates 1.9 M

Transaction Summary
================================================== ===========================
Install 1 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 1.9 M
Is this ok [y/N]: y
Downloading Packages:
(1/1): emacs-22.1-8.fc8.i 100% |=========================| 1.9 MB 00:04
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Installing: emacs ######################### [1/1]

Installed: emacs.i386 0:22.1-8.fc8
Complete!
[root@localhost ~]# emacs
Warning: arch-independent data dir (/usr/share/emacs/22.1/etc/) does not exist.
Warning: Lisp directory `/usr/share/emacs/22.1/site-lisp' does not exist.
Warning: Lisp directory `/usr/share/emacs/22.1/lisp' does not exist.
Warning: Lisp directory `/usr/share/emacs/22.1/leim' does not exist.
Cannot open load file: term/x-win

sidebrnz
20th April 2008, 10:07 PM
Why not do it the easy why? Go to Add/Remove Software, select Editors, check emacs and tell it to Apply. Yes, it's just a front-end for yum, but it will find all the dependencies and fill them, and I'm guessing that's part of the issue here because emacs is largely written in Lisp, and it might not be installed. (Using yum on its own should have caught that, BTW.) If that doesn't work, use it to install Lisp, then try emacs again.

Magnar
20th April 2008, 10:28 PM
I tried using the Add/Remove software interface. Emacs was already checked, but I checked some additional emacs packages. Still having the same problem, though. Any suggestions are welcome.

sidebrnz
20th April 2008, 10:40 PM
OK, that might be the result of what you've already done via yum. Try this: uncheck everything emacs related, apply, then reinstall. To quote Baron Fronkenshtien, "It just might work!"

Magnar
21st April 2008, 05:23 PM
Thanks. It works now. I had to search for emacs in the Add/Remove software program, because apparently there was a package emacs-common that wasn't removed when I did "yum remove emacs". Thank you for your help!